Cannot select HDMI audio after January 2016 update for Vero 1

After the january update I get no audio from the Vero. Happens more often after an update, the audiosettings are often a mess after updating. Now the output changed to SPdif instead of HDMI. Since I don’t use SPdif I get no sound. But the menu item is greyed out, I cannot select HDMI. So, okay, “normal behaviour”, just reboot…, but no, still greyed out.
On a sidenote, my Apple TV with the updated OSMC is also unusable now, how are the updates being checked, is there any quality control?

What’s that?

Would need to see a log for Vero. Re AppleTV, you are probably afflicted by the fsck bug (caused by improper shutdowns) which prevents the AppleTV kernel from updating. We have taken steps to ‘recover’ from these shutdowns, but you’ll need to upgrade first. I have posted fixes for this in the AppleTV category and this has been confirmed as working by a few users

Sam

What resolution and refresh rate are you set to ? Not all resolutions and refresh rates support HDMI audio. In particular make sure you are not on 59Hz, and please post a proper debug log.

I’d be willing to bet that your problem is like many others, who seem to unsafely power cycle their ATV’s and thereby end up with a uncleanly mounted Read Only /boot parition.
Having a RO boot parition will obviously cause all sorts of issues with updates.

Can’t see how people not cleanly unmounting their HFS+ drives are a fault of the underlying OS ?

The Dev team has made some changes to try recover from people not doing so, but the ultimate cure to the HFS partition being RO, is to always shutdown the ATV cleanly to the system halt stage, before powering it off.

I myself had my partition end up read only. Likely when the local power company changed our meter outside while I was sleeping. I had to fsck the partition manually so the update would complete correctly.

As has been repeatedly said on the forums:

To get a better understanding of the problem you are experiencing we need more information from you. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ for advice on how to help us.

EDIT: Sorry, I just fully read Sam’s post. didn’t realize I was repeating info.

My Vero runs at 720p and 50Hz. Audio just worked before (only after updates the problems I described before) and now not any more.

About the Apple TV, I never turn it of, never. I am glad I have not upgrade my CrystalBuntu Apple TV so far, which is working like a charm for years in a row. I had the problem other people had with the Apple TV after the update, all the commands Sam gave to fix the problem did not work, it is in a loop with a sad face, now the power is off of it.

Well, Sam, this is a customer being very annoyed after all the problems with the Vero. In the last update there were also things pushed by Linux which you didnot know about which caused the Vero to fault. You said (if I remember it correctly) that this would not happen again, but as I now see it it did happen again.

Logs: http://paste.osmc.io/iyewijakip

Problem is I cannot select the HDMI audio output device.

The last update has had no changes to HDMI code, Kodi, libCEC or userland libs. You will also see that there aren’t any other reports of this on the forum. I’m happy to help, but I don’t think this is a lack of quality control on our end. It is impossible for us to emulate every different AVR and TV combination, but a search around the forum will show you this is not just not widespread, but also not yet reported by anyone else.

They didn’t cause the Vero to fault. They caused you to need to manually input a choice to the updater. This was caused by installing a third party package. We have no control over how / when these are upgraded. If you want a set it and forget it experience, then you would ideally want to make fewer customisations. There are 40,000+ packages in Debian. It would not be our fault for example, if the Apache2 package received an update that changed site configurations and meant changes needed to be made. With that said, we’ve done our best to make sure that these prompts are kept to a minimum now.

If the Samba issue has occurred again we will investigate that. Can you provide a log for that too?

Please try @DBMandrake’s suggestion of changing the resolution. Please also upload the contents of uEnv.txt.

All users that followed by few commands eventually got things working again. If things don’t work for you, then you need to say more than ‘did not work’, and you should post in the AppleTV section.

Hi Sam, I know because I always check the forum first. But it has happened here, as you can see on the screenshot, and I don’t know what to do about it. Is the log being of use to you?

To me, as a customer, it is a fault. It doesn’t matter to me where the fault came from, I just wish to update the Vero and get on with it, using it as a mediacenter. If you can’t control all the updates being pushed to the Vero, well, that is what I mean with quality control. Remember, I am just a user, with a little knowledge of ICT but no knowledge of Linux.

No, it is no Samba issue. It is just that it isn’t working again as expected after an update. I have uploaded a log in the previous post, that does not include uEnv.txt? How do I upload that file, and where to? Changing the resolution did not make any difference.

Well, I just wanted a full reinstall with OSMC but it did not work, see the other thread about hanging HDD-installs. It is now running OpenELEC, just to try it out, and so far it is good. It also does DVD playback, which OSMC on Apple TV did not do very good. I cannot get back to that issue now but will if I revert to OSMC.

It does not show anything obvious to me

But you are not running it as a mediacenter, you are running it as a server, and customising it as such. If you were just running it as a mediacenter, you wouldn’t have experienced the issue. Your analogy is a false equivalency. If you add an aftermarket exhaust to your car, and it damages the engine, is it the car manufacturer’s fault? Could you say:

Without a log, I have no way of fixing that. Sorry. I have sent my CrystalHD rebase for Jarvis to chewitt, I believe he will use that code for OpenELEC 6.x. So if the issue appears then, you will know why.

You can upload uEnv.txt (it’s a one line file) from /boot. You can get this file by putting the SD card in your PC.

‘Changing the resolution’ doesn’t give me much to go on. What did you change it to? Have you tried changing the refresh rate?

Sam

I don’t see how I am running it as a server? I have only the standard add-on from your own store, samba, so I could upload and check files easily, just for maintenance. Like I now need the uEnv.txt file. I can switch samba off if that pleases you…

I tried all others. Some did not work at all (like 1080i and 1080p), but he ones that did work did not unlock the audio output menu item. I also changed the refresh to 60Hz, and I have restarted it many times, no difference. I don’t have a cardreader so I cannot do anything with the SD-card in the Vero.

The uEnv.txt is as follows:

mmcargs=setenv bootargs console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 rootwait quiet video=mxcfb0:dev=hdmi,1280x720M@50,if=RGB24,bpp=32 dmfc=3 consoleblank=0 loglevel=2 osmcdev=vero

If I remember correctly you have 720p TV / projector?

Try

sudo apt-get install --reinstall vero-image-4.1.12-11-osmc
sudo reboot

If it works, I will need to see:

sudo -s
printf "$(echo \0$(find /sys -name edid -exec cat {} +|sed 
's/\0x/\\x/g') | sed 's/\ //g' | sed 's/\0//' )" |tr -d ' ' >  /boot/edid.bin

This will create a file called edid.bin on your FAT partition. Your display device may be doing something funny.

Thanks Sam! This miraculously brought the sound alive! What is it exactly that you want to see now?

Running

will create a file called edid.bin in the same place you found uEnv.txt

Email me this file to sam@osmc.tv and I will take an in-depth look

Sam

Off topic, but has the 23.97 Hz option disappeard with january update? Anyone?

@sam_nazarko, have you taken your in-depth look at the edid.bin file?

Your EDID didn’t yield anything abnormal

I’ll send it to mk01 to have a look as well.

Are you still seeing issues with Kodi Jarvis?

Sam

Ahum, well, after the latest update just now…, I can say I have the EXACT same problem as the man who started this topic…, me.

So I cannot select my HDMI Audio output device, so I have no sound, so I cannot use the Vero.

If I do “sudo apt-get install --reinstall vero-image-4.1.12-11-osmc” will it revert to an older image?

Checked the EDID again, and the display isn’t advertising any audio capabilities. In recent updates we moved from providing default audio output settings to reading the EDID for a more accurate summary of the device’s capabilities. Sometimes the TV or AVR manufacturers get things wrong.

There is a fairly simple solution however. We can generate you an EDID and use that which will override the original one.

What audio options do you want to use? And what capabilities do you want to report (7.1 etc)

You can also try the old kernel which reverts to the old behaviour. I suggested this a few weeks ago, so I will need to refresh my notes to remember the exact details of the issue here

Sam

When installing a fresh copy of osmc on my Vero 2, I’m experiencing The same issue. I had this before when I first booted my new Vero Device, but I was able to fix it using the older distro using the previous methode of Reading the EDID data (as mentioned above).

Being unable to update the older distro for some reason, I installed a fresh copy today and the audio over HDMI problems are back (even after updating OSMC to the latest stable Version).

My guess is that OSMC does not detect my Denon X1100 HDMI capabilities correctly, thus providing me with analog and spdif output options only.

Surely there must be a way to use the latest OSMC distro with audio over HDMI in combination with my Denon. Perhaps there is way to bypass the New detection methode? Or another way to force the HDMI audio output option?

Edit: perhaps you could generate me a EDID file with most common capabilities? I Have AC3, DTS, 7.1 channels and True HD support from the top of my head. Thanks!

Edit 2: my edid.bin file: Dropbox - File Deleted