Can't connect to Samba shares in my network anymore

I switched to a new router recently (Asus with Asuswrt-Merlin) and all of a sudden I can’t connect to the HDD that’s connected to the router. It woked flawlessly before.
If I clicke on Windows network (SMB) all I get are 2 dots (…)

I have no issue connecting to this smb share (the HDD) via my Linux PC (fstab) just he Vero can’t connect to the Network it seems.
Any idea what I might be missing …

Try change the Samba version under Settings -> Services.


v1 worked although the router software says it also supports v2.

Maybe the router is not up to date.

it’s completely new with latest firmware on it

it says

Updated Samba version (3.6), with SMB2.0 support


I’d recommend changing the Samba protocol version on the asus to SMBv2 only and selecting that version under services on kodi, as it is more secure than v1. Hopefully asus-merlin will support v3 soon.

Thanks Tom.

I know that this topic is about Samba shares, but may I ask why you’re sticking with Samba? I am running Merlin (xwrt on R7000) but opted for NFS export for the USB drive I have plugged into the router. It is supposed to provide better speed.

A bit offtopic here, but I’m curious how you are running firmware for a Asus router on a Netgear Nighhawk? I have a R7000, and would love to upgrade the firmware on it to opensource.

I’ve read somewhere that Merlin isn’t keen on having this ported to Netgear.

That didn’t answer my question about how you say you have it running on a R7000?

Are you able to see the link above?

http:**About | Xwrt-Vortex. (remove ** with //)

Yes I saw that. That site is a mess of confusing links to other sites. The installation instructions are specific for Asus routers.

As much as I’d like to get opensource on my R7000, I think I’ll pass on that one.

Not that I’m trying to convince you or anything, but the download page has the R7000 links.

Here’s a quick Google search on installation instructions from

Thanks for that link. I’ll have to really think about this. I’d love to have my R7000 be able to share files using NFS and run a MySQL database…

The R7000 USB3 port is in the front when there are perfectly good USB2 ports in the back. I can be quite particular and this drives me nuts that I have to plug in my hard drive in the front. That being said, I’ve been running NFS export for a few months now with very minimal issues, probably all contributed to the learning curve of NFS export options.

guys. thanks for all the input. I moved from SMB to NFS. I just wonder why I have to set the router NFSV2. otherwise the 4k wouldn’t mount the shares

Did you use fstab or Kodi to mount? fstab should use V4 by default.

on osmc I tried to mount via the GUI (add source).

To correct you, OSMC is the distribution, Kodi is the software you are using, so you should say:

On Kodi I tried to mount…

Anyhow, if you had to force V2 then the server is running V2. Unless you are allowing access from the outside world to your network over the internet, I would not worry about having V2 vs V4 on a home network.