Can't finish installation - hangs on license?

1st time OSMC user, just dl-ed ‘OSMC_TGT_rbp2_20160303.img’ for my Pi3 and try to install.

Installation asks for language, timezone etc. and then scrolls the license … and that’s it. Whatever i do, wait patiently, press Ok/enter on ‘accept’ or whatever, it just keeps on scrolling … ?!

I’m probably missing something, but what ??

Already solved : [SOLVED] Pi 3 Stuck on Licence Agreement Screen - #23 by sam_nazarko

Its not a issue with the Pi 3 I have the same issue on the Pi 2 with Kodi 16.
The way I resolved this was to plug in an ethernet cable so kodi could see the internet, then licence walkthrough worked.

I did try running the following command but it didn’t work for me.
To get to the command line you will need a USB Keyboard
press the crtl key then osmc will boot to the command line
sudo touch /walkthrough completed, then reboot.

I have just got my Pi 3 so going to upgrading my system soon. I have few osmc boxes dotted around the house so I hope the performance is going to be good as I want to upgrade them all

also looking to reduced cost of ownership, say good bye to having to purchase wifi dongles!