[SOLVED] Pi 3 Stuck on Licence Agreement Screen

Wireless worked as well on RPi3 as long as there is only the buildin Wifi used for connection and no other Wifi-Dongle or else in use.

But how can it be connected to WiFi since you haven’t yet got to the settings where you can set up the connection?

You can preconfigure it in the installer before you write it to the SD Card, can’t you?

May he used the Image and not the Installer?

Oh, maybe. I just flashed the image manually, not via OSMC Installer/NOOBS.

Would any one be willing to recreate the error and the upload the kodi.log so that the team can figure out what is going wrong

Just run into this issue…

Whilst it was at the Licence screen scrolling forever stage, I plugged in an ethernet cable (no change, the Continue button still did nothing), but I hadn’t restarted at this point.

I didn’t do anything other than press ‘S’ on the keyboard to bring up the OSMC menu, then selected ‘Exit’ which caused my RPi3 to reboot.

When it came back up I’m at the OSMC screen ready to go.

I SSH’d to it and confirmed the ‘walkthrough_completed’ file was there, but evidently it must’ve done that itself!

After a crash course in SSH I’ve managed to get to the contents of the kodi.log for you. This is after deleting the walkthrough_completed file and rebooting with no network connection, going through the setup to the point of hitting continue on the licence screen (where nothing happens). I then plugged it into the network and pulled the log, without hitting continue or anything on the UI.

Hope this helps.

Thanks a lot. I think I have a fix but will wait for @karnage to confirm.


Hello, good evening
I have the same problem with new OSMC (20160303 usb.img) on latest Apple tv1.
After install everything ok until license screen… " I try hitting “Continue” but nothing happens. Like others,
I thought I might just need to wait for it to scroll all the way through the licence, so I did, until it looped back round, still can’t Continue."
Thank you

I install OSMC image 2016.02-2 RPi2 when I press Continue not happened

Issue is definitely present on the pi zero, just trying to install, same symptoms

Only got single power supply cable and one usb cable, have tried using usb keyboard when pi boots to get a console session but it doesn’t seem to recognise the keyboard and continues to boot, tried removing the SD card an putting it in my laptop and copying the “walkthrough_completed” file from a raspberry pi 2, same problem, it just hangs at the “continue” prompt, am at a loss now as I dont have another keyboard I can try and I cant get shell access as it wont work with the external wireless plugged in.

Any suggestions?

New, fixed images will be released shortly

Is it worth me trying to bodge it or should I just sit tight? watching tv on my laptop at the min lololol :wink:

If you can SSH into the box, simply touch /walkthrough_completed and reboot.

Its a pi zero, cant get wifi to connect and theres no lan adapter on the zero :confused:

If you can put the sdcard in another linux machine, touch the file in the root of the ext4 partition.

Tried that too, am running Kali on a laptop and put the sd card in the reader, mounted the filesystem, created the file, unmounted the card, put it back in the pi zero, re-booted and it just went straight back to language selection, as mentioned in my previous post even tried copying the file from one card that works in a pi2 mounted on my laptop to a SD card from the pi zero also mounted on my laptop, same thing again, straight back to the language selection, Think I’m probably just better off waiting for the image to be updated tbh, it’s not a big issue :slight_smile:

You must have touched the wrong file. Remember when you mount the SD card in another machine’s no longer /walkthrough_completed you want to create, but walkthrough_completed under the mount directory…

I copied the file from the exact location of a known working install, basically the root partition, should I be looking elsewhere?