[SOLVED] Pi 3 Stuck on Licence Agreement Screen

Using the latest image for Pi 3 (2016.02-2 OSMC_TGT_rbp2_20160303) and it boots (yay!) and I get so far through the setup, selecting language, timezone etc, and on the final screen with the scrolling licence agreement text, I try hitting ‘Continue’ but nothing happens. I thought I might just need to wait for it to scroll all the way through the licence, so I did, until it looped back round, still can’t Continue.

Anyone else having this issue?

Edit: Seems to work fine as long as you are connected to internet via wired connection (weird).

If that doesn’t fix it, SSH onto it and:

sudo touch /walkthrough_completed

Thanks to DBMandrake for that solution.

Yes I had it.

Unplug your Wif-Dongle and try it again, solv it for me

The Pi3 doesn’t have a WiFi-Dongle.
It’s built-in.

I have also struck same issue.
Stuck at License page in Setup.
Continue does nothing.

Put SD into Pi2 and then get past the License.
Put SD back into Pi3 after setup complete. OK

I know, sorry I haven’t say I had an external pugged in

CC @Karnage

As a workaround you can skip the walkthrough by logging in with SSH and running:


This should boot directly into Kodi without the walkthrough. You will need to manually configure your language/timezone settings in Kodi's Settings screen and your network settings in My OSMC.

I tried but there was no network connection may a conflict between the Wifi-Cards and nothing goes

You would need to plug in via Ethernet temporarily to use SSH.

An alternative would be to plug in a USB keyboard, then during boot as soon as you see the blue OSMC splash screen hold down CTRL on your keyboard until the screen goes black with a login prompt - this will bring you to a login prompt where you can login at the console and run the above command.

You might need to turn off overscan on your TV to see the login prompt as it’s in the top left corner - you should have overscan disabled anyway for best picture quality.

Also confirmed the same fault using a Raspberry Pi A+ and the RPi1 version of OSMC.

I think the issue may be when there is no internet access…
That shouldn’t be a requirement however, so does seem like a bug?

All I have plugged into the A+ is a keyboard…

Feature suggestion: Maybe the setup add-on needs some EXIT button in case faults like this arise in the add-on in future??

Update: Seems to work fine if you go through the wizard while plugged in via Ethernet.

Thanks for the help guys, really appreciate the quick response.


I just confirmed this as well on the Pi 3.

No Ethernet. Can’t complete wizard.
Plug in Ethernet and reset and wizard completes fine.

Yes it’s a bug.

Nice idea, except this particular bug would also cause the exit button to fail to work as well.

Wireless worked as well on RPi3 as long as there is only the buildin Wifi used for connection and no other Wifi-Dongle or else in use.

But how can it be connected to WiFi since you haven’t yet got to the settings where you can set up the connection?

You can preconfigure it in the installer before you write it to the SD Card, can’t you?

May he used the Image and not the Installer?

Oh, maybe. I just flashed the image manually, not via OSMC Installer/NOOBS.

Would any one be willing to recreate the error and the upload the kodi.log so that the team can figure out what is going wrong

Just run into this issue…

Whilst it was at the Licence screen scrolling forever stage, I plugged in an ethernet cable (no change, the Continue button still did nothing), but I hadn’t restarted at this point.

I didn’t do anything other than press ‘S’ on the keyboard to bring up the OSMC menu, then selected ‘Exit’ which caused my RPi3 to reboot.

When it came back up I’m at the OSMC screen ready to go.

I SSH’d to it and confirmed the ‘walkthrough_completed’ file was there, but evidently it must’ve done that itself!