Can't get through a movie

I have 3 vero devices. Two 4k and one 4k+. Ever since I have updated to the testing branch I can’t get through a movie. This log is for one of my vero4k’s. Can someone take a look and tell me what is going on? It’s not a network issue. It’s definitely a vero issue. If I use my backup device which is an intel mini pc the movies play fine (blu ray mkv and 3d blu ray mkv’s even though this examnple is 4k). I’m about ready to reinstall osmc and start from scratch. While watching the movie from this log the frames look off slightly. There is some slight judder like its skipping a frame. It can be 5 minutes in or 20 minutes in but eventually the screen will go black and the word buffer appears and then it fails and goes back to kodi.

The first thing to try is to fix this:

Adjust display refresh rate: Off

You should set it to On Start/stop.

Thanks but that’s not it. Set it back to on start/stop and it failed 2 minutes into the movie again just now. Black screen and buffering and back out to kodi

I don’t see anything else obvious in the logs. Have you tried rebooting the file server?

I had a similar problem a few weeks ago. One movie would play, the next one would buffering. Rebooting the server would fix the problem, sometimes for a few days, sometimes only for hours. It turned out to be a failing hard drive, and replacing the drive fixed the issue.

It took me a little while to track down the problem because if I tried playing the movies on my Linux Mint system they would play.

Actually happened to just reboot it a little while ago today. Nothing in the logs of the server about read errors or anything. How else can you tell if there is a drive issue? Intel mini pc plays everything fine.

Without knowing anything about your server (OS, etc) it’s impossible to say. Do you have more than one drive connected? If so, are the problem files all on a single drive? How is the drive formatted?

Have you tried doing an iperf3 test from the Vero to the server to verify the network?

Its a big library with multiple drives with one volume on a Synology using shr raid. It’s an 1812+ so it is aging. Never did iperf. What is the easierst way to do that?

I think I should use the Arch Linux 64 for the Synology right but how do I install it properly? SSH into synology and go where to install it?

I don’t know anything about the Synology, so I can’t help there.

But here is a good test you can try, use dd to ‘copy’ the file to the Vero. That will test the network and the drive performance.

dd if=/mnt/movies/BlacKkKlansman\ \[4K\]/BlacKkKlansman.atmos.4k.mkv of=/dev/null status=progress

(Run this from the Vero. It will take some time to complete) Of you can choose a smaller file to test with. I just used that as an example.

Figured out iperf3. There was a synology package. Think everything looks fine?

I would run a longer test then 10 seconds since your problem takes a while to manifest. Try adding -t 600 (for a 10 minute test) or -t 1200 for 20 minutes.

You ran that test from Vero 4K right (not a + model)?

Yeah that looks fine (for a 100 Mbit) connection.
What is the bitrate of the movie you are trying to play?
Also have you tried to play a movie that played fine in the past but gives issues now?

@bmillham yes a 4k not a 4k+. ok i’ll run a longer test

@fzinken It’s every movie. Doesn’t matter which one.

Ok, maybe try the dd copy test that @bmillham suggested.
But overall sounds quite strange. Maybe try temporary SMB instead of NFS.
Or try to play the Movie from USB Stick

Ok. I want to get off the testing branch for this device. How to go back from 4.9 kernel. That’s when all my issues started.

I doubt that the testing 4.9 kernel is your problem as I was using it (until I started early testing of Buster) and never had any network issues with my 4K (non +). We need to get to the root of your problem.

10 minute test done and was fine. Consistent 94 .1mbits/sec all the way through

So the next thing would be a dd test. That will test not only the network, but the drive performance.

You should also be able to run the dd test locally on the Synology I’d think.

ok. what line of code can i try directly from the synology from ssh?