Can't play mp4 files

Can’t play mp4 files
All the logs are here:

Can you try copying the file and playing it locally (e.g. from sdcard or usb stick).
That will confirm if there is a problem with the file or a networking problem (probably a SMB permissions issue).

Its playing other files in the same folder

Apparently the “SD” logo is not showing, but its appearing very slow and then they do play

Ok SD logo showed up for 3 files but not the rest

mp4 is a container format which could include all kinds of codecs. Suggest you give the output of mediainfo for that file.

sudo apt-get update
sudo apt-get install mediainfo
mediainfo <path/filename>

Please try playing the file locally. If it still fails to play, then a sample file that fails to play would be useful.
Ideally cut down to a couple of minutes and upload to a hosting site (e.g. dropbox or google drive).

I have almost the same problem, I can play a .MOV file locally, but when I go to play a m4v file, the audio visual appears, and everything is then silent. I don’t have any codecs, and am planning to get them, will the codecs help with this problem?

@rajanp as we have explained in the other thread, m4v is a container and doesn’t say anything about the codec used.
Check the MediaInfo
It would be good if we could find out more about the file you are having issues playing. Please see this Wiki resource for further help

If the m4v file came from iTunes it will have DRM (encryption) and won’t be playable (on any non-Apple player).

That link is broken. I understand that m4v is the container, and I looked at media info already. I don’t know what media info does. I gave googled it, but come across nothing much, except for install guides.

Is there a way to convert this? What about cloud converter?

Check the mediainfo section in How to submit a useful support request - General - OSMC

I have the issue with my osmc player as well, found it quite annoying as most of the torrent files available to download are in mp4 format. I am getting a black screen with no audio when i try to play the mp4 files. All the other files play perfectly. Have tried searching everywhere to find the root cause and a solution with not much luck till now.

Anyone has a solution for this yet ?

MP4 is a container format so you would need to check what’s inside.
It would be good if we could find out more about the file you are having issues playing. Please see the mediainfo section in How to submit a useful support request - General - OSMC


Thanks for the response and sorry for my late response.

Please see the media info output link below

I am getting a black screen with nothing on it and no audio as well.

I am trying to play this from an external HDD from which all the other formats play well (avi, divx).

This file should be playable. Does it play back on e.g. your PC?
Can you try to copy it on the SD Card and play from there?
Can you upload debug enabled logs when you play it?
Can you upload a short sample of it for us to try?

I just tried playing it on my PC , via samba share and it plays fine.

The monitor that I am using for osmc is a HD ready one (720p x 640p at 60Hz ) is that the issue then ? or is it any particular settings that I need to tweak ?

I am trying to upload the log but the system is getting crashed (this happens a lot after the latest upgrade). I will try an get the log some time today.

Thanks for the fast(est) response though. :slight_smile:

That is an issue that should not happen, is your powersupply OK? SD Card OK? Any unsupported Addons or overclocking?

yes, Power supply is a belkin 5v 2A one. and I have a externally powered USB HDD connected to it.

Overclocked - yes

unsupported addons - yes one unsupported video addon (which i installed from an custom repo)

But I was using all the above before the update as well with confluence skin with no issues (but just the playback issue from the original OP).