Can't see the nas

I use mount with a fstab. All was working some times ago.
But now, I don’t see anything.
I used putty to connect to the Vero, and this is the output of the command ‘mount’
systemd-1 on /mnt/films type autofs (rw,relatime,fd=48,pgrp=1,timeout=0,minproto=5,maxproto=5,direct,pipe_ino=13470)

And this the line in fstab : /mnt/films nfs ro,noauto,x-systemd.automount 0 0

I also did this :
osmc@osmc:~$ showmount -e
clnt_create: RPC: Unable to receive

This is the log :
I also tried to reinstall, but it failed with the message : unable to mount bootfs. I tried the 2 usb ports.

Thanks for help

This indicates that your NAS doesn’t export any folders via NFS.

  1. Check that the IP of the NAS is correct
  2. Check the NFS Share settings on the NAS

I made the NAS IP static (
There is some progress :
osmc@osmc:~$ showmount -e
Export list for
osmc@osmc:~$ ping
PING ( 56 data bytes
64 bytes from seq=0 ttl=64 time=0.903 ms
64 bytes from seq=1 ttl=64 time=0.826 ms
64 bytes from seq=2 ttl=64 time=0.767 ms

But I don’t see any file mounted .
For information, the files are on a Synology NAS.

new logfile :

The export list is still empty.
Have you checked the NFS share configuration on the NAS? Can you share a screenshot?
Are you using this NFS Share on any other device?

What NAS is it?
I had a similar issue with QNAP after updating the firmware… it did something which messed up the nfs shares… had to roll back the FW and that fixed it…

In the logs the error is “access denied by server while mounting” and this could be a permission problem in the nfs config on the Synology as @fzinken now already claimed several times.
I cannot reach my Synology nas for the next 3 weeks but in the following link you see the menu where you configure the ip/ip range of the clients which should get access to a specific share: Unable to connect / access NAS anymore - #5 by JimKnopf

I finally could reinstall the box, after trying 3 usb sticks.
I can now access to the nas, why ??? I didn’t change anything in the nas, same nfs properties…

There are some things I don’t understand :
1- without fstab, I can see the file with nfs sharing (nfs:…)
2- with fstab, I can also see the file (/mnt/films…)
Is it better to use nfs or fstab ?

In the latter case, the command “mount” don’t show the files. BUT if I do a command “ls /mnt/films”,
and redo a command “mount”, now the files appears : on /mnt/films_2 type nfs4 (ro,relatime,vers=4.1,rsize=131072,wsize=131072,namlen=255,hard,proto=tcp,port=0,timeo=600,retrans=2,sec=sys,clientaddr=,local_lock=none,addr=

Well, Im certainly not a specialist, and Im happy that it works.
The nas is DS418 from Synology. with DSM 7.2 (latest).

Your using NFS in both instances. If your using a NFS path directly in Kodi then all the networking is done by Kodi itself and this is typically a bit slower than if you have the operating system handle that task by using a system mount. This extra speed is only of particular import if Kodi is not able to provide enough bandwidth for the size of file your playing though.