Can't set Media View to Wide

HI all, I tried to search for answer to my question but I did not find the proper one, I guess.

I have a Raspberry Pi 1 with OSMC updated right now to OSMC 2017.12-1 ( Kernel 4.9.29-13 ) and I can’t set Media View to “Wide” View.

I don’t know actually if it’s the right definition (I’m italian so my GUI is set on italian language), should be “WIde” or “Wall”…anyway, the one with which you see the thumbnails of Films etc… every folder I have is stock on List View. I can open the lateral option bar but the First option is “List” and can’t be change.

I have also a Vero 2 with same OS version and there I can choose between 3 or more type of Media View so…why it can’t be done on the Rpb ?

Hope you understood what my problem is and can help me to find a solution.

Thanks in advance, best regards.

Well, at least you should prepare some logs, so the folks here can have a first look for possible errors while boot causing this: How to submit a useful support request

Yes, sorry…here’s the log :

  • I activated logging
  • rebooted
  • went into Video-Files
  • shown the left option bar
  • click OK to change the view…nothing appened.

I would like to take a screenshot but now I can’t access via ssh anymore: it gives me an error . We’ll figure it out after…

I took some photo with the phone:

This is what I see on Rsp ( TV Samsung LE32C530F1W , FullHD)

This is the same folder on the Vero 2 ( TV LG 49LF590V, FullHD )

I don’t know why the left options bar is cropped, but that’s not a serious problem…
as you can see in the second photo on the Vero 2 the Media View is set to “Wall”, and I can see the Thumbnails, while on the Rpb (first photo) Media View is set to “Lista” (List) and can not be changed.

Here’s the screenshot of the SSH connection error:


Any suggestions? Thanks!

To fix the ssh problem, get the latest version of Putty.

Thank you @bmillham that fixed the ssh problem.
Any suggestion about the Media View?

Thank you again!

You should fix your screen calibration under Settings : System : Display and scroll down to Video Calibration to adjust Kodi to fit on your screen.

It does not look like you are using the Library, but instead are just browsing the files? I’m not sure if all the views are available this way.

Look the 2 pictures attached…that show the same media folder (\NAS\Video\Films) : the first picture is taken looking at the TV using the Rpi (inside the bedroom), the second one is taken in front of the TV where is connected the Vero2 (in the living room). On the Vero2 I can choose different type of “Media Views” and I choosed “Wall”…on the Rpi seems there is only one option “List”. I would like to use “Wall” on the Rpi too…OSMC System is on the same version on both …so why on the Rpi there is no the “Wall” option?

For the screen calibration there is no option too, I take another screenshot (I also changed the lang to English so you can read better):

Change Settings level to Expert.

So you are not using the Library on either device?

Uh! Ok! I didn’t see there was even Expert Level…I tought Advanced was the last. Ok…the screen now is fine.

Oooh my gosh…I think I got it…it seems every File Paths I created are not in the Library…I tried to add another source from zero adding it to the Library and on that source I can select “Wall” view…damn…I’m so stupid…sorry to boring you with my stupid problem… :frowning:

How can I add existing source to the LIbreary? Have I to recreate all from zero?

Do you mean existing source on your other system? A shared MySQL library would be the way to go.

If you just mean local, I’d just start over as there should be no watched status.

Nope…I have 4 “source” for Video files:

  • Series
  • Disney
  • Movies
  • Anime

If I go into one of them and try to update Library nothing appens.
I craete a new source “Test” which has same network path of “Movies” but I added it to Library after created It and inside Test I can update the LIbrary and see “Wall” media view.

Is there a way to add Series, Disney, Movies and Anime folder to Library?

Maybe with a shared MySQL Library as you suggest…but I can i build it?

You just add them as normal ‘Movie’ or ‘TV Shows’ sources. You can have more than one Movie or TV source.

Mmh…ok…let me try…I think I will make a fresh install and start everything from the base.

Thank you very much for you support @bmillham !

You shouldn’t need to do a fresh install. ssh in and:

$ sudo systemctl stop mediacenter
$ cd .kodi/userdata
$ mv sources.xml
$ sudo systemctl start mediacenter

And add your sources again.

can I edit sources.xml directly from ssh to create New Sources?

Yes you can, but… You still need to set the type of source (TV/Movie) in the gui as it’s not defined in the sources.xml. Here’s an example (from my system) with 4 different directories in a source names TV Shows:

        <name>TV Shows</name>
        <path pathversion="1">/media/SeaDevil/TV Shows/</path>
        <path pathversion="1">/media/Tardis/TV Shows/</path>
        <path pathversion="1">/media/Sonic/TV Shows/</path>
        <path pathversion="1">/media/Rutan/TV Shows/</path>

Before editing sources.xml, stop Kodi

$ sudo systemctl stop mediacenter

Once you restart Kodi, you can then change the content of the TV Shows source to TV Shows.

this is my sources on Vero 2
is it good? can I copy it to Rpi?

    <default pathversion="1"></default>
    <default pathversion="1"></default>
        <path pathversion="1">smb://ZYXELNAS/video/Anime/</path>
        <path pathversion="1">smb://ZYXELNAS/video/Film/</path>
        <path pathversion="1">smb://ZYXELNAS/video/Disney/</path>
        <path pathversion="1">smb://ZYXELNAS/video/SerieTV/</path>
        <path pathversion="1">smb://ZYXELNAS/CAM/NVR/</path>
    <default pathversion="1"></default>
        <path pathversion="1">smb://zyxelnas/music/</path>
    <default pathversion="1"></default>
        <path pathversion="1">smb://ZYXELNAS/DOC/photo/</path>
    <default pathversion="1"></default>

Sure, copy it over. Just remember to stop/start Kodi and change the contents of each source from the GUI.

and what about sharing the library from Vero to Rpi?