CEC, back button duplicates

hi guys
hope you don’t mind if I ask my question in your thread.
I use osmc on raspberry pi 3 and the tv (CEC) remote.
After updating everything works but the back button duplicates and it’s very annoying. The last good version where this didn’t happen is OSMC_TGT_rbp2_20161128.img
I have tried switching to openelec and raspbmc but the same thing. I would like to stay on osmc because I think is the fastest.
Any suggestions?
p.s. It’s a phlips tv (older model)

Hi, split your post from previous topic since that deals with missing kernel modules for IR receivers connected to the Pi.

You can adjust the repeat filter in CEC settings. As you are on such an old version previously it’s hard to compare what may have changed

tried that no change, was messing around with every timing setting there is…
on the default settings every button works only the back button duplicates… it’s getting on my last nerve now.
If i remap the “previous menu” in keymap editor to let’s say yellow button (i got an idea that maybe the back button has two actions map to it) it works at it should normal one press-> one step back but then the back button is dead it has no function at all. If I change it back here comes the double step.

Hi… i don’t know if i can attack my question to this reply but i try.

Recently i have need to buy a newest remote for my tv… i have a LG Smart TV (if need i put the correct model) but i have buyed not the original remote but a compatible.
I have buyed a Meliconi… specific this:
http://www.meliconi.com/it/prodotti/audiovideo/telecomandi/gumbody-personal-2/

This a very good alternative… but now sometime when i navigate on menu i obtain sometimes a duplicates events. Sometime it’s append whit the ok button… sometime whit the arrow button and other time whit back, exit etc etc.

My question it’s… i thinks also i can set somethigs to help to resolve this issue on cec config… for example raise an interval or similar.
What’s the exact value or what’s the exact value i need to check on cec preferences ?

Goto settings->system->input->peripherals->CEC adapter menu to the bottom

You can only manipulate these 3 settings for your purpose (which are finally are stored in a file at /home/osmc/.kodi/userdata/peripheral_data).

But it is up to you to find out what setting is the best for this remote control, see this thread as suggestion/motivation, only [SOLVED] Raspberry CEC - repeated inputs

Omg… i don’t have understand if i need to modified both… tha value on kodi and the xml files at same time.

For made some modification applyed i need to reboot osmc of simply exiting from this settings ?
If i do somethigs on xml ?
EDIT
You thinks what’s in my case need to raise ? The delay ? The repeat rate or the release time ?

I see my xml it’s say:

    <setting key="double_tap_timeout_ms" type="int" min="50" max="1000" step="50" value="300" label="38050" order="16" />
    <setting key="button_repeat_rate_ms" type="int" min="0" max="250" step="10" value="0" label="38051" order="17" />
    <setting key="button_release_delay_ms" type="int" min="0" max="500" step="50" value="0" label="38052" order="18" />

Problably same value it’s on kodi settings… i can check lately…

Sorry, corrected the path info.

Only try to change the settings in the GUI and confirm with OK. I’m not sure whether the changes are going active at once or you need to restart the mediacenter/the pi.

Perhaps, it’s worth a try to start with the values

but to find the correct values is up to you.

I have modified my xml right now but on kodi setting apparently the value it’s not changed.
On xml i have put right now the suggested value… 650… 250… and 0.
Now i try to do this also on kodi preferences… need to test how it’s the result.

EDIT
Problably i have understand how it’s works all 3 value:
The first it’s the delay applied when you maintain a button pressed… for example when you used the “down” arrow on a video list. It’s the delay for first scroll.

The seconds value it’s for “consecutive pressures” on a single buttons… i have right now set it at 100. Problably it’s my best solution for my issue.

The third value i din’t touch… it’s leave it at 0.

I have do this from kodi settings… i don’t have idea if i need also to do it on xml files.

EDIT 2
I have also test 200… 100… 0. Apparently it’s only need to raise the seconds value on my case and applyed a little delay here.

Just to confirm: What exact file did you change and is it now solved for you? Thx in advance

Now… i have edited this file:
/usr/share/kodi/system/peripherals.xml

When i modify this files on kodi settings apparently nothings it’s change.

I see right now upper here you have edited the path…
/home/osmc/.kodi/userdata/peripheral_data/
rpi_2708_1001.xml
I have this upper xml files… i have opened it and yes now the value it’s same on kodi and in xml editor on pc.

At this point i need only to found my best value knowing the default it’s 300 - 0 - 0.

The first files we can discard and ignore it ?

EDIT
Meantime it’s very strange because i have tryed to raise to maximum all value from kodi settings and nothigs it’s changed on xml files (opened by text editor on my pc).
It’s possible i need to restart osmc for all modified it’s be applied ?

DId some tests

  • you should only modify the values in the GUI

  • here the file /home/osmc/.kodi/userdata/peripheral_data/rpi_2708_1001_CEC_Adapter.xml is modified by that on my Pi3

  • for tests I changed the “repeat rate” from 0 to 50 … and yes, the speed of repeated pressed key buttons changed dramatically (proof that these values have an effect at all)

  • any change to these values requires a restart of the mediacenter (power -> exit)

1 Like