CEC not working

Debug logs here.

Vero 4K is connected directly to my Panasonic TX-42G20E TV (Old plasma, but CEC works with RPi3/OSMC and Chromecast Ultra)

For some reason I can’t get CEC to work at all. Have tried all the usual things to get it working such as unplugging the TV, rebooting the Vero and so on.

Tried another HDMI cable that I know is working, but still not working.

In Setting>System settings>Input Peripherals is grayed out .

Let me know if you need more info.


I will check this for you later today.



Hi Thomas,

Thank you for your patience and for reporting the issue. I can indeed confirm there was a problem with CEC on the Vero 4K. The good news is that this has now been resolved. It was a small issue that occurred when rebasing OSMC for Kodi Krypton (v17).

I’ve now fixed this and pushed this as an update. You should receive a notification shortly. If you want to get the update sooner you can check for updates under My OSMC -> Updater.

Thanks for supporting OSMC and thank you for reporting the issue. Please let me know if you have any further problems.




I can confirm that it is working now after the Software update.
Thank you for the quick fix


1 Like

I can’t get CEC working yet. I have the latest OSMC version (checked updates) but it’s not working. Also installed the keymap editor addon.
It’s working fine on OSMC on my pi3, but not on the Vera 4k.

Are you using the supplied HDMI cable?

There was a problem with CEC on the initial release. It’s since been updated. Are you sure you’re up to date? Some logs will let us see what’s wrong. Make sure you power cycled both TV and Vero 4K after updating.

Yes. But note that I have it connected to my soundbar and then another HDMI cable to the tv.
Again, pi3 and osmc is connected exactly the same, and that’s working fine.

Ok I will try that.

CEC is not working for me either :frowning: I did the update and power cycled the vero

Please upload a debug log
You may also need to power cycle your TV.

Try another HDMI cable, describe as much as possible about your setup etc.

I’m using the hdmi cable that came with the vero 4k? Is it a special hdmi cable that only works with cec?

I tried creating a new kodi.log file but nothing was getting written to it when I enabled debugging.

It is a cable that we know to work with CEC.

I switched cables and it worked after a power cycle of my tv.

I’ll try again later with the provided cable, to see if it was an issue with the cable.

Ok I fully restarted all devices (unplugged power cable) but still CEC is not working.
I uploaded all the log files but before I provide the link, can there be any sensitive information in the log files? Like passwords?

While generally the script tries to hide all passwords we know that certain people still are not comfortable with any information shared. If you are one of those first create the file locally, edit it and then upload it.

Glad to hear this is resolved.

Check the logs first. Also consider unplugging any attached peripherals apart from Vero 4K in case they are conflicting. CEC is a 1-wire bus.

Ok here it is: http://paste.osmc.io/wuqumabomi.coffee

I already detached the pi3 with osmc that I used in the past. I did that before restarting the tv and vera 4k.

That’s not a debug log, so not much is discernible there.

What happens when you run cec-client? Are you able to power the TV on / off?

Also try use the HDMI cable you use on the Pi 3 on the Vero 4K. It’s possible there’s a problem with your cable