CEC not working

Hi, I just got a new CEC compatible TV (Hisense h32a5800), but I can’t make it work with my Vero 4K.

I tried several workarounds like testing several Hdmi cables, unplug the TV and the Vero 4K for 10 minutes, and I even tried a clean install of Osmc, but nothing seems to work.

Here is my log file: http://paste.osmc.tv/orimaxawos

I don’t understand much of it, but there seems to be a problem with “hdmirx”?

Can somebody help me?

Is no key working or only some keys (like arrow keys).
Hisense gave already people in the past CEC issues.

I believe on my Hisense, CEC must be enabled in the TV settings menu for that particular HDMI port.

EDIT: Not sure if this will be relevant as my 65H8F uses Android 8.0 as OS.

No key works…

CEC is enabled on the TV, but the Vero doesn’t appear in the list of compatible peripherals

Do you have another hdmi cable you can try?

Already tried 3 different ones, including a brand new hdmi 2.0 one

Have you managed to get CEC working on another display to rule out a cabling issue?

Sadly, I don’t have another display to test CEC, but I tried 3 different Hdmi cables.

It looks like the CEC communication is not working:

2020-03-29 16:17:26.380 T:3931329248 DEBUG: CecLogMessage - << Recorder 1 (1) -> TV (0): POLL
2020-03-29 16:17:26.380 T:3931329248 DEBUG: CecLogMessage - << 10
2020-03-29 16:17:26.580 T:3931329248 WARNING: CecLogMessage - Write: write failed
2020-03-29 16:17:26.580 T:3931329248 DEBUG: CecLogMessage - << 10

Are there other devices connected to the TV?

Have you looked at the documentation on your model TV? All inputs may not provide CEC support.

At first there was a Chromecast Ultra (which is identified by the TV as CEC compatible) but I unplugged it to try to find the problem

There is no information on the TV documentation, but the Vero 4K is not even identified by the TV as a CEC device…

That’s because the Vero is failing to communicate with the TV

It is unclear why.

Obviously a bad time to do this but I would normally suggest to test on a TV at work or a friend’s. Although — I can’t envisage how this is an issue on the Vero side.

OK, I’ll see what I can do!

So, I managed to test on another TV (LG 32lh3000) with no more success. I tested again with 3 different HDMI cables, but the Vero 4K was never identified as a CEC device.

Here is the new log file: http://paste.osmc.tv/vafetozoce

Also, I don’t know if it’s usefull, but I discovered that when the Vero 4K is plugged, the chromecast disappear from the list of CEC devices

Try stop Kodi, and run cec-client

OK, I will need some help on how to do that. Is there a tutorial or something?

See https://osmc.tv/wiki/general/accessing-the-command-line/

I’m not sure I used the right command, but here is what I got: http://paste.osmc.tv/kapofupunu.coffee