CEC problem since April update

I have the oposite experience from this post CEC Problem solves since last update :-)

LG 55LB5800-TA

RPi 3B

My CEC worked fine in previous versions. Now it stops working after TV suspend. I have to switch inputs from & back to HDMI to activate Simplink.

Is there a setting or anything I can do to fix this?

Thanks for a great product.

Did you try powering everything off at the mains for 10 minutes?


Thanks for the super fast response!

I tried it now and the issue persists after powering back on. When I use the TV remote to suspend and wake up, CEC is disabled.

It has been like this for 2 days since the update.

Can I do anything to diagnose this? Worst case: Can I roll back to the previous version of OSMC?


The easiest way to roll back is to backup your settings and install 2017.03-1 release, which can be found on the download page.

Debugging logs showing the issue, would probably be useful in helping the fix issue, details for which can be found here

Component specific logging, for libcec will probably be quite helpful too. You find this is logging section on osmc aswell.

Thanks Tom.

I’m having the same issues. When my tv goes into standby CEC isn’t working. Only just started with the last update. I’ve a rpi2 and a Panasonic tv. It all worked fine before update!


Debug logs please, please see above.

Thanks Tom.

I’m having the same problem. I guess there’s no reason to have two differents topics.

I have this problem with a LG and RPI2.

Here is the log file:


HI Velho10,

Probably not related, but the only error I can see is:

ERROR: SQL: [Textures13.db] The database disk image is malformed

This is repeated quite a few times, through out the log.

Could be a space issue, whats the output of:


Also I would delete:


This is either corrupt or has filled up your sd card. It will regenerate on restart.

After you’ve done that see if you can reproduce the issue, it maybe worth turning on component specific logging for libcec; you’ll see this where you turned on debug logging on osmc.

Thanks Tom.

52% of disk usage, that’s the output of df command.

I deleted that, still happening.

I’ve activated debug logging for libcec, now what do i do?


====================== lircd.conf =================== kdgLUcwP
# V2
# Please make this file available to others
# by sending it to <lirc@bartelmus.de>
# this config file was automatically generated
# using lirc-0.9.0(default) on Sat Apr  4 14:50:06 2015
# contributed by phate1
# brand:Samsung
# model no. of remote control:BN59-01107A 
# devices being controlled by this remote:Samsung PS50C680

begin remote

  name Samsung BN59-01107A 


# this config file was manualy generated
# using lirc-0.8.6(samsung) on Mon Mar 14 23:08:51 2011
# contributed by ulf
# brand:                       Satelco (Samsung IrDA remote)
# model no. of remote control: RE49C
# devices being controlled by this remote: Satelco EasyWatch DVB-C
# Basically this should handle all remotes reporting as Samsung IrDA
# (0419:0001), but for now only the Satelco remote is tested.

begin remote

  name  Samsung

You seem to have a lircd configuration for a samsung remote. Is this an additional remote or is the LG remote picked up as a Samsung? Sorry I’ve not got a LG TV to check this on.

Thanks Tom.

Never changed that option, i guess it comes by default as a samsung remote.

Nope default it points to
====================== lircd.conf =================== kdgLUcwP
# Please make this file available to others
# by sending it to lirc@bartelmus.de
# this config file was automatically generated
# using lirc-0.9.0-pre1(default) on Thu Jan 8 11:26:07 2015
# contributed by Dilligaf
# brand: OSMC
# model no. of remote control:
# devices being controlled by this remote:

I’ve changed to “lircd-full” but still happening.

In April’s update post says:

  • Fix an issue with CEC which could cause an AVR to be repeatedly powered on
  • Fix an issue with CEC which could cause a TV to be powered on spuriously

Maybe is that “fix” that is causing the problem all of a sudden?


So you’ve made no changes to lircd.conf or made changes to remote config via MyOSMC?

Could you please try the following:

sudo mv /etc/lirc/lircd.conf /etc/lirc/lircd.bak
sudo cp /etc/lirc/osmc-remote-lircd.conf /etc/lirc/lircd.conf
sudo systemctl restart lircd_helper@*

Does your remote still work? If so please, please suspend/standby tv and turn back on and see if the remote is now working?

If this doesn’t resolve the issue to revert (I suspect it won’t, I just want to see if its a remote config issue.)

sudo rm /etc/lirc/lircd.conf
sudo mv /etc/lirc/lircd.bak /etc/lirc/lircd.conf
sudo systemctl restart lircd_helper@*

Thanks Tom.

Can you also confirm the model number of your lg tv?

Tried that with no avail. I always have to reconnect (simplink) the tv for hdmi-cec to work.

The TV is: LG 32LB56.


Apologies for delay, could only get to this now. Let me know if I did this wrong or need to add anything.

Here is the log: http://paste.osmc.tv/onizageyum.vhdl

Steps taken:

  1. Enabled debug logging plus component logging for libCEC
  2. Rebooted OSMC.
  3. Used remote with CEC.
  4. Used remote to switch TV into standby and then to wake up.
  5. Tried to use remote. It does not work since CEC not enabled.
  6. Switched TV input to re-initialise CEC.
  7. Used remote with CEC now working.
  8. Uploaded logs through OSMC.

Thanks very much!

Hi Carlmon,

Are you still able to produce any logs, showing this issue?

@Blinkz Could you also please provide logs?

Sorry we are no closing to resolving the issue. I’ve requested logs from Carlmon & Blinkz, as I’m hoping a comparison will shed more light. I’ve also flagged the issue to Sam. Will try and advise on a fix ASAP.

Thanks Tom.

1 Like

Hi Carlmon,

Apologizes missed your post, when I requested the logs. Will check these now.

Thanks Tom


Just to clarify, does changing the source and then changing back to pi, bring cec back. Or do you still have to reconfigure.

Thanks Tom.