CEC problem with Samsung TV

I am using OSMC on my RPi 3 with a Samsung Smart TV.

I’m controlling OSMC through the TV remote (CEC / Anynet+).

Everytime I turn of the TV (the Pi is still running) and the turn it back on, the remote doesn’t work with the Pi anymore.

Any help for this problem?

I had similar problem and as workaround I’ve disabled DLNA serwer on osmc.

What does the DLNA server has to do with the HDMI-CEC??

The same question I’ve asked to myself. But with disabled DLNA on osmc, problem with anynet+ was gone.

Ok… I’m trying this and the I will reply…

I have the same problem. The only way how to get CEC working after the TV is switched off and on is to restart RPi or go to TV’s settings and to search Anynet+ devices.

The strange thing is that it was working OK for months until few weeks ago.

I’ve had DLNA disabled already - this workaround couldn’t help me.

after you turn on the Samsung TV press ‘choose source’ on the remote then press the ‘RED’ button (refresh).

a bit bothersome, but works.

I also have a Samsung TV, and am experiencing the same problem, but with a Vero 2 box.

The remote works fine, until I power cycle the television, or switch sources. Rescanning for AnyNet+ devices gets things working again, but is obviously very much not partner-friendly. FWIW, the DLNA server is not enabled.

The problem also first appeared about a month ago (very roughly). Before that everything was running fine.

I have entered a new issue into issue tracker: CEC disconnects after switching channels or turning TV off and on (Samsung TV) since it is reproducible by multiple users.

You should read the Wiki before opening bug tracker issues.

I would need a log to see what the issue is. Further, I suspect some of you are using Kryton test builds which uses a newer version of libCEC and complicates things further.

i have seen the same problem with latest stable kodi 16. I think this problem was not there a couple of months ago but i do not own a samsung tv to be sure. But i really do not remember a problem like that.

Solutions i have found are.

Turn off cec from samsung menu and then back on. On a couple of tv’s this dod not work. I had to do the next one. On another samsung it does work.

Search for cec clients. OSMC will appear and when you choose it it does work until either you turn off the tv or change source.

If you change source to tv and try to change source to osmc via the cec you either get the no cec client found or you get the osmc but pressing on it gets you to the no cec client found (it does not say it like that in the tv screen.)

I think i will be infront of a samsung next week and i will be able to upload logs. full logs from kodi or is there anything else you need via cli?

I am not using test builds.

Sam, I’ve uploaded log files with steps description. See my comment at the issue you closed.

I also opened a thread to point the same issue with a Samsung Tv.
As far as i remember everything was working well few months before (around the month of April) with Build 16.xx
the issue occurred soon after i bought a soundbar so it was not easy to tell on which side was the problem.
And I also tried to use a direct HDMI connection between the RPI3 and Tv and I tried to use an earlier build of OSMC before the month April with no luck.
Furthermore, my Tv had numerous firmware updates which are not reversible.
The only way i found to manage this problem is to manually connect / disconnect by discovering new CEC devices when i switch from a source to another or simply turn off the RPI3 so Anynet+ will update with the current CEC devices in use.
So the main problem is that CEC is working until the source is switch to another one…

Since 1-2 months same issue/problem for me, with my Samsung ju6850. The interesting point is, seldom the anynet+ connection works after TV on/off or source changing, but mostly not. Sometimes it needs some time… eventually 15-30 minutes then the CeC suddenly works from alone. But the fastest way is to search again anynet and reconnect to “Kodi“… then the Cec works fine until the Tv was turn off or the Source was changed…

Eventually Samsung has changed something in his firmware (actual 1470), before this I think to remember the cec worked in a better way.

My feeling is the Samsung doesn’t remember on his anynet devices, after turn on/off or source changing or the automatically anynet connection is corrupted in some way…, but hard to say if it’s a Kodi or Samsung problem.

the tv cannot reestablish connection only with the osmc. cec keeps working fine to all other devices that are cec enabled and connected on the tv.

Someone should test to see if the behavior is the same with another Pi distro for Kodi.

It would be good to know if an earlier version worked, and if it does, which version that was. However, @Landspeeder seems to have this issue, and I’m guessing he’s using Kodi Krypton builds which are based on libCEC 4. This version will soon become the default when Kodi Krypton drops, so it would be good to fix it before then.

@sam_nazarko I can confirm this behavior on rpi2 (stable), RPI3 (beta) , v1 (stable) , and v2 (beta) with 2 different Samsung sets. This did not occur on builds before the V2’s first couple of early release updates (time frame). My sets are not hooked up to the network and as such are running shipping firmware.

Never bugged me enough to push as other more pressing functions where being worked on and no one else was talking about the issue.

The specific issue is that even if the source channel is on OSMC when powered on, I need to refresh the cec source using Samsung red button and wait 15 seconds or so then select osmc.

Hi Chris

When was this? There seems to be a consensus that things regressed after this month’s update. If it was prevalent before then, then try with the latest update and let me know if anything is further broken.

Currently travelling but if you can give me SSH to your device and leave the TV on I can poke around on my return. I’ll get in touch.


I suppose testing with other CEC devices attached may not be fair to Sam & Co… so I retested.

First I ensured the latest updates on stable (via my osmc update manual check)
And I ensured the latest updates on beta:
ssh osmc@
sudo apt-get update
sudo apt-get dist-upgrade

I have a SONY BD player hooked up to both monitors (for Amazon & netflix primarily). Removing this allows RPI2 (stable) and RPI3 (beta) to resume CEC control when the tv is power cycled and the source was previously OSMC… it takes about 10 seconds after the TV is displaying video before control begins. SO… to those on Stable… do you have any other CEC devices hooked up as well? Try unhooking them, unplug all devices for 10 minutes, plug back in and then test.

On RPI3 (beta) and V2 (beta) if I turn on the tv and the source was something other than OSMC when shutdown then I need to either press the ‘select source’ and then ‘refresh’ buttons which takes a total of about 15 seconds from pressing TV ‘power on’ - or – wait a good 30+ seconds after pressing ‘select source’ This is a little annoying but not something I am about to fret about.

(Side note → V2 (beta) is again forcing me to select OSMC skin at each reboot. Edit: blowing away advancedsettings.xml using rm allows osmc skin to persist between reboots)

An Amazon Fire TV does not appear to impact CEC behaviour on any device when also attached.

Reboots to OSMC requires a ‘refresh’ of CEC

Minor power dropouts (not enough to shutdown tv monitors or osmc) also requires a ‘refresh’. I live smack in the middle of 2 LARGE power switching stations, so these are fairly common (LED lights in the house give a quick flicker when this occurs.

@sam_nazarko you may certainly SSH in if it helps!

1 Like