CEC problem with Samsung TV

one of the tv’s i saw this had another cec device on it. I did not test if removing the other cec device resolves this somehow.

On the other samsung i had this problem i had only one hdmi on it and only the rasp pi3 on it. No hdmi amplifier or any other cec device.

I wont be able to go to that device till next week at least so it will take me some time to be able to provide logs.

I wrote a few days ago that I had a similar problem with a Vero 2. Unfortunately(?), I now can’t reproduce it, so this currently Works For Me.

No problem. I’m keeping an eye on this issue. I’m back home on Tuesday, and I’ll publish some test builds for the brave.

Thought I’d post here as I opened a similar thread here:

I also have a Samsung TV and moved from a Vero to Vero2 recently. Everything worked OK with the Vero but the Vero2 doesn’t seem to register as an Anynet+ device. CEC doesn’t work, the Vero2 doesn’t appear in the TV list of Anynet+ devices and while the Vero2 is running, CEC on the other devices appears to have some issues. e.g. I can’t get any sound from my tv through to my home theatre system while the Vero2 is connected.
Sam I sent you a message with a url to a log file upload as requested on the other thread.


The problem still persists on our 3 different Samsung TV’s.
Anybody has some good news?

yes, I’ve had to power down and disconnect my vero when I’m not using it. It seems that all Anynet devices share the same HDMI signal path and if one device misbehaves they all get a bit confused.

I’m sure there’ll be a Sam along with good news shortly. :slight_smile:

Is autowake AVR enabled in Kodi settings?
Does disabling this help resolve the issue?

Not sure if that was meant for me or Chain but not on my system. All the options in my Peripherals CEC adapter are set to None or Ignore.

Did you get chance to look at the log file I uploaded?

Yes I did. I think setting up CEC as a Recorder may solve your issue. I’m not sure if it’s related to the other posts here.

How do I do that Sam? I looked in the CEC settings and can’t see any option to set the device as a recorder.

I have explained that in the other thread just now.

Please stick to one thread or it can get a little confusing to keep track of everything

apologies I didn’t see your update in the other thread. I’ll try what you’ve suggested and update the correct thread with my findings.


Cool – I have some ideas but want to mull over them first.

I’ve updated the other thread with my mixed results.


1 Like

For my Samsung CEC problem with my pi3 I studied the Vero 2 problem from makk509 and used the following commands:

sudo systemctl stop mediacenter
sudo nano /usr/share/kodi/system/peripherals.xml
sudo nano /home/osmc/.kodi/userdata/peripheral_data/rpi_2708_1001.xml
sudo systemctl start mediacenter

in both xml’s I changed the device_type from 1 to 4

and in actual the CEC seems to function normally… TV turned On/Off/On with changing source and it does work…

I will observe and test the pi3 a little bit, but eventually this could be a solution. It’s worth a test for everyone with the same problem.

Excellent :grinning: glad my results weren’t just a fluke.

I’m really don’t know what happend over night, when TV was off. But absolutely the same problem appears to me again. TV off / Source changing and CEC Controls are gone and must reconnect manually again.

Doesn’t work for me :frowning:

In the same way I tested again with device_type 1,2,3 and 4, but with no positive results.

The only interesting change on device_type 4 was that after an reboot of the pi3 the cec/anynet magically was connected with my samsung tv, but source changing or TV turn off/on leads to immediately disconnection of Anynet and needs again manual interaction.

It’s really a tricky problem. But I feel that the solution isn’t so far… the question is, what variable/trigger is to change in the right way, to get the former comfort with automatic Anynet connection.

I have Vero2 and Samsung TV.
When I power-cycle the TV, then I need to select source for the Vero2 again.
Also the button for the context-menu on my TV remote doesn’t work with Vero2.
(it worked fine with Rasp Pi with OSMC on the same TV).

Otherwise, everything fine with Vero2 and my Samsung TV.

Best regards,