CEC problem with Samsung TV

Hi Chris

When was this? There seems to be a consensus that things regressed after this month’s update. If it was prevalent before then, then try with the latest update and let me know if anything is further broken.

Currently travelling but if you can give me SSH to your device and leave the TV on I can poke around on my return. I’ll get in touch.

Sam

I suppose testing with other CEC devices attached may not be fair to Sam & Co… so I retested.

First I ensured the latest updates on stable (via my osmc update manual check)
And I ensured the latest updates on beta:
ssh osmc@192.168.1.131
sudo apt-get update
sudo apt-get dist-upgrade
reboot

I have a SONY BD player hooked up to both monitors (for Amazon & netflix primarily). Removing this allows RPI2 (stable) and RPI3 (beta) to resume CEC control when the tv is power cycled and the source was previously OSMC… it takes about 10 seconds after the TV is displaying video before control begins. SO… to those on Stable… do you have any other CEC devices hooked up as well? Try unhooking them, unplug all devices for 10 minutes, plug back in and then test.

On RPI3 (beta) and V2 (beta) if I turn on the tv and the source was something other than OSMC when shutdown then I need to either press the ‘select source’ and then ‘refresh’ buttons which takes a total of about 15 seconds from pressing TV ‘power on’ - or – wait a good 30+ seconds after pressing ‘select source’ This is a little annoying but not something I am about to fret about.

(Side note → V2 (beta) is again forcing me to select OSMC skin at each reboot. Edit: blowing away advancedsettings.xml using rm allows osmc skin to persist between reboots)

An Amazon Fire TV does not appear to impact CEC behaviour on any device when also attached.

Reboots to OSMC requires a ‘refresh’ of CEC

Minor power dropouts (not enough to shutdown tv monitors or osmc) also requires a ‘refresh’. I live smack in the middle of 2 LARGE power switching stations, so these are fairly common (LED lights in the house give a quick flicker when this occurs.

@sam_nazarko you may certainly SSH in if it helps!

1 Like

one of the tv’s i saw this had another cec device on it. I did not test if removing the other cec device resolves this somehow.

On the other samsung i had this problem i had only one hdmi on it and only the rasp pi3 on it. No hdmi amplifier or any other cec device.

I wont be able to go to that device till next week at least so it will take me some time to be able to provide logs.

I wrote a few days ago that I had a similar problem with a Vero 2. Unfortunately(?), I now can’t reproduce it, so this currently Works For Me.

No problem. I’m keeping an eye on this issue. I’m back home on Tuesday, and I’ll publish some test builds for the brave.

Thought I’d post here as I opened a similar thread here:

I also have a Samsung TV and moved from a Vero to Vero2 recently. Everything worked OK with the Vero but the Vero2 doesn’t seem to register as an Anynet+ device. CEC doesn’t work, the Vero2 doesn’t appear in the TV list of Anynet+ devices and while the Vero2 is running, CEC on the other devices appears to have some issues. e.g. I can’t get any sound from my tv through to my home theatre system while the Vero2 is connected.
Sam I sent you a message with a url to a log file upload as requested on the other thread.

Thanks

The problem still persists on our 3 different Samsung TV’s.
Anybody has some good news?

yes, I’ve had to power down and disconnect my vero when I’m not using it. It seems that all Anynet devices share the same HDMI signal path and if one device misbehaves they all get a bit confused.

I’m sure there’ll be a Sam along with good news shortly. :slight_smile:

Is autowake AVR enabled in Kodi settings?
Does disabling this help resolve the issue?

Not sure if that was meant for me or Chain but not on my system. All the options in my Peripherals CEC adapter are set to None or Ignore.

Did you get chance to look at the log file I uploaded?

Yes I did. I think setting up CEC as a Recorder may solve your issue. I’m not sure if it’s related to the other posts here.

How do I do that Sam? I looked in the CEC settings and can’t see any option to set the device as a recorder.

I have explained that in the other thread just now.

Please stick to one thread or it can get a little confusing to keep track of everything

apologies I didn’t see your update in the other thread. I’ll try what you’ve suggested and update the correct thread with my findings.

Thankks

Cool – I have some ideas but want to mull over them first.

I’ve updated the other thread with my mixed results.

Thanks

1 Like

For my Samsung CEC problem with my pi3 I studied the Vero 2 problem from makk509 and used the following commands:

sudo systemctl stop mediacenter
sudo nano /usr/share/kodi/system/peripherals.xml
sudo nano /home/osmc/.kodi/userdata/peripheral_data/rpi_2708_1001.xml
sudo systemctl start mediacenter

in both xml’s I changed the device_type from 1 to 4

and in actual the CEC seems to function normally… TV turned On/Off/On with changing source and it does work…

I will observe and test the pi3 a little bit, but eventually this could be a solution. It’s worth a test for everyone with the same problem.

Excellent :grinning: glad my results weren’t just a fluke.

I’m really don’t know what happend over night, when TV was off. But absolutely the same problem appears to me again. TV off / Source changing and CEC Controls are gone and must reconnect manually again.

Doesn’t work for me :frowning: