CEC stopped working

Hello all,

Just after I solved (or at least explained) my dhcp and hostname problems, The OSMC install in the livingroom stopped reacting to my TV remote. Not sure what changed here, but I suspect it came with an OSMC update. The TV is a Sony bravia 46W4500 that has always worked flawlessly with CEC and Kodi.

How can I track this?
I can’t find a CEC setting in Kodi.
I can’t find anything in the settings. Even though http://kodi.wiki/view/CEC mentions it should be under
System -> Settings -> System -> Input Devices -> Peripherals -> CEC adapter
(Is the wiki out of date, or is this an indication something is wrong on my side?)

Also can’t find anything on the log files. Tried hdmi_ignore_cec on and off.

Anything else I can do?

It is still in the same place but a lot of people see where it says Peripherals and think it is a header not something you click on. Did you make the same mistake.

Also what is your settings level because it doesn’t show when on basic but any higher level has the Peripherals options

:slight_smile: indeed, same mistake here…
When I click Periphials the CEC Adapter shows up.
Product ID: 1001 Vendor: 2708 Version: LibCEC 3.0.0 - firmware v1

Nothing to enable or disable thought, so I keep searching.

Highlight the CEC Adapter and press enter :wink:

Grrr… Unbelievable:-)
It is enabled, I don’t see anything especially wrong.
Lots of interesting settings to play with when I get the basis working again though!

But how… Is there any log message that indicates success or failure for instance?

Try unplugging the TV and Pi from the wall, let sit 5 minuted then replug TV and then Pi after TV is started and switched to correct input

My problem was not in the kodi setting but under programs add ons and then the osmc add on, there under display i found the setting ignore cec …
That was on and needs to be off. So it does not ignore it. Maybe you can find there a couple off settings.

Ignore CEC is never enabled by default and no update to OSMC would cause it to be enabled. While it might be a good idea for OP to confirm it is not enabled, you can be certain that if it is, it would have to have been done so by user. Also, it should be noted that hdmi_ignore_cec and hdmi_ignore_cec_init are two completely different settings.

http://elinux.org/RPiconfig#Video_mode_options

Unbelievable, but this did the trick! Thanks for your simple but effective tip :smile: