CEC support for VERO 4K - Update: GOT the VERO 4K but CEC NOT WORKING with SAMSUNG SUHD TV - KS8000 60''

One of the big reason I stick with RPI is that I can stick it back of the TV and use my TV remote to control the PI.

Given the lack of 4K support I am planning to move to VERO 4K? Currently I only use one remote and I would like to keep it that way…

Can someone please confirm can I use my current PI CEC user experience via VERO 4K? That’s mean can I stick the box back of my TV and use my TV remote to control the OSMC?

Vero - OSMC clearly answers your question.

Many thanks. I went through the post and found out that VERO 4K coming with it own power supply.

I live in Australia and want to know will VERO 4K ship with correct power point pins to support AU standards.

Reason is my power points flush against the TV and no room to put an adaptor in butween.

Kindly someone help to answer this last question around VERO 4K

I uses CEC with Vero 4k

You will receive the Australian power supply.

Vero 4K works with CEC. There was initially an issue with this but it has been fixed with a software update. There’s still about two days worth of devices (at this run rate) with the old software, so the first thing you should do when you get it is update it.

There is also a TV mounting kit included in the box.

Sam

1 Like

Thanks Sam. I will put my order today.

Great – we are on top of things so we will get it out for you first thing tomorrow morning.

Hey, there,

I’ve just bought a Vero 4k. Do you send compatible power plugs to all the countries you’re shipping to? If not, which are the ones do you deliver? I live in Germany and would need to know which adapter to buy.

Vero 4K is shipped with the suitable power plug for destination country.

1 Like

Yes – we send a compatible one to each destination country. You will receive an EU (two round pin) power supply, unless you request an alternate plug type in the order notes section.

Sam

1 Like

Thanks a lot for the info and your support!

Hello @sam_nazarko

As per your and product feedback I ordered and got the VERO4K but CEC not working. My TV and Remote models as below. Please help this is kind of a big problem for me. NOTE that my Pi CEC working perfectly with the current TV.

What I did:

  • Update the VERO 4K to latest
  • Make sure TV CEC ON
  • Tried with old HDMI Cable and also with one came with VERO
  • When I plug the PI it’s working
  • Restart the TV and VERO multiple times

TV Model:
SAMSUNG SUHD TV - KS8000 - 60’’
Link:http://www.samsung.com/us/televisions-home-theater/tvs/4k-suhd-tvs/60-class-ks8000-8-series-4k-suhd-tv-2016-model-un60ks8000fxza/

Remote Model: (Images attached)
BN59-01241A

Again please help as CEC working via TV remote is a mandatory requirement for me.

Is your device up to date?
Can you post a debug log or output of cec-client?

Try using the HDMI cable from the Raspberry Pi

If you have another TV also worth trying on that, I’m not aware of any major CEC issues presently and none unique to Vero 4K

Thanks

Thanks @sam_nazarko I will go and buy HDMI 2.0 cable and post the results. I think cables I got pretty old and I saw VERO is HDMI 2.0. I will post the results this afternoon. For now I can use OSMC remote as it working with VERO mounted back of the TV.

Thanks again for prompt response.

@sam_nazarko CEC now working with the new HDMI cable. Just FYI as I am not very fuzzy but other maybe… default cable coming with VERO4K seems to be not CEC compatible as tec guys at JayCAR here in Melbourne told me the same…

Only issue now is getting the CONTEXT Menu working on the attached Remote. I will start a new thread on this …

I know this has been solved, but one thing I noticed on my Samsung TV when using my new Vero 4K was that it wouldn’t detect the CEC device when I had my Raspberry Pi 2 connected, also running OSMC (I was setting up my Vero 4K after using Kodi on my Pi 2 for years). Once I disconnected the Pi 2 and power cycled my TV and Vero 4K, I was able to control the Vero 4K box using my TV remote via CEC.

Last tip - install the Kodi addon (Keymap Editor) as this will allow you to map specific buttons on your TV remote to custom commands - i.e. I use the blue teletext button to activate the context menu. This is a useful addon to have!

Hi. I had the same issue and I had to replace the cable. I have a samsung remote control similar to yours and I m trying to figure out what is the best solution for the context menu. Any advise? I will be using keymap editor to set it up eventually.