CEC TV remote not working on vero (But does work on Pi)

I received my new vero yesterday and have been trying to set it up to replace my pi 1 model B.
One thing I cant get to work on the vero is my Sony TV remote via CEC.
Interestingly I upgraded the pi from Raspbmc to OSMC and the TV remote continues to work fine with CEC.
I have tried connecting just vero to same HDMI socket that pi works on (and powering down TV for 5 min) but TV never sees the vero in its sources list (it just sees “HDMI 2” whereas TV sees pi as “HDMI-CEC Kodi”.

Any suggestions on why pi works and vero does not and how to fix? Both pi and vero have been upgraded to latest OSMC in past hour.


1 Like

CEC on Vero is a problem we’re aware of and one that Sam is working on to get fixed.


Any news on this? I got my Vero yesterday and did all the updates including the kernel, but CEC still doesn’t work. A bit of a showstopper getting the wife to accept the replacement to the old pi…

I did manage to get the Vero running via my TV remote on CEC tonight but only ONCE for about 5 minutes before it lost connection again.
I have always found CEC to be a bit of a nightmare with my setup. Not sure if its the TV, Sony AMP or Vero that’s the problem. For sure things could be temperamental with my old Pi setup but I would get several weeks (sometimes months) CEC connection before things went haywire (usually caused by kids). The only way I have found to get CEC back working again is to POWER everything off (not standby), wait at least 5 minutes and then as if by magic it (pi) would work through CEC again. Even this old trick does not work with Vero though (I have no idea what made it work the one time).

Have the exact same problem with my Sony KDL TV connected to a Denon AV receiver.

Also, with the old RPi connected, I used to via the TV remote be able to alter between hdmi inputs (Kodi or HDD recorder), but with the Vero connected, the Vero doesn’t even show up in the TV’s Bravia sync menu.

Same issue here with vero directly connected to samsung tv via hdmi. No SEC (works fine on pi)

Any updates on this issue @sam_nazarko?
It’s a bit of an inconvenience having to switch between remotes, but the only problem I have with my Vero.

as a temp solution until the CEC is resolved I have re programmed the samsung remote file as described here as the default one didnt work:

now I can control the Vero with the TV remote but every time I hit play pause etc I get unavailable error message popup on the screen for a sec and had to be careful to only use buttons on the remote that wouldn’t cause the TV to bring up random menus etc.

Not perfect by any means but might get you by on one remote for now. (also worth noteing if you enable another remote the vero remote that came with it will not work anymore)


If you want multiple remotes to work you can combine conf files. Open one file in a text editor and copy everything then open the other conf file and paste the copied text to the bottom of the file and save it using a descriptive name. Browse to the new file in MyOSMC Remote module and select it.

@phate1 Did you do a FULL learn of the remote? Full meaning all the buttons. If you did can you post a copy of it and hopefully I can get it included/added to existing

Didn’t think of combining files ill give that a go as the kids prefer the vero remote.

No I didn’t do a full learn, only what I use:
arrow keys, ok, back, info, play/pause, fastforward / rewind, contextual menu.

But i can run through the rest tonight and ill upload it

@Dilligaf Here is the full scan of the remote.
Remote Model Number: BN59-01107A ( same layout as pic on vero remote list)
Controlling TV: PS50C680

A few keys I guess or assigned them to a temp key for now listed below:

Ones i guessed at the best placement for:

The ones I couldn’t really find a home for:
KEY_1 Source
KEY_2 ch list
KEY_3 media.p
KEY_4 green button in middle main menu
KEY_5 p.mode
KEY_6 dual
KEY_7 3d
KEY_8 ad
KEY_9 p.size

hope that helps


Thanks for this, I’ll try to get our Samsung file updated. (Yes, I’ll combine the two :slight_smile: )

I’m sort of a geeky guy and have invested countless hours/days trying to setup a multimedia solution in my living room with minimum expenses.
The purpose behind the decision to buy Vero, was to get rid of the amount of time invested on geek activities, and get on board of a plug and play solution.
Having said this, I’m very happy with Vero, but I hope that a few issues preventing total satisfaction (Rolling Stones reference here :smile: ) can be addressed and solved.

This is one of them. I like the Vero remote, but my family would appreciate the ability to use the Sony TV Remote, via CEC. Not to mention that the wife would really apreciate the possibility to hide as much of the living room hardware as possible.

Keep up the good work guys.

1 Like

Same problem here on my Vero (CEC not reconized or controlled by 2 different Samsung TVs) - CEC shows up as a device under system/input/peripherlas as CEC adapter ID:1001 Vendor:0471 Class:cec.

CEC works on these TVs via Raspbmc and OSMC installed onto a Pi B v1 and Pi B v2, as well as Geexbox on a Cubox-i4pro.

The Vero (and all devices) are buried so remote access is out of the question.

I guess I will box the Vero up until an update allows CEC to work.

Same problem here. Won’t be able to use it until fixed :frowning:

Cec working now after last update!!! :smile:

Can confirm. Great news!
Edit: Okay, still not working well for me. Works great for a few minutes but then just stops working.

No joy with CEC and Sony W905


Indeed – CEC support should be improved now. I’d like a log if you can so I can see why it’s not working too well for you