Chapter skip broken

18.1 then, whatever the first v18 release was.

just a FYI, i just tried a folder rip of a UHD disc and a folder rip of a Blu-ray disc, same results

Have you tried with any other content?
How did you rip the disc?

Sam

i have full disk rips and MKV’s

Unencrypted full disc rips created with MakeMKV as are my MKV’s

Okay, those will be affected. I’ll produce a build with a fix shortly, but it will need some testing for regressions

Sam

will it be a installable hotfix? or a full system image?

You will need to install it via SSH.

ok!

hey @sam_nazarko, any progress with that test build?

Not yet. I’ll let you know when it is ready.

ok, thank you

@sam_nazarko Will this come after the 18.4 final build?

No - before.

thank you sir

Thanks for your patience here. I’ve made two changes:

  • One to support chapter seeking without depending on key frames
  • One is a backport of some TrueHD fixes, which fixes some crashes which can occur when seeking and TrueHD passthrough is not enabled.

To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

Sam

1 Like

I was having this issue as well, will install the patch.

Looking forward to your feedback.

installed, and ran a few quick tests, chapter skip works perfectly now!

TrueHD Passthrough is Enabled on my system so i can not comment there

1 Like

Glad to hear this. Thanks for testing. I’ll make this part of today’s update.

Sam

1 Like

I can confirm, works very good now.

Thanks for confirming