Configure Harmony Elite + Hub with Vero 4k/Kodi

Not really perplexing and if you use the Keymap Editor you while see that all keypresses are defined multiple times depending on the window your are in.

Details can be found here
https://kodi.wiki/view/Keymap

1 Like

cool! but can you expand a little more on this? from your comment, I thought the Vero 4k must be using some custom key map definition for the “menu/list” remote button

but I just checked under .kodi/keymaps , and I could not find any xml files .

I’m sure I’m missing something obvious… can you help?

Yes but nowhere does it state that multiple functions can be bound to a single key.

hi @pinn73, I think it does:

3 Structure

There is one global keymap and several window -specific keymaps.
Kodi falls back to the global map when the window-specific map hasn’t bound the key being pressed.

1 Like

I finally had some time to sit down and watch TV - my Harmony Elite (with a hub) is configured using a Microsoft Kodi device (using bluetooth). Its “Menu” button is configured as “Kodi/Context Menu” (for both short/long presses).

It does work as you describe (i.e., same as original Vero remote) - it presents me with the context menu whilst at Home, and the “CodecInfo” when playing a video.

I think, in your case, the easiest would be to install the Keymap Editor addon - it is quite straightforward to use.

1 Like

Hi,

Anybody having issue with waking up the Vero 4K+ via bluetooth connected Harmony Ultimate remote?

Mine somethimes wakes up but most of the time wont…

Not using the sleep function with this combination.
But it usually takes some seconds until the remote functionality works (to the dismay of my girls @ home - Patience is not one of their strength :smiley: )

I tried this several times, but in step 2 my iPhone keeps pairing briefly, but then disconnects. Any idea why this is happening?

If you are having problems pairing your iPhone with the Harmony, then I’d suggest that you go the the Harmony forums for help. Your problem has nothing to do with OSMC or the Vero.

Will this process work for a Harmony Hub with OSMC on a Pi3…and the soon to exist Pi4 versions?

This worked like a charm for me! Went through it step-by-step, 4 minutes later: done!
One teeny thing that is bothering me… Volume up. For the life of me I can’t get longpress Volume UP to work with the Logitech. Volume down works like a charm; using a seperate keyboard (with dedicated volume controls) does provide a longpress volume Up and Down as you would expect. Short press Volume Up works (1 step per press).

I checked the settings via MyHarmony: all good. Tried mapping the bluetooth code with volume Up (and Down): no change.

What am I overlooking here?

I would suggest rebooting twice, turn on debug logging, hold down Vol down, let go, hold down vol up, let go, then upload the Kodi log with My OSMC. Post the url that is returned in this thread.

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

Hi Darwin

Did what you suggested; the URL is https://paste.osmc.tv/zujavozowi

Thanks,
Ron

HandleKey: plus (0xf02b) pressed, action is volumeup
HandleKey: shift-long-plus (0x102f02b) pressed, action is
HandleKey: minus (0xf02d) pressed, action is volumedown
HandleKey: long-minus (0x100f02d) pressed, action is volumedown

It would appear that your remote is sending a shift modifier along with the plus which is why nothing happens when you hold down the key. This is something you probably need to get sorted out on the Harmony side (maybe a longpress action in myharmony, not sure, I don’t have this hardware). If you wanted to try work around it on the Kodi side you would need to manually (because keymap editor doesn’t support this) edit a keymap file to add a volumeup action to shift plus. Another alternative if you get stuck would be to change the volume buttons to something else in the harmony software and then map those keys to volume actions in keymap editor.

BTW a keyboards dedicated volume buttons will be sending volume_up/volume_down.

Hi Darwin,

Thank you very much for your quick response, appreciated. It’s strange, though; the Harmony is configured the same for both volume down as for volume up. I did actually reprogram as you suggested, using the MyHarmony app, both volume up and down buttons, including short and long press. The result was exactly the same:

  • short press down: per press, 1% less
  • long press down: ‘running’ lower volume
  • short press up: per press, 1% up
  • long press up: 1% up, no matter how long I press. As you describe that you assume NOTHING happens, I thought it could still be important to mention that something DOES happen: it acts the same as the short press.
    In other words, I don’t think MyHarmony is incorrectly configured/a way forward.

I did notice that my keyboard - with seperate volume buttuns - does work as expected. I now often times use that keyboard.

I don’t think you want to configure a longpress in myharmony for either of those “volume” buttons. Kodi is not looking for a secondary action, it is looking for the key to be held down. I don’t own a harmony remote that supports that function (or Bluetooth) so I don’t really have any details or knowledge of how that end of it is working. I think my point may have been missed a bit here though. Your remote is acting as a Bluetooth keyboard. You press a button on your remote and it sends some keyboard key to your Vero. According to your log when you press the volume up/down it is sending the +/- keys which is not the same as the multimedia volume buttons your comparing it to with your actual keyboard. This is normally just fine and using +/- for volume is common and supported in Kodi. HOWEVER, what is different with your setup is that when you hold down (long-press) the volume up button on your remote, instead of sending a repeating + key, it is instead sending a repeating SHIFT and +. The issue here being that although + is mapped in Kodi to a volumeup action, shift plus is not mapped to anything. Thus you either need to figure out how to get your remote to only send a repeating +, keymap shift +, or have your remote send out something else entirely and keymap the volume buttons to those.

Ah, now I see, thanks. Strange though that the Harmony is not doing the same with the up button as with the down (why would it add the SHIFT for long-press volume up, where it does not do that for the long-press volume down, eludes me…).

Anyway, figuring this out will be a challenge, though. Still, thank you very much for your answer!

1 Like

This worked the first time, very snappy and very nice so saved and went on with next activity on the Elite. Second time i tried it just to see, it was slow IR again with no understanding why. Any ideas?

I re-removed and connected a few times and now it seems to be working. It can be a little unstable right at the pairing so.