Confirmation of 'Factory Reset' process

Hi, I have 1xVero4k and 2xVero4k+. Recently my home network’s router died, and I replaced the whole home’s system with a newer & different one (switched from Unifi Gateway+APs, to Eero). That caused all 3 Vero4k units to no longer start up.

I’ve had them a long time and they’ve worked so well without tinkering all that time, that I have forgotten how I set them up. I have an aging QNAP-NAS and the movies, TV shows, and music, all is located there. I don’t run Plex or anything like that on the NAS. I just gave the Vero4k’s access to the folders on the NAS and it does the rest. I remember having some trouble at first getting the Vero4k’s to “see” those folders on the NAS but with help from this forum, got it sorted out. If I recall correctly, I also set up a NAS-based shared library, with a shared file for saving watched-or-not, and resume-play-where-you-left-off (I forget what that’s called).

Anyways, I searched around the forum and found this thread and noted the advice here:

but at least now I know where the pin / button is.

Meanwhile, I intend to follow this:

My question is, the above guide only refers to the Vero4k. Does this also equally apply to the Vero4k+? Most likely yes, but just in case not, I thought I’d check so I don’t brick those two units. I use a Windows PC.

Prior to this, one of the 3 units, I can’t remember which, at one point the ethernet port stopped working but wifi still did, so I switched it. If I can get them going again, and if that problem repeats itself, I’ll start a different thread. Maybe it’s something simple, though as I said, I haven’t messed around with anything (settings etc.) in a long time. I’m not complaining. These units have served me well for a LONG time.

I wouldn’t start from scratch if I was in the same boat. I’m assuming what is going on here is that you were running a fixed IP on your NAS that was set by Unifi and now that is gone and maybe even now in a different subnet. You could change the ip address (and subnet if needed) in your Eero software to what it was before. Alternatively, you could update the Vero’s to work in your new network. The first thing to do is to figure out what IP addresses your devices are currently using and set at least your NAS as fixed. Once you have that SSH into your Vero’s or just access the terminal locally with a keyboard. See the article [here] to find out how to do that. Once you have access to the terminal then…

nano ~/.kodi/userdata/advancedsettings.xml

and then edit the ip address pointing to your MySQL database. While your there also add in a path substitution to point your existing library over to the new ip address of your NAS. This should be all that is needed to get you back to where you were. Instructions on how to do the path substitution can be found here…

1 Like

Ok thank you. I’ll clean the cobwebs out and try your recommendation later tonight. Revert after or tomorrow.

1 Like

Just for completeness one could also just remove/rename advancedsetting.xml to get Kodi to boot again and in a shared database type setup like this it would bring them back to loading the local database. This could be done at the console but if you had Samba enabled previously it could also be done from a PC browsing from the network.

Yes, it does.

UPDATE:
Indeed, I had set the QNAP NAS to a static IP address. Upon installation the new ‘eero’ router had selected for itself a different subnet. After some searching, I finally found where & how to manually set it (Changing Gateway IP address and range - Questions & answers - eero Community), and then found where & how to set a ‘reservation’ (https://support.eero.com/hc/en-us/articles/207613326-What-advanced-features-does-eero-support-) for the QNAP to have the same static address as before.

Rebooted the router, rebooted the QNAP, then rebooted the Vero4k, and now it’s working.

Sorry for the delay in working through this, and thank you very much!

1 Like

Glad to hear this.

UPDATE #2
I mentioned in the OP I have 3 units. After changing the QNAP back to a static IP address, two of them booted right up, and I have successfully updated them to the latest software. The two that are working, one is a Vero4k and the other is a Vero4k+.

The third unit, a Vero4k+, is not working. When I try to boot it under the exact same circumstances, I briefly see “please stand by”, then the solid blue screen with the white logo, then the screen turns black. That’s it. When a ‘good’ unit boots, I can briefly see text printed on the left of the black screen, which looks like code that’s running is outputting that it’s doing its thing step by step. But it’s very fast. Anyways, I do not see that with the bad unit.

I was thinking about perhaps copying the configuration from the working Vero4k+ unit to test on this ‘bad’ one? They should already be the same, but who knows, it’s been a while since I changed any settings.

I had also noted in the OP that one of the units, AFAIK the ethernet had stopped working. I have them labelled as to which room they came from, and I think it may be this unit that had that issue. When I set up the new eero router & APs, I set back up my wifi exactly the way it was before, but, maybe it won’t boot because it can’t “see” the NAS, neither by ethernet nor by wifi.

Something else that’s probably unrelated, but just in case… my Windows PC is hardwired to the network, and so is the QNAP NAS. All that separates them is 1 ethernet switch. When I try to use File Explorer from the PC, it shows nothing connected to the network. I can browse to the QNAP only because I know its path is \\QNAP. I can’t remember what I named the Vero4k’s (because I have 3 of them), so I can’t type in their path, or I would have tested this on the good units. I could try connecting them via USB to the PC and see how that goes. I need to troubleshoot this issue ‘separately’, but again I’m just mentioning it in case it’s related.

I could start a new thread if that’s preferred. I imagine I will need to re-learn SSH/telnet. In the past I used https://www.putty.org/

Thanks!

My suggestion is to first just remove the SQL section from the not working unit and see if it is working then. For that either go locally by connecting a USB keyboard or look at the DHCP Lease List and check if the Vero is visible and then connect via SSH.

As a last resort you can reinstall that Vero via Download Image and then copy the Config over from the other device.

1 Like

Trying to unravel this mystery further…

I am in over my head, but, I am determined to work through this. As I’m sure you can tell I was never a network expert and since it has been a long time, for many things I am starting over.

I have a desktop PC which has two monitors. PC is a desktop so I can not move around the house with it. So, for this troubleshooting, I have the Vero4k+ connected to one of the two monitors (whichever Vero4k unit I’m working on, but only one at a time; I have them labelled to keep track of which is which). The PC is connected to the other monitor. I can hook up to the network, more than one Vero4k at a time but I would have to go back & forth between rooms, or, I could connect them to all to the ethernet switch next to the desktop, and swap the HDMI cables back & forth as needed.

Yesterday, after the above post, I plugged back in the ‘non-working’ unit, and then at the black screen, I got distracted for some hours. I came back much later, and it had booted up?! However, it does not display movies or tv shows, nor even list those ‘headings’ on the main menu. The other two units do.

Following is what I can determine so far:

first just remove the SQL section

I don’t know how to do this. Browsing around, I found under MyOSMC–>NETWORK–>MySQL, the following:

  • Enable MySQL Video Database = Square Box is ‘lighted’ = ENABLED
  • Enable MySQL MusicDB = Square Box is ‘lighted’ = ENABLED

Underneath both of those are (nearly) the same thing:

  • Name: MyVideos …or… MyMusic
  • IP Address: the old static IP address; as noted above I already made a reservation for the QNAP, in the eero router; the QNAP reservation = static address is 192.168.1.108
  • Port: 3306
  • User: kodi
  • Pass: **** (literally it is 4 asterisks; selecting that item, I am shown a keyboard and again 4 asterisks; I do not know/remember this password)

Below those two columns, it also shows

  • Import Watched State: ENABLED
  • Import Resume Points: ENABLED

I assume I should disable both of these and reboot. I will try that.

~ ~ ~ ~ ~ ~

Further browsing the area, under WIRED

  • Enable Adapter = DISABLED

Attempting to enable it, it sits there for a few seconds and then turns itself back off.
Below that,

  • Automatically configure the network toggle = GREYED OUT

Far below that,

  • Wait for Network = ENABLED

~ ~ ~ ~ ~ ~

The next section, WIRELESS

  • Enable Adapter = ENABLED (It appears to be successfully connected to my wireless network.)
  • Status: Connected
  • Wait for Network = ENABLED

~ ~ ~ ~ ~ ~

BLUETOOTH = DISABLED

~ ~ ~ ~ ~ ~

TETHERING

  • Hostpot SSID = osmc_wifi
  • Hotspot passphrase = h0tsp0t0smc … and I think those are three zeros but not certain
  • Ethernet_to_Wifi = ENABLED
  • Wifi_to_Ethernet = DISABLED
  • Do not connect this device to a wired network with a DHCP server
    … with the mouse I can browse to the word ENABLE and I cannot browse to the word DISABLE. Given that the ethernet does not seem to be working, to be candid this is confusing. Because ‘disable’ is greyed out, is it already disabled? If I were to click on ENABLE, would it then be enabled? And if enabled, does that mean it would then be blocking connections to a wired network, meaning that function would be disabled so to speak? So, enabling it, disables it?

~ ~ ~ ~ ~ ~

look at the DHCP Lease List

I also do not know how to do this.

~ ~ ~ ~ ~ ~

Looking on the QNAP, I have two ways to examine the folders on the hard drive: Windows File Explorer on the PC, or, “FileStation” on the QNAP (accessed via the QNAP via browser, and logging in). Using the FileStation app, I can see some hidden folders that I cannot see via File Explorer. they all begin with a period. Anyways, I cannot find the above referenced MySQL libraries, neither as files nor as folders. I vaguely recall being taught another way to access ‘files’ and ‘folders’ (directories?) on the Vero4k’s, and on the QNAP.

The QNAP has an add-on, called phpMyAdmin. Clicking on that brings up a browser page to log in, but I don’t know that username & password. I tried user=kodi or user=root or user=admin, and PW=(lots of things, including blank, root, 1234, abcd, etc.) without success. The reason I mention this is, when it fails to log in, the message states: “Cannot log in to the mySQL server”.

I cannot find in the Vero4k settings, where to view or set the device’s network name/path. In SETTINGS → SYSTEM INFO …

  • Storage: Filesystem = /dev/vero-nand/root, Size = 14G, 26% used
  • Network: IP address: 192.168.11.22
  • Hardware: Serial: 210d0400e9f97efc4a0ac42bb137657c

~ ~ ~ ~ ~ ~

I have not yet tried to sort out why, in Windows 10 File Explorer, the initial ‘view’ of the Network shows nothing. However when I browse to the QNAP by typing in it’s path/address, \QNAP, then I can see all the folders except the hidden ones that start with " . " (a period).

~ ~ ~ ~ ~ ~

On the Vero4k, SETTINGS → MEDIA → LIBRARY → VIDEOS …

I used to have 3 main folders of “videos”, two for Movies (Kids & Parents) and two for TV Shows (Kids & Parents). We no longer need the Kids side of things. Attempting to browse to any of them: Connection timed out, then Couldn’t connect to network server. Attempting ADD VIDEOS → BROWSE , I am presented with choices

  • Home Folder (.kodi, .ssh, Backup, Movies, Music, Pictures, TV Shows) … the ‘media’ folders are all empty.
  • Network File System (NFS) … doesn’t work; no response
  • Root filesystem, has a right arrow out to the right (bin, boot, dev, etc, home, lib, lib64, lost+found, media, mnt, opt, proc, root, run, sbin, selinux, srv, sys, tmp, usr, var) … something about the folder “mnt” is vaguely familiar
  • Video Playlists … empty
  • Windows Network (SMB) … empty
  • Zeroconf browser

Options within ZEROCONF:

  1. FTP File Sharing on Vero4Kx__ … The underscore/blank is actually “B”, which looks like what I would name a device, since this one is from the Bedroom. Back in Windows 10 File Explorer, attempting to manually type in the path \Vero4Kx__ and trying many variations, including “B”, all with no success, while this device was powered up & plugged in. Anyways, clicking on this it freezes for a few seconds but otherwise has no effect.
  2. Samba shares on Vero4KxB (SAMBA) … child folder = osmc
  3. VERO4KXB (SAMBA) … child folder, also = osmc

Update: under MyOSMC–>NETWORK–>MySQL , disabling both of them, and rebooting = no change. The device boots up, but no media, movies or tv, is showing.

It successfully downloaded and executed an OSMC update.

~ ~ ~ ~ ~ ~

Reconnected the ‘working’ Vero4k+… it’s still working, I can see the media, play a movie, etc. Under SETTINGS → MEDIA → LIBRARY → VIDEOS, then on the remote pressing the button that looks like a bulleted menu with 3 bullets, then select EDIT SOURCE, it shows the following

smb://192.168.1.108:445/Vero_Movies_Parents

which corresponds to a folder on the QNAP NAS. In the box below, Enter a name for this media source, it lists “Vero_Movies_Parents”.

Attempting to add another folder (they are all already there, but, going through the motions) I have the same results as above except that Zeroconf has more choices:

  1. FTP File Sharing on Vero4Kx__ … [now the name is Vero4KxT, where the T stands for Theater. Back in Windows 10 File Explorer, attempting to manually type in the path \\Vero4KxT it successfully finds it and lists only one child folder, “osmc”. The subfolders of osmc are all empty except for Backup contains OSMCBACKUP____.tar.gz]
  2. QNAP(FTP)(FTP) … new
  3. QNAP(SAMBA) … new
  4. Samba shares on Vero4KxT (SAMBA) … child folder = osmc
  5. VERO4KXB (SAMBA) … child folder, also = osmc

Attempting to browse further, the screen froze and has been unresponsive for a long time.

UPDATE: unplugged it, plugged it back in after 60 seconds, it booted back up. Under option 3 above, QNAP(SAMBA) I can see all of the QNAP’s folders and select one to add as a media source.

Obviously without the MySQL you will not see any movies as your master database connection would be missing but you should get a picture (Kodi booted) that was what this exercise of removing the database was for.

If using a central MySQL database all OSMC (Kodi) versions would need to be on the same major update.

As mentioned if you have a working device it would be best to just copy the sources.xml and advancedsettings.xml to the none working one.

Also I lost a bit the overview what is now at the end your problem. Maybe you can explain once more what currently is not working and share the logs from the working and not working device.

you should get a picture

A picture of what? When? Where?

Maybe you can explain once more what currently is not working and share the logs from the working and not working device.

The non-working device still does not work, even after updating OSMC, and also after disabling MySQL.

copy the sources.xml and advancedsettings.xml

Where are these files? How does one copy from one Vero4k+ device to another? Hopefully via Windows 10 File Explorer? Keep in mind I cannot ‘see’ the non-working device via File Explorer.

Please understand: these devices are very difficult for a layperson to set up and troubleshoot. That’s why I didn’t touch them for so long after I got them working. I am glad to research on the internet, how I’m supposed to do what people here on this forum recommend. I just haven’t invested time in learning networks, linux, etc. I merely need a bit more guidance than you might give to a fellow enthusiast.

Means the device boots and shows you the Kodi screen.
You early had the issue

What does “does not work” means exactly? No picture, not finding movies, no access via ssh?

These files are in a hidden directory of the home folder (/home/osmc/.kodi/userdata/)
You should be able to access them via File Explorer (if hidden directory enabled and you have SMB Server active on Vero) but I suggest to first rely on SSH/SCP as that is more reliable.

For me currently the options you have are:

  1. Reinstall the non working Vero4k via the OSMC Installer → USB Stick and when you have a normal booting device you then can either just configure MySQL via MyOSMC and/or we talk you thru copying the config files from the working one.
  2. Figure out the IP address of the none working Vero (from your router) and try to connect via SSH.

Details regarding how to access the command line interface can be found here on our Wiki: Accessing the command line - General - OSMC

I have 2 working units, one a Vero4k, the other a Vero4k+.

  • they are connected to my network via ethernet (do not need wifi)
  • they can access the internet
  • all available OSMC updates are installed
  • they can access my network, specifically the QNAP NAS, where media is stored, and where, I believe, I have a “mySQL shared media-info library” or whatever it is called.
  • more specifically they can ‘see’ media folders, display media correctly on the NAS, and play said media
  • my Windows 10 PC can access them via the network, via File Explorer (I have to manually type in the path, namely \\_____, for example \\QNAP or \\Vero4k, in order to access any device. Something in ‘automatic device discovery’ or whatever it’s called is not working quite right.)

I have 1 non-working unit, a Vero4k+.

  • ethernet does NOT work
  • it is connected to my network, but via wifi which works
  • it can access the internet
  • all available OSMC updates are installed
  • it can NOT access my network, specifically the QNAP NAS
  • it can NOT ‘see’ media folders on the NAS and therefore obviously cannot display or play anything
  • my Windows 10 PC can NOT access them via the network, via File Explorer, not even when I manually type in the path, \Vero4k

Therefore, something in the settings of the non-working unit is preventing it from accessing the network, and vice versa.

Well it could be that there is something in your router that prevents direct communication between wired and wireless devices.

What is the IP of your None working Vero? Can you connect to it via SSH?

I’m not familiar with Eero, but I assume there must be something in the Eero app which gives you a list of all the devices currently connected to the network? If you go into that, it should tell you what the IP address of the not-working Vero device is. Once you know that, you can try connecting to it via SSH - if you can get in, the OSMC guys can then tell you what you need to type to get more information about its network state.

It would help to know a little more about what the Eero is doing. There’s probably a section in the app which lets you control what range of IP addresses it can assign, and which IP addresses are currently assigned to which devices. If there’s a section called “DHCP”, try looking in there.

Also, can you actually see the OSMC or Kodi UI on the not-working device now, or are you just getting a black screen as soon as it boots up?

Is it possible that the WiFi network the non-functioning Vero is connected to is intended to be a “guest” network, i.e. one that provides internet access but does not allow access to other devices on the network?

Is it possible that the non-working Vero was originally set to use a manual IP address rather than an automatically assigned one, and that this manual address is now outside the range of the Eero’s subnet?

1 Like

Thank you for this suggestion. I do have a ‘main’ and a ‘guest’ wifi network. I found that both credentials were ‘stored’ in the Vero4k+ and for whatever reason it was defaulting to only connecting to the ‘guest’. I should have noticed that, sorry. It’s my lack of experience combined with some frustration, I suppose. Anyways, I forced it to forget the ‘guest’ & rebooted. More on that process below.

…there must be something in the Eero app which gives you a list of all the devices currently connected to the network

Another good suggestion. I checked and the Vero4k is listed there. I can see it’s host name, address, etc. And it shows whether it is connected wired or wireless (still wireless) and whether ‘guest’ or ‘main’ (confirmed it’s now ‘main’). It also displays whether it, the eero, thinks it’s connected. green instead of red, and it is green.

Also, can you actually see the OSMC or Kodi UI on the not-working device

Yes, OSMC and Kodi both appear to be working. I mean, TBH I cannot tell the difference between the two, but it’s working. I have the main blue colored screen with the menu on the left, all the sub-menus, etc. However I still do not have Movies & TV in the menu, as I explain further below.

Is it possible that the non-working Vero was originally set to use a manual IP address rather than an automatically assigned one, and that this manual address is now outside the range of the Eero’s subnet?

I don’t think so. I have rechecked and it’s set to automatic.

~ ~ ~ ~ ~ ~

After changing the wireless connection to the main network … on the first reboot, no movies & TV … still not working.

Under MyOSMC → Network → Wired … attempting to enable this, still fails. It turns itself off after a few seconds.

Then I looked under MyOSMC -->NETWORK -->WIRELESS–> At first, for several minutes, it showed: STATUS = NO INTERNET. After troubleshooting this & that, I rechecked it and it finally showed STATUS = CONNECTED. However movies & TV were still not showing under the main menu. On the other hand, I could browse to the media folders (Settings–>Media–>Library–>Videos) and play a movie. Maybe it needs another reboot now that it is finally connected.

Second reboot: still not showing any movies/tv. Going immediately to check the connection, MyOSMC -->NETWORK -->WIRELESS–>STATUS = CONNECTED. At this point I also tested from Windows 10 File Explorer, and it works to manually type in the path \Vero4kxB: I can see the osmc folder and it’s sub-folders. This is the same behavior as the working units.

Back on the Vero4k, under MyOSMC -->NETWORK -->MySQL … they are both still disabled. Attemtping to re-enable them, I cannot. They do not store what was previously there, and ‘reload’ those parameters when re-enabled. I do not know the password and I cannot copy it from the other units because they do not display it. I regret not knowing this prior to disabling them.

Third reboot: no change. Still no movies & tv showing on the menu. On the Vero4k, wireless is connected, it has internet, and I can browse to the media folders & play a movie, and browse to the QNAP NAS via ZeroConf as if I were adding another folder. From Windows File Explorer, it works, I can access the same folders on the Vero4k by manually typing in the path.

I finally found where to trigger a manual update of the library but had no effect. It also does have “Update library on Startup” enabled.

Now I’m stuck again. The unit admittedly does sorta work, in that I can laboriously drill down into the media folder to manually play something.

I’ll give you an analogy.

Imagine you have a desktop PC whose only job is to run Microsoft Word. So, when you boot the PC up, it launches Windows, but you never actually see the Windows desktop, it just launches Word automatically and goes straight into that, and the only UI you ever see is the Word application.

The Vero 4K+ is a computer whose job is to run a single application - Kodi. To do that it needs an operating system to run the application in - it uses a version of Debian Linux. So, the Vero device is equivalent to the imaginary PC; Debian Linux is equivalent to Windows; Kodi is equivalent to Word. OSMC is a software distribution which includes both a customized version of Debian Linux, and a somewhat tweaked version of Kodi (including an OSMC “skin”). So, OSMC is all of the software that you initially install on the Vero 4K+ - both the operating system and the sole application. The application you are running once the Vero has finished booting is Kodi.

Anyway, just to recap at this point: are your two “working” Vero devices now able to access your media library (your stored movies and TV programmes) in the way that they used to? If they can, then (fingers crossed) all you now have to worry about is making sure the third Vero can access the same library. I think you were told to disable access to the shared SQL library higher up the thread? If the other two Veros can still access that okay, then restoring the MySQL settings on the third one to match the settings on the other two should hopefully get everything working again. (Your initial problem would have been that the third device couldn’t see the NAS because it was connected to the Guest wireless network; but now that it’s connected to the correct network you should be able to see the SQL media library as well).

On the other hand, if none of your three devices have a working media library, then some more setup is required.

I’m going to bow out at this point, because I’m not familiar enough with a Kodi setup that uses a shared MySQL library, and I don’t want to risk offering bad advice about how to set it up. :grinning: But I feel like we’re headed in the right direction now!

OSMC is your OS. That’s based on Debian.

Windows is an OS, as is macOS, Android and Ubuntu. All can run Kodi.

OSMC runs Kodi and we try and do it as tightly as possible in terms of integration.