Connect to Synology via Wifi to access files

Hi all,

I just got my Vero 4K+ and I want to connect it to my NAS via Wifi, because for now I can’t connect it via the cable. I have been reading up on how to do this, but I can’t seem to get it to work. I went through this documentation and I need some more guidance. Does anyone have some detailed step by step tips so I can access the files from my Vero 4K+?

Thanks in advance!

The guide you linked to is quite step-by-step. It would be much better if you told us on which point you’ve had issues, and i’m sure someone with nas experience will help.

The guide you linked to is quite step-by-step. It would be much better if you told us on which point you’ve had issues, and i’m sure someone with nas experience will help.

Ok, well I figured out I still needed to activate on my Synology NFS which I did (see this article). I have however nog setup the EZ - Internet on Synology, but I am not sure if that is necessary.

Now the goods news is I was able to add a NFS source on Vero and I now see the ip-address and I can browse through the folder, but when going deeper in the folder I get a “Remote share - Couldn’t connect to network server” message.

As ooZee pointed out, please mention the steps through which you successfully worked.

Is your Vero connected to the wifi at all?

The Kodi wiki has a step by step guide with pictures on setting up NFS shares on a Synology DiskStation.

It’s just needed for access from outside your LAN. That’s for later. Focus on setting up NFS shares correctly and accessing them from your LAN first.

Good the NFS share works at all! If lower folders can’t be accessed, make sure you correctly set up NFS read permissions for them.

Also: what does your Vero’s /etc/fstab look like?

Yes, I think I have see screenshot:

Could it have to do with mounting folders as described in point 4 here? Don’t know how to do that. I work on a Mac.

Where can I find this? In the file manager?

If you want to specify a single IP to have access, you have to append its subnet mask in decimal with a slash after the IP. Look at the description of your screenshot, last sentence at the bottom. I assume you’re using a standard subnet of 192.168.1 with subnet mask of This is /24 because it uses the whole first three octets or 24 bits of its subnet. Anyway, just change to This assumes is the IP of your Vero.

€dit: Just reading the three sentences at the bottom again. It shouldn’t be necessary to append the /24 if you only want a single IP to have access. On my 918+ it works despite the /24. Oh, well …/€dit

Yet, it’s in the Vero’s file system. I didn’t know you were using Kodi’s GUI to mount the share. It’s possible but not as fast as kernel-based mounts. These are covered in grahamh’s tutorial section OSMC as a client – using fstab or autofs or here in detail. You can access your Vero via ssh by opening a terminal.

I did the same about a year ago, here’s my thread on how I set up NFS shares on a DS 918+ and mounted shares kernel-based with a Vero.


Is the the Vero4K+'s ip: ?

I’ve also found sqaush set to: Map root to admin, works for me.

Thanks Tom.

1 Like

Would you mind if I DM you? Seems like I have the same devices you use. I already went through the documents you provided (the fstab) but when doing the cd command the check if I can find the folder it gives no results.

Sure you can DM but if we solve it out in the open others can profit from the solution, too.

That might be it. Missed that in the screenshot. Squash ist set to all users to admin on my 918+ as well.


Brilliant, that did the thing. Now I can access the folder. Thanks!

1 Like

Yes, that solved it. Thanks for helping out. You pointed me in the right direction and also your solution regarding fstab seems to work. Will dive into it later on. Going to reset my NAS because I want to set it up differently and then get things going. Thanks again.

1 Like