Connecting to wifi issue on raspberry Pi 3

I was working on setting op OSMC on my raspberry Pi 3 model B. I was using this link (see link down below) to help me configure it, but I ran into this issue. I wanted to use my wireless wifi connection to connect my raspberry to the internet, but when i try to connect to it and fill in the passphrase and press enter, the loading logo just keeps on spinning forever. Doesn’t matter if i fill in a wrong or right passprhase (tried it like 4 times) the logo just keeps on being there and I am just stuck there forever. The rasperry isn’t frozen or anything, but its just stuck on the logo. I pulled the power supply out the raspberry from my laptop like 4 or 5 times and tried to connect to the internet again, but without any results. Any suggestions? Thank you.

Maybe try via command line using connmanctl as described below

Details regarding how to access the command line interface can be found here on our Wiki: Accessing the command line - General - OSMC