Enable wifi under GUI

I installed OSMC with OSX and chose wired network connection. Now however I would like to use my Edimax EW-7811UN. How can I set it up under GUI or eventually command line? Im on Alpha4 and Raspberry Pi 2.

1 Like

Hi, I have just installed OSMC Alpha 4 on a Raspberry Pi B+ and did the install with my network cable connected to the internet. I have a Wi-Pi wireless dongle for wireless connection by OSMC is not seeing the device. Is there a way to get to the configuration so I can connect to the internet via wireless dongle?

1 Like

I don’t think wifi drivers are yet included. Config by GUI is not yet implemented. Both of these are very high on the to-do list though. If you are able to install your own drivers, you may be able to configure by use of connmanctl command in CLI. You’ll have to google it’s use though…

OSMC kernel has drivers for a lot of wifi adapters.
Go in terminal and type ‘dmesg’ to see if your wifi adapter is recognized (if you don’t konw how to find it, unplug and plug the adapter and you shold see something on the latest lines of dmesg output).

Then, follow these steps:
$ sudo cat /var/lib/connman/settings

You should see somthing like this:

If WiFi is setted to false:
$ sudo nano /var/lib/connman/settings
Change ‘false’ to ‘true’, hit ‘control key’, type ‘Y’ to save.
$ sudo reboot

Open terminal again, then:
$ connmanctl
connmanctl> agent on
connmanctl> scan wireless
connmanctl> services
(you should see your wifi network called “wifi_somethingsomething_managed_psk”)
connmanctl> connect wifi_somethingsomething_managed_psk
(the agent will ask for passphrase)
connmanctl> quit

1 Like

Thanks for jumping in with that @goose2600

1 Like

Just to improve on the above suggestion a little bit, you don’t need to manually cat or edit any connman files - in fact you should not edit connman files directly. Instead to check if wifi is enabled:




If wifi is off use:

enable wifi


scan wifi


agent on



This will list found networks, then use connect with the long string to the right of the network you’re trying to connect to - for example

connect wifi_c83a35ca4314_535454657374_managed_psk

Tip: you can use tab completion so you don’t have to type every character.

Once connected the connection will be remembered and automatically used in the future.

Network settings will soon be added in the OSMC settings addon so this manual method (or entering the details during install) won’t be needed for the final version of OSMC.


Hmm when I type technologies wifi status doesn’t even come up… I’m pretty sure I selected wifi during the initial setup…

Fresh install of Alfa 4.
Trying to follow the tips you guys left here… here is my output:

root@osmc:~# connmanctl
connmanctl> technologies
Name = Wired
Type = ethernet
Powered = True
Connected = True
Tethering = False
connmanctl> enable wifi
Error wifi: Method “SetProperty” with signature “sv” on interface “net.connman.Technology” doesn’t exist

I guess my WiFi dongle (Asus N-10) does not get recognized properly:

[ 2.378515] usb 1-1.2: new high-speed USB device number 4 using dwc_otg
[ 2.480264] usb 1-1.2: New USB device found, idVendor=0b05, idProduct=17ba
[ 2.480304] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 2.480325] usb 1-1.2: Product: 802.11n WLAN Adapter
[ 2.480342] usb 1-1.2: Manufacturer: Realtek
[ 2.480358] usb 1-1.2: SerialNumber: 00e04c000001
[ 5.618245] random: nonblocking pool is initialized
[ 8.578882] EXT4-fs (mmcblk0p2): recovery complete
[ 8.588955] EXT4-fs (mmcblk0p2): mounted filesystem with ordered data mode. Opts: (null)
[ 8.589057] VFS: Mounted root (ext4 filesystem) readonly on device 179:2.
[ 8.589264] devtmpfs: mounted
[ 8.590320] Freeing unused kernel memory: 324K (c08ed000 - c093e000)
[ 10.118919] NET: Registered protocol family 10
[ 10.168431] systemd[1]: /etc/mtab is not a symlink or not pointing to /proc/self/mounts. This is not supported anymore. Please make sure to replace this file by a symlink to avoid incorrect or misleading mount(8) output.
[ 10.724130] systemd[1]: Cannot add dependency job for unit display-manager.service, ignoring: Unit display-manager.service failed to load: No such file or directory.
[ 10.885177] fuse init (API version 7.23)
[ 11.178599] EXT4-fs (mmcblk0p2): re-mounted. Opts: (null)
[ 12.088644] systemd-udevd[100]: starting version 215
[ 14.218635] FAT-fs (mmcblk0p1): Volume was not properly unmounted. Some data may be corrupt. Please run fsck.
[ 14.595620] systemd-journald[75]: Received request to flush runtime journal from PID 1
[ 15.515776] Installing knfsd (copyright © 1996 okir@monad.swb.de).
[ 17.510849] smsc95xx 1-1.1:1.0 eth0: hardware isn’t capable of remote wakeup
[ 17.511671] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 19.130361] smsc95xx 1-1.1:1.0 eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
[ 19.138062] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 29.153194] Console: switching to colour dummy device 80x30

After its recognized with SerialNumber there is no more mention of the device.

Any ideas?

If ‘enable wifi’ in connman failed and there is no mention of a driver loading in dmesg after the USB device is detected it means there is no driver for the wifi adaptor.

Please report the model number of the adaptor and also the chipset it uses so we can try to add this driver in a future Alpha. If the adaptor works in Raspbmc or Raspbian you could get the driver name and version from dmesg while booting one of those systems.

Hi,I configure ssid and password network with osmc installer but get no connection on OSMC.

I found this thread and tried to run some connmanctl commands.

But I’ve problems with scan wifi command, it shows “Scan Completed” but when I run services command It shows all except my network.

Is this related with the configuration of OSMC installer (SSID & pass)? Can I remove this configuration and launch again scan wifi?

rtl8192cu adapter
dmesg shows MAC auto on okay!

Pre-configuring WIFi would not affect the visibility of services in a scan.

Is there anything special about your network? I.e. hidden ssid; 5Ghz, 802.11ac etc.


Does it include driver for edimax ew-7811utc ac600 ? If not pls explain how to install.


Don’t know. What chipset is that?


hi @DBMandrake, thanks for your help. It did work for me, just had to run a quick update first. Thanks a lot!

Chipset Realtek 802.11ac (rtl8812au)

Openelec support this.

No, it’s a 2.4GHz, 802.11n, WPA2 with visible SSID.
Cable Router Netgear CG3100D.

I have the same wifi adapter, did you just update within OSMC settings program?

From working Raspbmc:

smsc95xx 1-1.1:1.0 eth0: register ‘smsc95xx’ at usb-bcm2708_usb-1.1, smsc95xx US B 2.0 Ethernet, b8:27:eb:da:d9:c1
usb 1-1.2: new high-speed USB device number 4 using dwc_otg
usb 1-1.2: New USB device found, idVendor=0b05, idProduct=17ba
usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 1-1.2: Product: 802.11n WLAN Adapter
usb 1-1.2: Manufacturer: Realtek
usb 1-1.2: SerialNumber: 00e04c000001
EXT4-fs (mmcblk0p2): recovery complete
EXT4-fs (mmcblk0p2): mounted filesystem with ordered data mode. Opts: (null)
VFS: Mounted root (ext4 filesystem) on device 179:2.
devtmpfs: mounted
Freeing unused kernel memory: 188K (c057b000 - c05aa000)
udevd[86]: starting version 175
bcm2708_i2c bcm2708_i2c.1: BSC1 Controller at 0x20804000 (irq 79) (baudrate 1000 00)
usbcore: registered new interface driver rtl8192cu

Yes, with built in settings program.

Everything is ok(Usb wifi adapter dlink dwa-121 lights stated blinking)untill I get this in ssh.

Where do find my ssid and enter mywifi password?

Edit : wifi works now!