No wireless networks found using raspberry pi 3

Hi,

I have recently installed the latest version of OSMC on my raspberry pi 3. However, I am unable to connect to (any of) the wireless network(s) via the GUI. I have also tried using connmanctl to enable wifi and scan for network (as described here), but it still does not detect any.

I did the following:

connmanctl

technologies
scan wifi
enable wifi
agent on
services

This last command returns as an empty line. When I plug in the Pi3 with an ethernet cable to the router, connmanctl services only finds

*AO Wired ethernet_‘some_random_hex_number’_cable

Does anyone know what could cause this issue?

Thanks in advance!

First, check your power supply. Pi3 is recommended to be power by a 5v 2.5A PSU. If no joy, provide logs.

To get a better understanding of the problem you are experiencing we need more information, including logs from you. Our wiki contains detailed steps for providing the relevant info we need to help you.

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request

I am unable to find any wireless network on my raspberry pi3, with OSMC installed. I have never been able to find a wireless network on my raspberry pi3 with OSMC installed (also with a previous version of OSMC), via the GUI or via the command line. A couple of days ago, I installed the latest version of OSMC, but I am still facing the same problems. I have tried the following to resolve this issue (with an ethernet cable attached during the following):

osmc@osmc:~$ connmanctl
connmanctl> technologies
/net/connman/technology/p2p
Name = P2P
Type = p2p
Powered = False
Connected = False
Tethering = False
/net/connman/technology/bluetooth
Name = Bluetooth
Type = bluetooth
Powered = False
Connected = False
Tethering = False
/net/connman/technology/ethernet
Name = Wired
Type = ethernet
Powered = True
Connected = True
Tethering = False
/net/connman/technology/wifi
Name = WiFi
Type = wifi
Powered = True
Connected = False
Tethering = False
connmanctl> enable wifi
Error wifi: Already enabled
connmanctl> scan wifi
Scan completed for wifi
connmanctl> agent on
Agent registered
connmanctl> services
*AO Wired ethernet_b827eb9b998e_cable
connmanctl> exit

When I don’t connect the ethernet cable, the last command (services) returns an empty line.

My raspberry pi3 only has a USB drive and some usb dongles (for a wireless keyboard and mouse) attached, and is powered with the official raspberry pi charger.

Please find my logs attached here (created by running “grab-logs -A” in the terminal).

Did you try unplugging the USB drive and the mouse and attempting via GUI?

Yes, I tried unplugging the USB drive and the wireless mouse, but the result is the same.

Do you get WiFi on any other distribution?

If not, the device may be faulty.

Same problem with my Pi3.
With LibreElec I have no problem.

I found the problem, apparently the raspberry pi cannot find wireless 2.4GHz networks on any channel higher than 11. Changing my router to use a lower channel solved the problem.
A workaround can also be found here: http://tosbourn.com/get-channels-12-and-13-on-the-raspberry-pi-3/

1 Like

Did you set the wifi regulatory respectively?

What do you mean exactly?

You may need to set the CRDA.

Install wireless tools
sudo apt-get install iw

First check if the correct country already set (unlikely)
iw reg get

Then set it with
sudo iw reg set <2 Letter Country Code>