Connection problem changing between wifi and cable

Hi,i have my OSMC with a Dynamic DNS(using No-IP) here : raspiosmc.ddns.net

Is connected by WIFI,the problem is i dont know what to do for change it and have the connection by cable(if i disconnect the wifi and connect cable all die,using the same internal IP and DNSs)

What to do? reinstall NO-IP or what? thanks

If you change medium (wifi -> cable) there will be a change in internal ip, so my guess is that your portforward in your router is still pointing to your wifi ip.

2 Likes

Done,but now the connection is SUPER SLOW :confused: web server dont load(but at least ask for user and password),neither VNC

why???

using wifi is fast u.u

To get a better understanding of the problem you are experiencing we need more information, including logs from you. Our wiki contains detailed steps for providing the relevant info we need to help you.

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request

Hi ActionA my problem is that when i stream using web server Chorus at work is SO SLOW using wifi(in my house is fast,obvi),then i thought change to cable,but now the problem is,i access the web server(in my house) and is sloooooooow,why?

To get a better understanding of the problem you are experiencing we need more information, including logs from you. Our wiki contains detailed steps for providing the relevant info we need to help you.

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request

-Issue: Slow speed using cable

-What i was doing: I just changed the IP(before 100,now 150,ports opened in router)

-For replicate the issue:
1(Using WIFI and no cable)

i connect to raspiosmc.ddns.net:8080 and the webserver loads fine

Network configuration:

IP 192.168.1.100
MASK 255.255.255.0
GATEWAY 192.168.1.1
DNS 8.8.8.8
DNS2 8.8.4.4

Router configuration: 192.168.1.100:8080 OPENED

2(Using cable and WIFI disabled)

i connect to raspiosmc.ddns.net:8080,the webserver ask for user and password,but DONT LOAD

Network configuration:

IP 192.168.1.150
MASK 255.255.255.0
GATEWAY 192.168.1.1
DNS 8.8.8.8
DNS2 8.8.4.4

Router configuration: 192.168.1.150:8080 OPENED

BUT if i connect to the webserver using 192.168.1.150:8080 load FINE

-Device running OSMC: A Raspberry Pi 3

-Peripherals attached: Internet cable, USB for media

-Version: the october version

Do you need something more? tell me please

I’m not sure how to be more clear Sir.

1 Like

Sorry ActionA,i am angry thanks to this problem -.-

Logs

If you have port forwarding to both IPs in your router it will probably try to forward to the first one (100) and then wait for that to time out before trying to forward to the other one.

If you’re only ever going to use one or the other, just configure both wired and wifi interfaces to the same IP and have only 1 rule on your router.

Otherwise, pick one connectivity method and stick to it.

I just did port forwarding to one IP(if i try the two one dissapear)

I tried with the two at same time too,and same problem.

Thanks for your time

The log shows bpth the wifi and ethernet active at the same time in places. Is there a reason why you need to use both?

It would be much easier to have only one interface active at anyone time.

I suspect packets are arriving on one interface and being routed back over the other.

I tried using just cable(because i want more speed using the streaming of Chorus),then trying to connect to web server at house(raspiosmc.ddns.net:8080) or to vnc,to all is so slow.

If i use the internal ip(192.168.1.150:8080) all is fine

And with only wifi the problem is the slow streaming in chorus connecting at work(but i can access w/o problem).

Sometimes i used the two at same time but was a caos.

Any ideas? thanks :slight_smile:

First choose and configure the connection method you want to use long term.

Disable the other one.

Reboot RPi and router.

Test.

Then we can work out any residual issues with you.

Most importantly never have wired and wireless interfaces connected at the same time.

Amaaaazing :smiley:

Better to reinstall? Am bored of this xd

Whatever the disk sda4 is it is not responding. If it is an SD card, check to make sure it hasn’t gone corrupt, if it is a spinning disk check it has enough power.

1 Like

Is fine now :slight_smile: was my fault

Now i restarted router and RPi(wired enabled,wireless disabled)

But WebServer is slow :confused:

First try:

"The page raspiosmc.ddns.net does not work

Raspiosmc.ddns.net has not provided any information yet.

ERR_EMPTY_RESPONSE"

Second try:

WebServer asked for username and password,but page dont load

What if you try connecting to your current numeric WAN IP address:8080?

1 Like

http://...:8080/

same!! :frowning:

MOD EDIT: removed user’s public IP address…