Connection to a 5GHz hidden wifi

I have bought a Vero 4k two weeks ago and it worked almost flawlessly after I configured it. At the beginning it lost its settings twice and switched to default ones, after reboot but didn’t happened the same after.
The only issue I have now is to keep it connected to a hidden ssid wifi. In My OSMC > Network > there is no “Wireless Hidden (psk)” option no matter how much I wait, it displays just the visible surrounding wireless networks. By making the network ssid visible, it connects. Then, after setting the network back to hidden ssid, vero4k stays connected until the next reboot when it turns to the same initial state, which is - disconnected, no hidden ssid displayed in available wifi list, none available option in settings to add a hidden wifi.
There is any solution to this? Thanks!

The easiest way would be to connect via the command line.

agent on
scan wifi

then type services and you will see some WiFi networks

type connect long-service-name and enter password if prompted.


Thank you Sam!
It is fixed now. It worked like a charm :slight_smile:

1 Like

It’s not recommended you hide your ssid, it’s more of a risk than help.

1 Like

A post was split to a new topic: WiFi connection issues