CPU Usage all cores 96-100% at idle

My library consists of around 3,500 movies and I add more on a daily basis.
I have 11 hard drives connected to my Vero 4K+ via the USB Hub. (wired)
I noticed that I frequently encounter the Blue Screen with the frowning face lately.
Also 4K movies stutter.

I thought perhaps the modified AEON MQ7 and AEON MQ8 Skins that I’m using might have caused the problem
but even if I try to use the OSMC Skin or Kodi’s default, CPU usage on Idle is still the same. (96-100% on all Cores)

Can Vero 4K+ handle AEON MQ7/MQ8 Skin even with a large library?

Thanks in advance for the help. Here is my log:

http://paste.osmc.tv/uwokeraqub

Is Kodi or another process using the CPU’s?

1 Like

How do I determine which process is using the CPU?

Connect in via the command line and use the top command.

Thanks for the reply.
Sorry but I’m quite a newbie with command lines.
I’m using a macbook.
Can you point me to the right direction?
Or is there a command in the terminal that I can just copy and paste in order to determine what’s
causing the sluggish performance?

https://osmc.tv/wiki/general/accessing-the-command-line/
and
https://osmc.tv/wiki/general/working-with-osmc-via-the-command-line/

Upon checking,
KODI.BIN is the culprit, it is using 392% of CPU and 74% Memory at IDLE specially after playing a 4K movie for a few minutes.
Whenever I play 4K movies, most likely I will encounter slowdown and then the BLUE SCREEN with the
Sad Face :frowning:
After restart, it will play the movie fine but upon exit and play or fast forward/rewind, memory will become full, movie becomes sluggish again and then the Blue Screen will appear again.

Ok, then we at least know that we have to dig in Kodi.
I suggest to try with a clean Kodi folder. Just configure your source and play the 4k movie afterwards.

Let’s test with Kodi default settings. Enter the following commands with an SSH connection.

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bak
systemctl start mediacenter

If needed you can restore:

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bk2
mv ~/kodi.bak ~/.kodi
systemctl start mediacenter

If your original setup was restored as expected and you want get rid of the unneeded clean install you can delete that with the following command.

rm -r ~/kodi.bk2

Let’s test with Kodi default settings. Enter the following commands with an SSH connection.

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bak
systemctl start mediacenter

If I do this, will I lose my library and settings?

You will temporary lose them as you will get a clean Kodi.
But they will be in ~/kodi.bak where you can recover them from with the second set of command.
But as usual it helps to have backups also done before

I tried the First command and played a 4K movie flawlessly.
Upon checking the CPU usage after playing a movie, rewinding and fast forwarding it,
only 1 core is at 10% while the others are all 0% and the memory used is just 10%
When I connected via command line.
KODI.BIN is just using 5% memory and the CPU load is around 12% only instead of the previous 390+%.
What do you think is causing the problem?
I’ll try to restore my kodi using the 2nd command that you’ve given.

Addons most likely. Suggest first just to recover sources.xml and guisettings.xml only

What do you mean? I need to make a backup of my sources and settings?
Can you please let me know how I can do that? Thanks again.

If you haven’t restored the whole kodi directory I suggest just to do this
systemctl stop mediacenter
cp ~/kodi.bak/userdata/guisettings.xml .kodi/userdata/guisettings.xml
cp ~/kodi.bak/userdata/sources.xml .kodi/userdata/sources.xml
systemctl start mediacenter

@fzinken, I did that mate.
I was able to restore my kodi using the previous command that you gave.
I now tried the last command that you suggested.
It restarted but I did not see any difference.
CPU at almost 100% and sad blue screen again after playing a different 4K file.

When you ran the previous command than you have already restored your whole Kodi folder!
Start from scratch again
systemctl stop mediacenter
mv ~/.kodi ~/kodi.bak
systemctl start mediacenter
systemctl stop mediacenter
cp ~/kodi.bak/userdata/guisettings.xml .kodi/userdata/guisettings.xml
cp ~/kodi.bak/userdata/sources.xml .kodi/userdata/sources.xml
systemctl start mediacenter

I corrected the instructions!

1 Like

I entered this command.
Now my kodi is on its default stage just like when I tried the very 1st command that you gave.
Again, 4K videos playing without any problem.
What would be the next step?

My guess would be it’s the banned add-on that you have in your sources. And you have 2 others that I’m not familiar with. Don’t reinstall those, or if you do, do them one at a time to find out what the culprit is.

I’m not familiar with the banned add-ons.
Can you tell me the specific ones that I should avoid reinstalling?

If the add-on is giving you free content that should be paid for, then it’s banned. The one in your sources starts with a V.

For more information about banned add-ons:

https://kodi.wiki/view/Official:Forum_rules/Banned_add-ons