Crash Issue

Hoping someone will be able to help me. Recently purchased a Vero 4k+ and am in the process of setting everything up. I am experiencing a continual crash problem every minute or so.

Attached is a short YT clip which shows what happens. As soon as the on screen ‘jitter’ has finished, the device is unusable unless rebooted. The same problem will manifest itself a few minutes later after the reboot.

First time I’ve ever tried uploading a log but hopefully this works:

https://paste.kodi.tv/owaziyacox

There doesn’t appear to be a certain thing which is causing the issue - it seems relatively random.

Any help would be appreciated.

The video is private so we can’t see it, but it shouldn’t be necessary.

Can you upload logs via My OSMC instead?
Was it crashing from the beginning or only after making some changes?

Sam

Looks like a HDMI cable or connector problem.

Apologies, have made the video public now.

Hopefully this log has everything you need.

https://paste.osmc.tv/piqenijozo

Have had a quick look through and can’t see anything sensitive in the log but if so, please let me know so I can remove the link.

Indeed. Try cleaning the HDMI connector with isopropyl alcohol.

Sam

Thanks for the help so far.

Just to give more context, the freezing of the device persists even if I swap over the HDMI cable when it is in its “frozen” state. Same if I swap the HDMI cable for another but keep the same input.

I’ve tried separate cables and separate inputs but the same thing is happening.

Also worth pointing out that I’m using the cable shipped with the device which only arrived a couple of days ago.

Then please provide debug enabled logs.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

I’m assuming the logs I’ve uploaded don’t help isolate the issue?

If not I’ll have another go at reproducing the issue.

Do you know if this is the case?

I think it only started to manifest itself when I installed Simple IPTV Client, added my IPTV details and started to load the channels.

As I suspected this to be the cause, I disabled the client and rebooted but the problem still arises.

Since fzinken’s last post, I’ve been trying to get the issue to arise again but so far no dice. Previously it was happening every minute or so. I’ve even managed to re-enable Simple IPTV Client.

I take it back; has just happened again. I’ll try and get another log uploaded. This time it happened with a separate HDMI cable and HDMI port.

EDIT: Can’t get to the point where I upload my log without it crashing. Bit stuck here.

The log uploader will include the logs from the last crash after reboot.

Also can you access the Vero via SSH?

I’d try and re-install OSMC. See https://osmc.tv/wiki/vero-4k/reinstalling-osmc/.

Hello guys - back again I’m afraid.

I did a couple of fresh installs of OSMC, each time I’d experience the same issue.

Uploaded log is here: https://paste.osmc.tv/ibijutiyur

The crash occurred between 12:55:48 and 13:10:45.

At the moment, the device is unusable and I’m having to revert to my Raspberry Pi.

I guess given that the issue has been reproduced after a fresh install, it must either be (a) a hardware issue or (b) one of the add-ons I’ve installed isn’t playing well with OSMC?

Would appreciate help resolving otherwise I am going to have to return the device as it is unusable at the moment.

Thanks.

How do you “experienced” the crash and what did you do when you considered the device “crashed”?
The logs show active keyboard input at 12:57.

Also have you tried this?

The device is unusable after the visual error shown on the YT clip. Keyboard presses seemingly do nothing unless I reboot the device by switching it off and on again via the power supply.

When debugging mode is enabled, the constantly cycling details in the top left corner even freeze when “crashed”.

You are correct on the timings - I wrote down 12:57 as being the crash time but when I checked the log (as a non-expert) I saw a gap between 12:55:48 and 13:10:45 so wanted to point your attention to this point.

By my notes, the error occurred at 12:57 (according to the Kodi clock). I switched the device off at 13:04 (by a secondary clock) and switched it back on at 13:10 (again, according to the Kodi clock).

On the SSH question - do you mean generally or when the device is in the “crashed state”?

Well if you generally can access it via SSH then please try to reach it next time it is in the “crashed state” and if you can access it run sudo systemctl restart mediacenter

I would check if you can ping the device when it happens.

Confirmed that I can neither ssh or ping the device when in the “crashed” state.

SSH result: Connection times out.

Ping result: Destination host unreachable

As happened last time, the crash is now happening within 20 seconds of turning the device on.

It sounds like it’s crashing as soon as Kodi comes up.
My recommendation is to re-install OSMC. See https://osmc.tv/wiki/vero-4k/reinstalling-osmc/.