Crash on startup

#1

It’s now the 3 time in a row that my OSMC installation is somehow damaged and I need to a full re-install.

The installation will work fine for about a month or so, then after that period it will suddenly crash and never wake up again.

Upon startup the sad face shows up and then it reboots and on and on and on and on.

I don’t know what to do. :frowning:

#2

Hi,

It seems like your SD card may be problematic.

Some SD cards are not genuine or have a lower capacity than advertised. Some simply fail over time.

Symptoms of SD cards not working correctly are:

  • Read-only behaviour, or changes made not persisting
  • A filesystem corruption error

Symptoms of counterfeit SD cards are:

  • Writing works until a certain filesystem size is reached, thereafter, writes seem to cause issues where existing data is lost or newly written data is not preserved.
  • SD card fails after a short amount of time.

Counterfeit cards are usually found on Amazon and eBay.

SD cards have a limited lifespan. I recommend you change SD card and suspect that issues will no longer persist with a good card. If you would like to be a good quality SD card purpose manufactured for OSMC, then you can find one in the Store.

#3

Thank you, I will try that.

#4

Okay so I bought a new genuine SD card (so was the previous one BTW), and installed OSMC again. It worked fine for 2 days and now the screen turns black on start up after the OSMC splash screen.

#5

Can you connect by SSH? Were you ever seeing the lightning bolt icon on the screen?

#6

Not able to SSH but not sure I can do SSH properly (used phone app). I don’t know about lightening bolt. I just get the OSMC splash screen and then all is black.

#7

How are you powering the pi off? Just by pulling the plug off?

#8

Well when the screen is frozen like this, then yes. There’s no response whatsoever.

#9

No, before, when it worked fine.

#10

No, I usually don’t power it off. I switch off the TV and let it run.

#11

I just assumed you turned it off before.

#12

Yes: OSMC is frozen, no response whatsoever. So I turn it off and on again. In this particular case today, it was black after reboot.

#13

Can you please specify

Which model Raspberry Pi
Make and Model of SD card (old and new)
Make and model of power adapter
List all devices plugged into the Raspberry Pi
Anything your using (hardware/software) that may be outside of the norm for a run of the mill user

#14

Thanks for your help.

The Raspberry Pi is 3 model B1.2 (2015)
The connect external hard drive is a wD My Passport 1 Tera
New SD is Kingston 16Gb
Old SD is Samsung Micro SD 4HC 8Gb
TV Sony KDL40EX650 via HDMI
Adapter Stontronics that came with raspberry output 5.1V 2.5A

#15

Is the drive self powered, or drawing power from the Pi. If it’s getting power from the Pi you probably need a powered hub because the drive is using to much power.

#16

I would agree with what bmillham posted above especially if the drive is not using a split cable that is drawing power from two USB ports at the same time. That model Raspberry Pi is not designed to allow for normal full power draw from the USB ports. What’s more is that the overcurrent protection they use on those ports can degrade with use so what used to work without issue may not after a period of time.

#17

Wow okay! It’s definitely not getting power out of thin air so that’s taking juice from the Raspberry. I didn’t know that and simply assumed the USB port was meant for such things as with regular computers.

Alright so I’ll have to see if this drive has an additional power socket, else I’ll find out about sled powered hub.

Do you reckon my Raspberry is now done for?

#18

The Pi should be fine. It could also be that the power supply is getting old and not supplying as much current as it used to.

#19

I see.

  1. My HD has a dual port (power / data) so I hope to find the right equipment for this.

  2. I tested the Raspberry without the external HD and the same symptoms occur. So based on what you’re saying, the power supply could be an issue: so that would mean buying a new one.

  3. Should I do a test by reinstalling OSMC on the SD and not using the HD?

#20

If your hard drive has the dual plug then that should be fine. In that case I would try a new power supply and see where your at once you do that.