Crash or freeze after long idle

Hi there,
Had my new Vero 4k up and running for about four days now. Been rock solid never seen a problem while using, however after being away for an extended period of time, as in overnight, when I turn the TV back on the screen has a dull odd solid color. Seems to be new color every time. Seen green, pink, blueish etc. No response from Vero 4k. Still solid blue LED. No tick, tick sound when attempting to navigate and the screen just remains the same. CEC is disabled. Pull the power to the Vero 4k and when I reconnect it boots and everything is just fine. Not sure if the log will show anything cause obviously has been booted since problem occurred. Any ideas?

Do you have any screensavers enabled?


No. Just the 20% darker it comes with out of the box

Your Kodi log isn’t a debug log so hard to guess what it may be. If you have any addons installed you could try disabling them and enabling addons one at a time


Can you SSH in when it’s in this state? I know you aren’t using CEC, but what happens if you try to switch to a different source on the TV and then switch back to the Vero?

Another interesting test would be what happens if you just leave the TV on all night.

Yea OK, Ill try the sugguestions from @bmillham.
@sam_nazarko it’s a very minimal install. I do have Library auto updated installed and set to run every 24 hours. Now that the library is updated I will disable and see if has any influence. I will also enable debugging.
Thanks, leave it with me for the time being.

This is the symptom I had when my Vero overheated once. At the time, I had a book on top of it and it was quite hot when it ‘froze’, hence overheating suspected. But at least mine was working hard at the time so may be unrelated.


Is the device in a cabinet or on top of another AV unit?


Update: After uninstalling “library auto updater” the problem has disappeared. However, when running manual library updates the exact same thing happens, though only after running for a long time. Cannot SSH and the unit is “offline” on the Yatse remote app. I am suspecting overheat, but CPU usage seems quite low during library update but judging from how hot the 4k unit gets by touch there is definitely something producing a lot of heat during the operation.
How do I best go about troubleshooting this?
SSH and monitor temperature somehow?
On my old Rpi3 there was a little thermometer icon that would appear when the unit was working hard. Never seen it on the 4k but may not be implemented the same way I suppose.

The Library Watchdog add-on can cause freezes.

Is Vero 4K on the latest software?
Are you running any background services?

The device shouldn’t really be overheating. Some debug logs might give some clues.


It is not the Library Watchdog. It is the Library auto updater addon. Simply a timer that starts the library update. Not the addon causing the problem since it is now uninstalled but the problem persists with manually running the library update. The library is on a NAS. The 4k unit is connected with the built in WiFi.
No background services except the SSH that was already running out of the box.
It’s on latest software.

The logs may have some clues.
Are you scanning in a really large library? If you’re only incrementally updating it, I can’t see why it would be overheating.

Make sure the Vero 4K has nothing placed on top of it and has room for ventilation.


Nothing on top. It has the same room to breathe as the Rpi3. It did overheat until I put a tiny passive heatsink on it and drilled holes in the official enclosure. Then it was borderline but OK.
I’m incrementally updating. I wouldn’t say it’s a really large library… about average? :wink:
I’ll enable logging and run the library update and hopefully catch some more info.

We definitely need to see some logs then.
A lot of people have large libraries and scan them straight in when they get their Vero without issue

OK, just happened again with debugging turned on. Confirmed no answer from SSH. After pulling power and reboot go to log upload. With full log upload enabled (can’t remember the exact setting name) there was no meaningful url returned:
Tried this a couple of times same result. Disabling the full log option worked but not very useful log: nukanixadu
Is there a way I can grab the log via SSH and post again?

grab-logs -A

This is what i got:
osmc@osmc:~$ grab-logs -A
Logs successfully uploaded.
Logs available at
(no useful URL)

What was displayed?
Alternatively cat .kodi/temp/kodi.old.log | paste-log

Not sure if it is old.log or log.old

What I showed on the previous post is a copy paste from the Putty output. Nothing.
Using your new suggestion I get this:
osmc@osmc:~$ cat .kodi/temp/kodi.old.log | paste-log
Unable to upload log. Log file is too large. (68MB)

Couple of thoughts:

  1. Exclude the Kodi log, as that’s the largest. While it will likely have the source of the error, it would be good to check overall system health.
  2. Annoyingly, one bad file can be enough to cause a Kodi crash when scraping or viewing. This has even been seen with pictures in the past. You could try bisecting:
  • Split contents in to two directories
  • Scan both directories
  • If one scan crashes, split that directory in to two.
  • Eventually you find the problematic file

The Vero 4K has good thermal governing and shouldn’t overheat. It may get a bit warm to the touch, but the system should remain responsive.