CV out became monochrome after the big upgrade

Hello! I upgraded to the latest Matrix and now Composite Video output is black and white. I think some settings got lost in the process but I have no idea which one can be…

I’m using OSMC on a CRT and I don’t have any HDMI display so I can’t test if the problem also apply to this output.

Any suggestion?


To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Thanks for your answer! Actually I had to for the SSH method as MyOSMC is now disabled, a message at reboot gives the warning, among others of other disabled plug-ins.

So here are the logs:

Thanks again.

Looks like a incomplete upgrade.
Try from command line
sudo apt-get update
sudo apt-get dist-upgrade

I ran the commands and they finished their jobs. Sadly this didn’t help, now after a reboot logo is displayed (still in B/N) and after a while a black screen takes its place with no more evidence of activity. Trying to SSH would reply with ACCESS DENIED if credentials are wrong but if they’re correct nothing would be replied:

2021-08-18 23:45:30 Sent password
2021-08-18 23:45:30 Access granted
2021-08-18 23:45:30 Opening main session channel
2021-08-18 23:45:56 Opened main channel

So at this point I’m stuck and I don’t know how to generate more logs :confused:

This most likely will not give you back your screen but you should be able to connect via SSH.
Check this out

Yes it did the trick! Thanks!

So this is the new log: - honestly I have no idea where to start figuring out what’s broken because there are hundreds of errors :confused:

Anyway I figured out what caused the initial colour problem: it seems like during the upgrade the content of file “/boot/config-user.txt” was erased. (which isn’t supposed to happen, I think) This file contained a setting needed to display colours from PAL mode: sdtv_mode=2

I suspect we assume people don’t have that file and just write an empty file on upgrade. It should be safe from now on.

With yesterday dist-upgrade file config-user.txt became empty again

OSMC won’t touch the config-user.txt file.
I’d check to see if your SD card is corrupted.

A corrupted SD which keeps resetting the content of the very same file at every upgrade? A bit unlikely.

If you say so…

I have a similar issue. I have a PI3B with an official 7" screen and dac+ working okay but when I update to the latest I get a white screen after boot, no response from PI
Luckily I have a backup, So restored a backup from 2019 to a new SD card reboot and it is okay, but tried to update again on 2 different SD cards to a blank config-user.txt again.
I have now disabled the update and stuck to an old version of OSMC.