Denon AV not showing Atmos as audio format

I have recently purchased a Vero 4K and have this connected to my denon AV via hdmi, playing trueHD/Atmos mkv files from my nas, through to my 4K LG oled. However my AV is not displaying that this is an Atmos audio file, any suggestions?
Apologise I am a novice.

Have you checked this wiki entry?

Do you have ATMOS speakers connected to your receiver? As in “height” channels.

From what I know with my own Denon receiver is that it communicates if you use ATMOS to the Vero and if not in use Vero will not send ATMOS but TrueHD or DD+.

I’ve a Denon x4500h receiver in 7.1 config and plays Atmos without any issues, even shows on display

" "

see the link from @fzinken be sure you enable all the audio formats and also passthrough.

Just for my understanding. You have Atmos speakers connected to your receiver (as in 5/7.1.2/4)?

i don’t have atmos speakers connected. I’ve only 7.1 setup. i meant that atmos is displayed when playing (for example the link I’ve added in previous message), as reply to @r666rkb which doesn’t see it.

I will try the file in your link but i have the same issue as the topic starter with my Denon X1400H.
I do not see Atmos in the display when playing an Atmos enabled movie. I always understood it is because I have my receiver setup as 5.1. so these files will show TrueHD or DD+ on the display.

In my manual of AVR this is mentioned: Dolby Atmos is not supported in a 5.1 channel or lower speaker configuration.

for x1400h it seems the same: unless you add special Dolby Atmos Enabled speakers to your config

1 Like

Great find. Now I have some substantiation for my explanation.
@r666rkb might have a 5.1 setup too.

I want to add 2 new ceiling speakers but i first need a new house or ceiling… :stuck_out_tongue:

Sorry for the late reply. I do have Atmos ceiling speakers and have it set up as 5.2.1.
Netflix works fine and the amp shows Atmos on the display. Also if I play the file direct from nas to my oled and ARC to my denon it displays Atmos (although I know the LG oled does not pass through true Atmos sound).
There is no issue with the sound, it seems to be working but I can’t choose or see that the display shows Atmos so not sure if it is pure Atmos or not. I just get the standard sound options to switch to on the amp DD, multi, DTS neural x etc
I have the vero setup as 7.1output and hdmi pcm

I will try the file posted tomorrow to see
If that makes any difference.

7.1 pcm output is demuxing the audio in the Vero so your receiver would never display Atmos, as it’s receiving a LPCM input. In order to get the Atmos bitstream passed over to your receiver you must enable passthrough.

For Denon and Marantz; you need to make sure you pick right mode (color buttons on remote). The left one (red I think) is for movie audio mode. Click through the options here until you end up with Atmos. If right mode is not selected you will not get Atmos but TrueHD (or other upmix on the base TrueHD stream).

And you don’t need hight speakers to get Atmos; Atmos works with only bed channels as well.

But only with more than 5.1 base speakers :wink:

1 Like

I have pass through set on the vero as well. What should I have the channels set to then?

If you want Atmos, 7.1 is the correct setting.

so passtrhough is enabled and 7.1 is selected.

you mentioned direct on tv via nas then via arc atmos is "visual. "

But via vero, what hdmi channel on AVR do you select? Because i understand you don’t see atmos then when playing via the avr? DId you test is with the file link? that’s is pure atmos. On my AVR it plays well. Maybe a screenshot of settings in Kodi for audio.

Yes 7.1 and passthrough enabled on vero.
If I play the same file direct from nas to tv then arc to AV it is visual.
I’ll have a play with hdmi port and cables

You don’t have “Sync playback to display” turned on in Settings>Videos>Playback by any chance do you?

You might also look in the settings menu of your Denon for a information screen. This will show you exactly what kind of signal is coming in from the Vero.

Some logs will let us see if this is the case