Device crashes when playing movies with Dolby TrueHD

As I mentioned a couple times in this thread, this does only happen when TrueHD passthrough is disabled, i.e. when the Vero transcodes the TrueHD track to AC3
My settings are:
Dolby Digital (AC3) capable receiver -> On
Enable Dolby Digital (AC3) transcoding -> On
TrueHD capable receiver -> Off

Right, got you. Thanks for reminding me.


My only guess is that maybe for a short period of time the cpu load is too high but I’m sure you would know better than me.

That wouldn’t cause a segmentation fault. It’ll be something else.

So when you set your audio settings like I did and try to play a file with TrueHD audio and then use the up/down button on the remote to jump to the next/previous chapter of the movie a couple of times in a row, your media center never crashes?

No – I was not able to reproduce this presently.

I’d recommend trying Kodi v19, which should improve things: [TESTING] Kodi v19 builds for Vero 4K / 4K +.

Wow, thank you for still keeping track of this.
I haven’t visited this forum for a long time, so I’m sorry for not responding until now.
Because the described issue is still there I logged in again after months and saw that you replied.
I will give it a try this week.

Issue is still there even with the test build.


Indeed. It looks like it is being worked on upstream however.

I can confirm this is still happening in the new v19 update. Dolby Transcoding is the only way to get multichannel sound in my setup since it goes through ARC. Still only affects TrueHD. Edit: I just remembered that the sad face crash with TrueHD always happens when I skip to chapters - not when I skip random times or at least not that often.

Any news from upstream?

But the very long silence after unpausing a video is finally fixed now (different issue)! :smiley:

Unfortunately this issue still isn’t solved in Kodi v19, but we continue to monitor this.

No hurry, but do you know why this only happens when chapter skipping or jumping to a specific time by using the Kore/Yatse app and not when jumping 10s, 30s, 60s etc. by pressing the left/right arrow on the remote?

I think they use different ways of seeking


I have had no issues playing HD audio and skipping since upgrade. I watch a lot of 4k films and not noticed any issues. Sorry not very helpful.

edit: OK I see this when down mixing to 2 channels? I never do that, just bitstream it through my AVR to my headphones or speakers. Initially when I played the first file it incorrectly played non HD audio. Then I reopened the file it was fine and been fine since then.

The crashes only occur when the Vero transcodes a TrueHD track to LPCM or AC-3, not when using passthrough, and only when skipping chapters (up/down arrows on remote) or when using the progress bar of the Kore app.

I am curious why you would rely on kodi to down mix to stereo. Surely your AVR should do that?

I have my Vero connected to a cheap 2.1 soundbar which is only capable of decoding AC-3 and DTS. If I enable TrueHD passthrough I don’t get any audio at all on my soundbar.

I’ve read previously about a Kodi bug with Dolby TrueHD audio, one of my displays requires 2-channel PCM conversion, and I can’t chapter skip reliably on mkv’s with TrueHD audio as I get lots of sad-face playback crashes (V4K+, Aug 2021 OSMC). Short of adding a regular DD5.1 track to the mkv’s, is there anything I can do? Not posted a log as I think this is a known issue, but wanted to check status.

I moved your post into this thread as I don’t think it make sense to open a new thread.