DNR filter

I just installed the December update on my Vero4k+ and started to watch a bluray. I immediately noticed that something was wrong, but first I thought that it was due to a bad encoded bluray. It looks like there is a heavy post processing filter applied, somewhat like it has gone through heavy digital noise reduction. Fine detail is blurred and there is kind of a posterization of the picture that makes the picture sometimes almost look like a painting. I compared by playing the file with the media player build into the TV and it looks fine there. I searched the settings menu on the Vero4k+ and can’t find any settings that might cause the problem.

Any idea what might be causing this?

1 Like

Difficult to say without an image showing the effect or logs.

Its hard to get a good picture of the problem with my phones camera but I tried. Also the picture might be scaled and compressed a second time when I upload it.

The first picture is from the media player on my TV. Notice the face of the girl and the wall to the left looks kind of blurry but natural.

The second picture is from the Vero4k. The girls face is not as “clean” and the wall to the left looks like a painting.

You sure you got those the right way round? The second pic looks better to me.

The second picture might look sharper, but it looks like it has been artificially sharpened and introduced a lot of artifacts. It is much more visible on a 65 inch screen.

Is there a way to go back to the previous update?

OK. I see what you mean but I don’t think there’s been any change to the video code that could have caused this between the previous release and this one. @sam_nazarko would know better than me.

To go back, you would have to reinstall I’m afraid.

FWIW I downloaded the 1080p trailer for that film and can’t see any significant difference between Vero 4k, Vero V and the internal player on my Panasonic. It does seem to be produced with a soft focus.

No change in this update. You could try and older version of OSMC but I don’t think it’s that that has changed


I played the movie on my Oppo UDP-203 bluray player and there it looks good. I switched the HDMI-cable between the Vero4k and the Oppo to rule out the cable or the input source on the TV.

I will try to reinstall the Vero4k when I find some time.

Which version did you upgrade from? Might help narrow things down - but if it was the August version then nothing has changed.

Im pretty sure I had the June update before I updated today.

looking at both pictures but it is not the same frame, see left arm of the man behind the left woman

Yes, I know its not the same frame. I was doing the best I could. The Tvs internal media player doesnt have a frame counter or frame stepping.

If you can, please upload a clip including that frame (say a few seconds before and after it). Then we can do the comparisons here. Also confirm that the Oppo isn’t upscaling.

You didn’t upgrade to the July or August releases. You must have been on June before.

I disabled the upscaling on the Oppo and it still looks good.

Here is the clip from the movie. Also look at the doorframe in the following scene and on the faces of the actors. There is noise that are moving, while on the Oppo and TVs media player, the picture is much more stable.

1 Like

Can you see if this fixes it from the command line?

echo 1 | sudo tee /sys/module/di/parameters/bypass_all

1 Like

I tried disabling hardware acceleration for h.264 and that fixes the problem, but the movie stutters like crazy.

I’ll try command you provided…

echo 1 | sudo tee /sys/module/di/parameters/bypass_all

fixed the problem with hardware acceleration turned on! But the problem comes back when I restart the Vero4k

Yes, that will reset that parameter. Thanks for testing. We’ll work on a permanent fix.

Could you go into some more detail as to what’s happening behind scenes in this case? I’m curious.