Does Vero 4K+ supports GPT formatted HDD's?

Vero 4K+ doesn’t recognize a 6TB HDD

This is the setup:
HDD bracket connected to the USB port of the Vero 4K+.
In the HDD bracket a WD blue 6TB (replacing a 2TB (in MRB)).
I reach the HDD on the Vero in Win10 using the Samba communication protocol.

This is what i’ve tried so far using MiniTool Partion Wizzard:
a 6TB newly created exFAT partition in GPT, wont work
a 1TB newly created exFAT partition in GPT, wont work
a 1TB newly created NTFS partition in GPT, wont work
a 1TB newly created NTFS partition in MBR, works

The common denominator seems to be “GPT”.

Here Can Vero 4k+ Access a 20TB HDD? fzinken refers to a topic with sort of the same question stating that OSMC isn’t limited and supports GPT and exFAT.

In another topic, though, I’ve found formatting the disk in OSMC could be an option. Me being a noob, i have no idea how to. But if this is the solution, is there a tutorial about it?

Thanks in advance

Yes, GPT is supported.

How is the drive powered?

I’d suggest posting logs so we can see what’s going on.

The harddrive is powered by its own powersupply. The previous 2TB (MBR) worked fine the same way.

I’ll search a “how to” of making a log.

Hi,

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

https://paste.osmc.tv/malexocaxe

I see only this:

Aug 03 17:16:49 osmc kernel: scsi 0:0:0:0: Direct-Access     WD       60EZAZ External  1.75 PQ: 0 ANSI: 4
Aug 03 17:16:49 osmc kernel: sd 0:0:0:0: [sda] 3131110576 512-byte logical blocks: (1.60 TB/1.46 TiB)
Aug 03 17:16:49 osmc kernel: sd 0:0:0:0: [sda] Write Protect is off
Aug 03 17:16:49 osmc kernel: sd 0:0:0:0: [sda] Mode Sense: 23 00 00 00
Aug 03 17:16:49 osmc kernel: sd 0:0:0:0: [sda] No Caching mode page found
Aug 03 17:16:49 osmc kernel: sd 0:0:0:0: [sda] Assuming drive cache: write through
Aug 03 17:16:49 osmc kernel: sd 0:0:0:0: [sda] Attached SCSI disk

Doesn’t match either the 6TB or the 2TB drive. Which drive(s) do you have attached when booting?

FWIW, this is what I get with my GPT 4TB drive

[    4.434682] scsi 0:0:0:0: Direct-Access     Seagate  Backup+ Hub BK   D781 PQ: 0 ANSI: 6
[    4.435989] sd 0:0:0:0: [sda] Very big device. Trying to use READ CAPACITY(16).
[    4.436239] sd 0:0:0:0: [sda] 7814037167 512-byte logical blocks: (4.00 TB/3.64 TiB)
[    4.440130] sd 0:0:0:0: [sda] Write Protect is off
[    4.440141] sd 0:0:0:0: [sda] Mode Sense: 4f 00 00 00
[    4.440591] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[    4.441271] sd 0:0:0:0: [sda] Very big device. Trying to use READ CAPACITY(16).

[    4.512447]  sda: sda1 sda2 sda3

[    4.513654] sd 0:0:0:0: [sda] Very big device. Trying to use READ CAPACITY(16).
[    4.514978] sd 0:0:0:0: [sda] Attached SCSI disk

and

Disk /dev/sda: 3.64 TiB, 4000787029504 bytes, 7814037167 sectors
Disk model: Backup+ Hub BK
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 04064888-9199-4551-997C-07326499C037

Device          Start        End    Sectors  Size Type
/dev/sda1          34     262177     262144  128M Microsoft reserved
/dev/sda2  3922778112 7814035455 3891257344  1.8T Microsoft basic data
/dev/sda3      264192 3922778111 3922513920  1.8T Linux filesystem

So no problem with GPT. It looks like your issue is at a lower level.

I had a small USB thumb drive attached at boot, than switched over to the 6TB harddrive.
Interesting you have a GPT drive working, so that rules GPT as the issue out, i guess.
I use an old WD Mybook case in which i swapped out the HDD (1TB or so) for the aforementioned 6TB, could that be the issue?

Did you format the 6TB drive after you swapped it into the My Book case and then run WD’s drive checking utility on a PC to make sure it was actually working correctly? The adapters they use in those cases are generally not as forgiving to drive swaps as a regular external drive case.

1 Like

I formatted the drive while hooked on SATA in mij pc than put in the My Book case.
This morning i connected the 6TB in the My Book case to my pc, deleted the partition and try to create it again same way i did before. Now i can only allocate up to 1.45TB… So the My Book case being the flaw here seems very plausible.
I’ll order a new HDD USB case to see if that solves it.

2 Likes

Grahamh, do you have that 4TB HDD connected by USB to the Vero?

Yes. I used one of these for a while with a 2TB disk but then got the Seagate Backup Plus. The USB hub sockets are the USP - I plug two DVB sticks into those for live TV.

Last sunday the new HDD bracket arrived, i swopped the drive and made a new 6TB GPT ExFat partition. The Vero recognised the HDD immediately.
So, many thanks to all of your excellent support, the problem is solved. I never thought the issue would be found in the WD HDD bracket, the more because it worked just fine while attached to my pc. So some supreme detective work there.

1 Like

Glad to hear that this is now solved.