DVB-T dongle not working after 2015-08-03 update

Yes that log file does suggest that a full power down may be necessary. “Warm state” probably means the devices firmware is already uploaded from the previous session, and that firmware may be too new for the driver in the older kernel. A full power down will cause the older firmware to be uploaded on next boot, so it may work then.

Powered off Pi, powered on, still no go. Then realised tuners are plugged in to a powered hub, so I powered down Pi, unplugged hub power, plugged hub power back in and restarted Pi. Hooooray all 3 tuners back up. Can’t believe I didn’t try turning it off and on again.
Thanks @DBMandrake you’re a champ.
@nirvana80 I’m sure you’ve probably already tried powering off everything, but if not, worth trying.

Glad that fixed it - it’s quite common for some devices like that to do a firmware upload after a cold boot but not a warm boot…

I’d suggest you hold the kernel meta-package to prevent any further automated kernel updates until this issue is resolved.

sudo apt-mark hold rbp2-kernel-osmc

In theory you should be able to safely do updates and receive updates for everything except the kernel, which will be held back. You can remove the hold using unhold.

Eventually some other feature/functionality of OSMC might depend on a newer kernel so you might eventually see problems but for now you will be ok.

(Note for anyone reading, holding back the Kernel on a Vero is not an option as Kodi and libcec are tightly tied to the kernel version, but on a Pi it is generally fairly safe at least in the short to medium term)

@Spasmodean Well you say that but I didn’t power down the USB hub, I might as well be suffering from the same issue as if I recall I saw the same dmesg error I think.
I’ll try it later and update, if this solves miy issue as well I’ll be very happy indeed.
On what kernel did the power off of the hub fix the issue, 3.18 or 4.1?


I don’t update very often my system (raspberrypi B, OSMC).
Two days ago I decided to make it.
Since then my USB DVBT rtl2832U has given up working (“Realtek RTL2832U reference design successfully deinitialized and disconnected”, “No free adapter”, etc).
In Tvheadend web GUI, I did not have anymore adapters under Configuration -> TVAdapter.

I made some reboot, but only this last shutdown has solved the issue.
Thank you.

ps: my update did not upgrade the kernel, but I had anyway the issue. My kernel is 3.18.13-1-osmc

Downgrading to 3.18 and powering down the hub/USBtuner fixed the issue again. All working again for me.
i’m holding kernel updates now until I can or it is fixed.

Thanks for the tip guys.

Just been wondering, is it possible that this was the upgrade issue in the first place (not powering down).
What I mean is, could my tuners have been still on older 3.18 kernel firmware which made it malfunction with the new 4.1 kernel after I updated. If this happened perhaps a full power down might have fixed the issue with the newer kernel and not required me to regress to 3.18? As I stated earlier I usually only ever reboot, not power down, so I never tested this.
Could this be the case, or is RTL2832 definitely broken in newest kernel?

The RTL2832 works on a Linux 4.x PC? Is very curious that Linux 4 have this error and is not resolved in nexts versions, when RTL2832 is the “standard” TV tunner in linux. ¿Can be only a OSMC problem?

It looks like it is broken.

Anyway on 3.18 with all other updates done my osmc seems to freeze every day or so. Screen goes blank and a power off from power is needed to get things working again.

Has anybody holding 3.18 got similar freezing issues? It could be something else not sure.

I’m in a 3.18 (withouth other updates) and I can maintain a few days OSMC working withouth problems.

I updated to 4.x but I had some problems (I don’t have a DVB-T dongle, but I had some freezes that with 3.18 I haven’t). So I restored a pre-update backup.

yeah getting lockups here to, requiring unplug then replug

I wonder if it’s related to have the older 3.18 kernel running on an updated OSMC system.

just had to unplug again, gonna leave debug on until it happens again

Can’t think of any reason why the older kernel would cause lockups. Are you sure it’s a complete lockup and not just Kodi hanging ? Can you still ssh in ? If so please provide:

sudo journalctl | paste-log
paste-log /home/osmc/.kodi/temp/kodi.log

Not sure about nirvana, but I had instances where it was a full lockup (no ssh or ping) and other times where it was Kodi hanging. I’m gonna try 4.1.5-1 again, and rely on internet catch-up tv instead of my tuners, until kernel is fixed. Hopefully won’t have trouble with lock ups then.

I am also experiencing this issue so registering to this thread to see any updates.

Hi guys,

I’m doing “sudo apt-get install rbp1-image-3.18.13-1-osmc --reinstall” but all I’m getting is

E: Unable to locate package rbp1-image-3.18.13-1-osmc
E: Couldn’t find any package by regex ‘rbp1-image-3.18.13-1-osmc’

Any reason I’m unable to find the package? has it been moved?


This package seems to be no longer in our APT repository.

There are a couple of slightly later 3.18 kernels still there but they are probably test builds that had issues and were not intended for users.

cc @sam_nazarko

Thank DBM. Can you tell me if the issues are resolved going with 4.1.5-1?

My tuner still won’t scan on it or can you tell me where I would be able to find rbp1-image-3.18.13-1-osmc?