DVB-T local server

Hi all, i have a raspberry pi 3 B+ (2016), i also purchased MPEG-2 and VC-1 license, the os and videoplayback works great, but i want to be able to watch TV on my raspberry.
So i have a Evolveo MARS dongle and i have copied the firmware to /lib/firmware
Now the problem:
I want to connect my raspi to monitor via hdmi and use it regular tv… i dont want to stream the tv or videos over network , all tutorials are about tvheadend,GnuTV, mumudvb and so on but as far as i understand i dont need server i need only some local player capable of playing dvbt-tv …
Please help me :smiley:

Well in your setup you still will use a client/server approach even so everything happens on the same machine.
So just install tvheadend server from App Store and configure tvheadend (HTS) PVR-Addon to use localhost (127.0.0.1)

hi, could you help me to setup the tvheadend ?
when i log in i can see my adapter in TV adapters, it says Afatech AF9033 (DVB-T) #0 : DVB-T #0

than i go to networks and click on add, in first popup i select DVB-T as type , in next one i find my area in pre-defined muxes, and check the “idle scan muxers” hit apply

now back to TV apapters, click on my afatech, and in parameters check “Enabled” and in networks i choose my network…hit save

after this when i go to muxes i see two of them and both says “Scan result FAIL”

any idea what im doing wrong ? when im using the same dongle on windows am able to find like 8 tv stations and 4 radios…
are pre-defined muxes updated ? or can i get some sort of list of muxes from net and import them ?
thank you for any assist :slight_smile:

I can verify the pre defined muxes (especially in the UK) are sometimes wrong…you need to find exactly what frequencies are used in your area and double check them against the pre-defined muxes in TVHeadend.

That could be the cause of your problems.

They seem to be in a state of change quite regularly. See TVHeadend - keeping muxes up to date.

Yeah its a bit of a mess where Im living right now, the border of Suffolk and Cambridgeshire.

Ive managed to get the important muxes working, the HDTV one is the main one I use…but the one that carries Sky news seems to have died recently.
Not sure if its just a temporary thing, its been gone about a month now, but I miss Sky News and the radio station Talksport which is also on that mux.
Most of the information I can find is out of date and Im getting nothing on the frequency where it’s claimed to have been moved to.

I think I’m in a dodgy reception area, as my closest transmitter is Sandy Heath, but I receive nothing whatsoever from there…so I use Sudbury which at least gives me the HDTV channels.

See http://www.digitaluk.co.uk/operations/700mhz_clearance/clearance_events_in_2018 for some notes on retuning in your area.

What’s your antenna like?

Yeah I’ve tried using the frequencies they mention for Sudbury but im not getting anything for that Mux.

Im in a rented house atm, but I’ll only be here for a couple more months so its really not worth me messing with the aerial now…its a huge thing up in the loft and it seems strange because the other muxes I’m interested in all tune ok, just that one with Sky News/Talksport is dead.

When I move permanently I’ll assess the situation in the new house and buy a decent aerial if needed.

I managed to do a successful scan and tune in most of tv chanels provided in my area, but my dongle is just acting out (most of the times its acts like osmc cant see it or cant tune) so i bought the official osmc dongle and will report back when the post deliver it :slight_smile:

Are you sure your power supply is up to the task?

well im not sure in anything , but im powering my pi with 2A charger and used a powered usb hub… on android i used the otg Y cable and there i have to first plugin the source than connect it to tablet and than plug in the dongle …if i plug in the dongle first its not working…so im just gona trust in OSMC dongle … if its the same quality as the OS than there will be no problem with it … i just love osmc !

“chargers” are not reliable to power the Pi. So if you still have problems when you get the OSMC tuner I suggest to switch to a proper power supply as next step.

916473e510a6bc9a-300x200
BRO ! you just blown my mind!
so as i understand a charger will output power depending on demand from device (mostly for regulating battery charging ) and a power supply will output the same power all the time , oh man ! ok i have to get a power supply , problem is i already give away the evolveo dongle so i still have to wait for couple a days to test this …but man…oh man :smiley: