DVD playing failure

(This has, so far as I know, nothing to do with my earlier thread about DVDs playing back badly on the Vero 4k+.)

Some DVDs simply will not play for me on the Vero 4k+. When I select “Play disc” from the top-level menu, nothing at all happens in the UI; in the kodi.log file I get, e.g., the following:

20:32:43.258 T:4075110992   ERROR: Error on dvdnav_menu_call(Title): Unable to copy VM.
20:32:43.258 T:4075110992   ERROR: Error on dvdnav_menu_call(Root): Unable to copy VM.
20:32:43.366 T:4075110992  NOTICE: VideoPlayer: Opening: iso9660://VIDEO_TS/VIDEO_TS.IFO
20:32:43.366 T:4075110992 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
20:32:43.366 T:3439325952  NOTICE: Creating InputStream
20:32:43.455 T:3439325952   ERROR: Error on dvdnav_menu_call(Title): Unable to copy VM.
20:32:43.455 T:3439325952   ERROR: Error on dvdnav_menu_call(Root): Unable to copy VM.
20:32:43.455 T:3439325952  NOTICE: VideoPlayer: playing a file with menu's
20:32:43.455 T:3439325952  NOTICE: Creating Demuxer
20:32:43.455 T:3439325952   ERROR: Error getting next block: Encrypted or faulty DVD
20:32:43.456 T:3439325952 WARNING: could not find codec parameters for /dev/cdrom
20:32:43.456 T:3439325952 WARNING: CDVDInputStreamNavigator::GetVideoResolution - Failed to get resolution (Virtual DVD machine not started.)
20:32:43.456 T:3439325952  NOTICE: Opening stream: 1 source: 512
20:32:43.456 T:3439325952  NOTICE: Creating video codec with codec id: 0
20:32:43.457 T:3439325952   ERROR: Unsupported video codec
20:32:43.458 T:3439325952  NOTICE: CVideoPlayer::OnExit()
20:32:43.458 T:3439325952  NOTICE: VideoPlayer: eof, waiting for queues to empty
20:32:43.470 T:4075110992  NOTICE: CVideoPlayer::CloseFile()
20:32:43.470 T:4075110992  NOTICE: VideoPlayer: waiting for threads to exit
20:32:43.471 T:4075110992  NOTICE: VideoPlayer: finished waiting
20:32:43.471 T:4075110992  NOTICE: CVideoPlayer::CloseFile()
20:32:43.471 T:4075110992  NOTICE: VideoPlayer: waiting for threads to exit
20:32:43.472 T:4075110992  NOTICE: VideoPlayer: finished waiting

Any suggestions?

We’d need to see a full log with debugging enabled. Snippets aren’t very insightful.
Is the disc encrypted?

The above is everything that appears in the log from when I select “Play disc”. If you can be more specific about what debugging to enable then I’ll gladly do it. I would assume the disc is encrypted; it’s a standard commercial DVD. (Do I need to do something special to play encrypted DVDs – buy a codec licence or something?)

Merry Christmas, by the way.

Not all encrypted discs can be played back to my knowledge, as we rely on libdvdcss. But it’s important to get some more information.

We’d need a debug log. See How to submit a useful support request - General - OSMC for more information on how to do this.

Merry Christmas

OK, thanks; what I hope is a full set of logs can be found at https://paste.osmc.tv/uvotojekuv

This should represent two attempts to play the same DVD, separated by maybe 15 seconds or so. The DVD in question is a region-2 one, “Fantastic Beasts and Where to Find Them” (one of my daughter’s Christmas presents).

… If the Vero 4k+ cannot play “all encrypted discs”, why does OSMC’s advertising for it say, in so many words, " Vero 4K + : ready to handle anything you throw at it"?


Not even DVD players can play all encrypted discs: because of region coding

23:14:19.601 T:4077494864   DEBUG: libdvdread: Attempting to retrieve all CSS keys
23:14:19.601 T:4077494864   DEBUG: libdvdread: This can take a _long_ time, please be patient
23:14:19.601 T:4077494864    INFO:   msg: libdvdread: Get key for /VIDEO_TS/VIDEO_TS.VOB at 0x000209a0
23:14:19.602 T:4077494864    INFO:   msg: libdvdread: Elapsed time 0
23:14:19.602 T:4077494864    INFO:   msg: libdvdread: Get key for /VIDEO_TS/VTS_01_0.VOB at 0x000211ca
23:14:19.603 T:4077494864    INFO:   msg: libdvdread: Elapsed time 0
23:14:19.603 T:4077494864    INFO:   msg: libdvdread: Get key for /VIDEO_TS/VTS_01_1.VOB at 0x000222d4
23:14:19.603 T:4077494864    INFO:   msg: libdvdread: Elapsed time 0
23:14:19.603 T:4077494864    INFO:   msg: libdvdread: Get key for /VIDEO_TS/VTS_02_1.VOB at 0x00370865
23:14:19.604 T:4077494864    INFO:   msg: libdvdread: Error cracking CSS key for /VIDEO_TS/VTS_02_1.VOB (0x00370865)!!

The problem here is that your DVD drive is enforcing region encoding. This isn’t an OSMC issue. I believe that Matshita and some OEM DVD drives enforce this.

You should be able to set the drive to Region 2, which will do the trick. This can be done using a program called ‘regionset’.

Do you know how to use SSH?

Alternatively, you can change the region on your computer. But keep in mind that you can only change the DVD region a few times.

BTW: I have fixed the issue with some of your discs stuttering and it will be in for the next update.

Edit: I see this guy also had a similar issue and arrived to similar conclusions


(Other issue news: Awesome; thanks. What was the problem?)

Yes, I know how to use ssh. After installing regionset, running it produces the following output:

regionset version 0.1 -- reads/sets region code on DVD drives
Current Region Code settings:
RPC Phase: II
type: SET
vendor resets available: 4
user controlled changes resets available: 4
drive plays discs from region(s): 2, mask=0xFD

which unless I’m confused indicates that the drive is already set to region 2, which (at least according to the information on the DVD case) is the region of the DVD it was failing to play.

So, the drive is already set to the region of the disc but it won’t play.

The other discussion you linked to suggests that some drives may just do the Wrong Thing despite having the correct region set, though it’s not clear whether that’s an actual known problem or just conjecture. For what (probably little) it’s worth, the DVD drive is a Lite-On eTDU108-01. If it turns out that my DVD drive is rubbish, are there vendors or models known to work well?

One reason why I am skeptical about blaming this all on the DVD drive: it plays just fine when I attach the exact same drive to my laptop and use VLC.

Have you tried using the drive on a PC to play the DVD? You could also try using a tool like MakeMKV to just rip the DVD to a hard drive.

@bmillham It looks as if our replies crossed there… Yes, the very same drive with which the Vero 4k+ can’t play this DVD can play it just fine when connected instead to my laptop.

Yes, ripping the DVD seems like a possibility, but for the moment I would prefer (unless it turns out to be impossible) to make the Vero actually reliably capable of playing DVDs rather than looking for workarounds.

Yea, I noticed that you answered my question before I asked it :smiley:

You don’t happen to have another drive you could test with to help rule out if it’s a drive problem.

Did you see @sam_nazarko s edit about re-installing and updating KEYDB.cfg?

I saw his pointer to that other thread where someone talked about those things. If I understand right, keydb.cfg is specifically a Blu-Ray thing, hence not relevant to my issue, and “libdvdcss is faulty somehow” seems like a super-low-probability hypothesis and in any case I’m not sure what I should do if I wanted to reinstall it. (sudo apt-get reinstall if I thought the file had become corrupted somehow, but again surely that’s super-unlikely; sudo apt-get upgrade to get a newer version, but I’d worry about upgrading bits of the system by hand. I’m imagining scenarios where e.g. OSMC’s usual upgrade process always upgrades X together with Y, and then something checks what version you’ve got by checking the version of X, but I’ve upgraded X without Y and so the assumptions it’s making break and disaster ensues…)

Doing the reinstall is safe as apt takes into account package dependencies. So it’s worth giving that a try.

KEYDB is indeed for Blu ray disks

@gjm11: do you have an encrypted DVD that’s Region 2 that does play?

What’s the year of the titles that don’t play?


@bmillham I wasn’t concerned that apt would get confused – as you say, it handles dependencies automatically – but that other stuff layered on top of it might expect that X and Y always get updated together even though neither actually depends on the other.

@sam_nazarko The one that just failed to play was released in the last couple of years. When first experimenting with the Vero 4k+ I think I encountered a somewhat earlier DVD that wouldn’t play, and I think I then found that on a later occasion it did play, which is a bit odd – but stupidly I didn’t make a note of it and I might be wrong. I can do some experiments. I’m not sure what the best way is to determine whether a DVD is encrypted; I’ll try playing back with debug logging turned on and looking at the messages in the logfile.

… OK, this is distinctly strange. I’ve just tried to play a disc that has played before, with no obvious problems, on the Vero 4k+ with the same external DVD drive. (It’s disc 5 of season 5 of The West Wing, released somewhere around 2004.) And it’s now failing in what looks like a very similar way. (libdvdread tries to crack a bunch of CSS keys; some succeed but several fail; some INFO messages saying “can’t seek to block 3454576” which may or may not be relevant; and an ERROR message saying “Error getting next block: Encrypted or faulty DVD”. And no playback. The same happens with at least one other disc that played OK before.

So it seems like something has changed; maybe I should try upgrading/reinstalling packages. So, doing sudo apt-get upgrade libdvdread gives me a chiding message saying that that can cause instability and I should use dist-upgrade instead. Looks like my concerns above were well founded! Doing a dist-upgrade upgrades only libssl, which surely can’t be relevant here.

However, I’m having trouble figuring out which packages might be relevant. dpkg -l doesn’t seem to turn up any DVD-related things other than regionset, which I installed in order to check my DVD player’s region setting. There are virtual packages libdvdcss and libdvdcss2 but the former doesn’t seem to be provided by any real package and the latter seems to be provided only by libdvd-pkg, which so far as I can tell is not installed. But I’m not a Debian expert and may well be confused. If reinstalling things seems like a good idea, could someone advise me on the best way to proceed? Thanks.

Can you back up the DVD as an ISO on your PC?

If you keep it encrypted and OSMC can play it, it rules out an OSMC issue and suggests something is up with the drive.

Unfortunately my laptop has chosen today to turn into a brick. However, my wife has a laptop with a DVD drive built in; I’ll give that a go. (But, yet again, I have had no trouble playing any of these DVDs with the exact same drive when connected to anything other than the Vero 4k+.)

I haven’t attempted to reinstall anything. However, things are now failing in a different (but no more useful, so far as I can see) way.

I copied the bits off the “Fantastic Beasts” DVD mentioned in my original report into an ISO file and checked that this plays OK with VLC on the FreeBSD box I copied it onto. I set up an NFS server on that box. I told the Vero to use that as a source of video files in two different ways, one with a nfs: path and the other by mounting the thing by hand and pointing at the local mount point. I am getting the same behaviour from the DVD itself via the USB drive and from both NFS-mounted versions of the ISO.

What happens is this: I select “Play disc” from the top-level menu. A short Warner Brothers intro plays (their logo and Jingle). Then a black screen plus what I’m fairly sure is the audio that would accompany the DVD’s main menu, in a loop a couple of minutes long. After several repeats the audio goes quiet. No picture ever appears.

If I turn on the “Attempt to skip introduction before DVD menu” option (note: that was on before, if it makes a difference to the interpretation of what I reported) then instead – again there’s no difference between the three ways of getting the bits – that same DVD-menu audio plays in a loop while at the top right of the screen there appear the word DVD and a timer counting up from 0:17 to 2:06. When it reaches 2:06 it starts counting again from zero but without the “/2:06” that had been there before and the audio fades out and doesn’t return. This time counts up well beyond 2:96 if I let it. No picture at any point.

The logs now don’t appear to have any mention of CSS key-cracking, either successful or unsuccessful. I’ve uploaded some at https://paste.osmc.tv/wolocexivo. If memory serves, the sequence here is: reboot after turning on logging; attempt to play from DVD (this time it’s in do-absolutely-nothing mode, I don’t know why); attempt to play over NFS (behaviour as described above); attempt to play from DVD (does absolutely nothing again); turn off “Attempt to support introduction…”; attempt to play from DVD (does absolutely nothing again).

The inconsistency is puzzling. Anyway, the Vero will not play this DVD any more willingly from the ISO than from the drive, even though sometimes but not always the exact symptoms differ a bit.

Do you still have hardware acceleration disabled?

If there is no libdvdcss message then you likely decrypted the disc when you backed it up.

Try play the feature rather than the menu

Yes, hw accel still disabled for SD content. The copying process was as simple as dd if=/dev/cd0 of=DVD.iso bs=2048 – could that really have decrypted anything?

How do I “play the feature rather than the menu”?