DVD playing failure


#21

Which device did you dd from?

Cheers

Sam


#23

/dev/cd0 on a FreeBSD 11 box (with its own internal DVD drive). To be clear, this wasn’t directly on the Vero and didn’t use the same DVD drive as I’ve failed to play DVDs on the Vero with.


#24

OK – thanks for clarifying, that’s what I wanted to know.
I know some DVD menus can be problematic; but if you play the TS file directly directly, it should work

Sam


#25

Forgive my dimness: how would I do that? I had a look at the output of the mnt command and a quick look through the filesystem, and don’t see any place where any of the files “inside” the DVD are visible to the Vero.


#26

I think that if you select the ISO it should let you browse in to it.

At least such is the case with BD ISOs.

I will try and obtain the disc to test this

Sam


#27

Does that assume I have the ISO ripped from the DVD?

Is there any prospect of there being any way to make the Vero 4k+ be able to play ordinary DVDs reliably, or is that simply not an intended use case?

(I’m happy to rip things for diagnostic purposes, but I’m really hoping to end up with something that is capable of playing DVDs. Please do let me know if that’s an unreasonable expectation.)


#28

Hi,

Vero 4K + should already be able to play DVDs (as other users do so).
I’m trying to work out what’s not working for you here. This is meant to be a test; rather than a workaround or fix.

Cheers

Sam


#29

OK, good to know that there’s some prospect of success in the end.

Selecting Videos > Files > my NFS source > the ISO file, hitting the menu button and selecting “Browse into” does indeed give me a VIDEO_TS directory containing what look like typical DVD contents.

Then clicking on VIDEO_TS.IFO gives the same results as playing the disc; clicking instead on VIDEO_TS.VOB seems to try to play something 16 seconds long at something like 16x speed – so far as I can tell from the indicator at top right. It doesn’t pay any actual video. Picking one of the other VOBs instead – typical name VTS_01_1.VOB – does the same “counter at top right, no video actually plays” thing; some audio does play but it’s scrambled. I guess maybe this is the result of un-cracked copy protection?

If any of this sounds like the sort of thing it would is be useful to have logs, or more details, of then let me know.


#32

Yes — some logs will be helpful.

In a few days I’ll get a dvd drive from the loft and try a disc lying around and check a few things

Sam


#38

OK, here are some log files – though not, as it happens, for the same failure mode I just described. This is from a DVD containing two TV episodes, the first of which plays without difficulty while the second fails. The actions represented in the log file are: boot up, play disc (at this point an anti-piracy notice plays, followed by a brief BBC jingle, and then we get the top-level DVD menu), select “Part Two” (leading to a scene-selection menu), select first scene – at which point I get dumped out to the main Kodi interface. Result is the same with either hardware or software decoding. I think this DVD is not copy-protected.

(It’s one of a boxed set of BBC versions of Agatha Christie mysteries, this one being “A pocketful of rye”; I think the DVD set is from 2005. Region 2.)

https://paste.osmc.tv/boyelusane


#39

There are some discussions on Kodi-related fora that include the last error message I see in kodi.log (ERROR: Got MSGQ_ABORT or MSGO_IS_ERROR return true) such as this one https://forum.kodi.tv/showthread.php?tid=318621 – but I can’t find any that ever received a useful response…

I’m aware that there may be multiple independent issues here, and I’m sorry to be intermingling them if so. What they all have in common is that they are making DVD playback impossible for me…


#40

Now some logs from the other thing.

What I did: enable logging; reboot; “Videos” from main menu; “Files”; select the “nfs://” source; highlight the ISO file; click menu button and select “Browse into”; select (the only option) VIDEO_TS; select VIDEO_TS.VOB (it shows something at top right for a few seconds suggesting it’s trying to play something, but there’s neither audio nor video); maybe a minute later, select VTS_01_1.VOB (counter at top right counting towards 20:33, scrambled audio); stop by pressing “square” button on remote; upload logs.

https://paste.osmc.tv/emubacuvah


#41

Let me know if anything else it would be useful to have logs of.

Some of the misbehaviour I’m seeing is inconsistent from one occasion to the next. E.g., earlier today my wife tried to play a DVD and reported that Kodi crashed completely with a solid-orange screen (and when I returned home I found the screen still orange and the Kodi entirely unresponsive to the remote; regrettably I was an idiot and didn’t try ssh’ing into it or even pinging it) – but when I then tried to play the same DVD it failed, but in a different way (played DreamWorks intro Jingle thing, then black screen with scrolling “Playback failed” message at top right, after a few seconds of which the top-level Kodi UI returned). Incidentally, immediately before the failure “ERROR: Got MSGQ_ABORT or MSGO_IS_ERROR return true” appears in kodi.log – same message as in at least one of the other cases I just described.

The inconsistency seems suggestive of some sort of hardware flakiness, maybe?


#42

How is the drive powered? It’s odd that you are the only user experiencing these seemingly random, not always repeatable, isssues.


#43

Drive is powered with a small powered USB hub. This was admittedly the cheapest powered USB hub I could find (more precisely, the cheapest I could find from a manufacturer I’d heard of as opposed to one of those six-random-letters ones that clog all Amazon search results pages); perhaps it’s defective. I think my employer has an inline USB voltage-and-current meter, which I will try to see if anything obviously bad is happening.

(I did try putting a multimeter across the GND and VCC pins of the USB port on the hub, but as soon as I contacted the VCC pin the Vero crashed, which doesn’t fill me with confidence about the hub.)


#44

I do agree that the lack of repeatability is odd. As to whether I’m the only person experiencing the issues, who knows? Maybe few Vero users are trying to use external DVD drives rather than streaming media services, local media servers, etc. Maybe other people are suffering in silence. Someone else just recently posted about having a stuttering problem similar to the one I reported (though using software decoding does seem to be an effective workaround, and Sam mentioned – earlier in this very thread, I think – that there should be a proper fix in the next release). So not all of my problems are entirely unique to me…


#45

There are literally dozens of you, I’m sure. :wink:


#46

Well, quite.


#47

Must admit that I downloaded a few DVDs for my dad for xmas. He still likes the format for some reason.
I too tried to play a couple of the ISO files and got exactly the experience posted. I just put it down to ISO issues burnt the DVDs tried them on his DVD player and they played fine.
I’ve watched rather than posted as my playback was NAS NFS share and after burning I deleted the files.
Relatively Kodi newcomer also no need for DVDs personally. Plus source was newsgroup not disc.


#48

So here’s a question: is there anyone reading this who uses a Vero 4k+ to play ordinary commercial DVDs and finds that it consistently works correctly – so that you can pull a DVD off the shelf, put it in the drive, and be confident that the Vero will play it properly?