DVD playing failure


See Autoplay problem with BR DVD USB player

Might help.
When time allows I will look in to this in more detail



Maybe I’m being dim, but that looks to me like an entirely different sort of problem. Are you suggesting that the config tweak described there might make some of the problems I’m reporting go away?


I would try it, yes. Otherwise I’ll need to revisit this with v18


OK, created .kodi/userdata/advancedsettings.xml containing the suggested content and tried again to play a DVD that gave grief before. Nothing seems different. Logs at https://paste.osmc.tv/yexaseliqo.

If there’s really good reason to think this is a hardware problem, I don’t at all mind replacing my DVD drive or getting a less-cheapo powered hub or whatever. But I’m reluctant to do that if it might turn out that the Vero hardware and/or software shouldn’t be expected to be able to play DVDs reliably.


I can’t talk about watching Physical DVD and having a DVD Drive connected but I have watched well over 100 DVDs ( in file structure or .iso ) on my vero 4k and they all played fine…But I have also seen some people saying that some of their DVDs don’t play after they ripped the content of the physical disc and tried to play from HDD.


That’s encouraging. My DVDs are all still DVDs and the only one I’ve ripped behaved exactly the same after ripping as when it as a physical disc – but I’m suspecting I have multiple different problems. Some of them seem like de-CSS-ing failures, which is what worries me – that seems like the kind of thing that might just never be going to work if it doesn’t now…


I wonder whether it’s possible to get some clarity on what sort of thing is likely to be wrong here. Let me ask some specific questions.

Frequently, when I try to play a DVD, kodi.log (with debug logging enabled) contains a number of libdvdread messages about key cracking: on one typical example it seems to succeed for VIDEO_TS.VOB, VTS_01_0.VOB, and VTS_01_1.VOB, and then fail for VTS_02_0.VOB and all subsequent vobs. After this, there are messages saying “Can’t seek to block 3638808”, “Invalid IFO for title 4 (VTS_04_0.IFO)”, “ifoOpenVTSI failed”, and – this last one is the first of type ERROR – “Error getting next block: Encrypted or faulty DVD”. On the face of it, this looks like a software problem, and it seems like it should be solvable either (a) by buying whatever licences are required to use the disc or (b) by actually cracking the keys. I understand that (a) might not be possible for silly commercial reasons, but surely (b) is a very solved problem these days. So:

1. Am I right in thinking that the symptoms above indicate that the Vero needs to crack some CSS keys but is failing to do so?

2. Given that I can successfully retrieve all those CSS keys from the exact same DVD in the exact same drive using VLC on my FreeBSD box, and that when I tried copying the bits off a DVD into an ISO file the Vero had the exact same problems with this file as with the DVD, am I right in thinking that this is unlikely to be a hardware problem and should in principle be solvable?

3. Does anyone reading this have any idea what the underlying problem is likely to be?

4. Is an inability to play DVDs reliably regarded by the OSMC team as a problem that ought to be resolved?

And, I guess,

5. Is there anyone reading this who has tried playing several ordinary commercial DVDs using a Vero 4k+ and found that it consistently succeeds in playing them properly?

I keep being told that my experience is weird and unusual, which might suggest a hardware problem. But, again, the Vero seems to be having very pure-software-looking problems that don’t occur using the same DVD drive using different software. And so far no one in this thread seems to have reported success when doing the same things that fail for me. There’s one person playing DVD images, ripped in some unspecified fashion, without problems; and one person who’s found plain ISO images from DVDs and had the same problem as me.

Perhaps playing physical DVDs is such a weird minority thing these days that I can’t reasonably expect it to be supported. That’s a bit hard to believe; surely I can’t be the only person with a few shelves of DVDs. But maybe it is, in which case it would be nice to know. (And then I can buy some more hard drives, spend a few weeks ripping DVDs, and turn my FreeBSD box into a media server, or throw the Vero in the bin and buy something that is better at playing DVDs, or something.)


It does look like software here; not hardware. Particularly as you don’t appear to experience other symptoms.

The next few days are going to be tricky but this is on the list and I will test with a Region 2 DVD shortly and feedback. Things should still work as expected – but you never know…

We’ll work it out – don’t worry. It’s not forgotten and you won’t need to chuck the Vero in a bin :slight_smile:



Looks like it was forgotten after all.

Should I give up?


I’ll actually be setting this up myself in the next few days. I’ll be happy to report what I see with a 4K+ and external Blu-Ray setup


Not forgotten. It’s resolved in Kodi v18. Once that is released the problem should be solved



I also have played a DVD using an external player attached via USB to my Vero a while ago and it played fine. Will check other dvd’s tomorrow evening.


Cool! What turned out to be the underlying problem?


Just push MPEG2 to SW only < 576p
This can be backported to v17 but no point now.


Wait, are we talking about the same problem here? I had a different earlier issue that was addressed by switching to SW decoding, but this thread was about something quite different – total failure to play many DVDs, with symptoms suggestive of a CSS-key-finding problem. If you tell me that’s fixed by using software decoding then I’ll take your word for it (at least until I can try it out for myself and check) but if so then I’m very confused. (Which I totally might be…)


Will have some betas for v18 shortly, are you willing to try them and feed back so I can hopefully get things all wrapped up for final?

There were a couple of issues, hopefully both fixed.




My apologies for the very slow response. If it’s not too late to be useful: yes, I am very willing to try out beta software and see whether and how it helps with the troubles I’ve had.


Cool — keep an eye out for an imminent test thread


So, I upgraded to what I believe to be the latest v18 version and can report that at least one DVD that had been failing to play now appears to play correctly.


Glad to hear this.

Let us know if things don’t work…