DVD stutter


I’ve been using a Vero 4k+ for a few months now. The firmware is up to date.

I can play files from a NAS in any resolution and framerate without problems. But my DVD collection is stored as ISO images, and those I can’t play in good quality:

First problem was that there were huge stuttering issues. Every second or so, the frame seems to “skip a beat”.

I played around with the “auto change framerate” settings. If anything, that made it worse: When playing a region 2 DVD image (24 fps) and setting the output to “auto”, the TV changed to that format, but not only was the picture still stuttering, but now there were also video/audio sync issues - the longer the ISO played, the farther away audio drifted from the video.

So I went back to fixed framerate (I set it to 60Hz since most of my DVDs are R1) but deactivated hardware decoding for SD resolutions. This helped a lot with the sync issues, and the stuttering returned to the “drop a frame a second” state. Still not enjoyable, though.

Some funny facts:

  • I’m seeing the same problems with DVDs that are R1 and R2, NTSC and PAL, 24 and 30 frames. The stuttering seems to be no different at all. Also, it doesn’t matter in the least bit how the output is set - the stuttering is the same whether the TV is set to 50Hz or 60Hz.

  • I’m also using a Amazon FireTV (Gen. 1) that is running the same version of Kodi. On this device, I can play the ISOs without stuttering or sync issues on the same TV. On the FireTV, switching of framerate is not supported in the first place and it was never required for decent playback either.

All this - and some previous threads - suggest that there is a basic problem with the Vero when it comes to DVDs and/or MPEG2. It seems to be completly unrelated to how the output equipment is set.

Can anyone suggest a way to get to the bottom of this?


Some logs would help here, with Adjust Refresh Rate enables.


You should have this option enabled. Set it to Start / Stop for best results.

With the option enabled, there are audio/video sync issues. Disable it, and at least there is only the stuttering.

I have the option on start/stop and don’t have any stutter nor audio/video sync issue.
So it must be an issue either with your settings or the ripped ISO.
How is your Audio setup looking like?
Upload debug logs with Adjust refresh Rate start/stop set as @sam_nazarko advised

Ok, forget everything I wrote above:

I’m now playing an ISO of a R1 DVD. The video is 720x480 at 29.97 fps (according to OSMC’s info display.) There’s stutter.

My TV is set to 60 Hz 1080p. Why should there be stuttering?

We really need logs to have an idea what is going on.

Ok: I’ve uploaded logs, URL is as follows:

[via PM]
edit: @sam_nazarko: I can’t figure out how to send you a PM. Can you help me?

Description: I played a R2 DVD (25 fps). The TV switched to 50 Hz. There was massive stutter in the playback.


Is there a reason you can’t post the log publicly? I’ve hidden your last post revision as the log was visible there

Thank you; yes, I didn’t realize it was not just the log since the last restart, but everything. I don’t want to make that public (local file server paths, viewing history, server names, possibly user names…)

That’s why I was so reluctant to create logs in the first place.

It won’t show any passwords or personally identifiable data.

You can send it by PM but it will limit the number of eyes that can see the log to just me, which isn’t ideal…


Can I limit the logs? For example, it seems like the issue here is just the MPEG2 decoder. Does this have its own log I could send? And can I limit the range to “since last restart”, instead of “everything I have”?

Just reboot the system to limit log output and exclude Kodi old log.

Or: reboot twice, reproduce problem, upload logs


Doesn’t work here as you describe.

Do you have a email address? This forum system is horrible!

I’m currently on holiday – so limited access to things like email.
You can raise a support ticket via My Account.

You should just be able to type the link here. Can you elaborate on what problems you’re experiencing?

Four times out of five, when i try to write a message, the browser hangs when it says “saving” and I have to do it again. In the edit boxes, there is no cursor. I can’t find a way to PM you at all. In a word, it sucks! :frowning:

I’ll try opening a ticket, thanks.

I would suggest trying another browser or device to write the message.


To send a PM, you’d just click on a user’s name and press ‘Send Message’/

Have you tried updating the browser? The forum software is very intuitive to use and runs buttery smooth here

No logs, no help!

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

1 Like