Emulator how-to?

#1

Hello,

I have a 4K+ and upgraded to the April update yesterday. I’ve been searching for a how-to on game emulators for Kodi 18. Here’s what I have done:

  • I have an 8bitdo N30Pro Bluetooth controller that I was able to pair by going into the OSMC program plugin. After I paired the controller, a pop-up came up for me to “map” my controller to existing controller profiles. I wasn’t sure what I was doing at that point so I mapped a NES controller and that’s it. I have no idea how to trigger that pop-up again to initiate other controller mappings.

  • I reviewed a post in the Testing section that showed certain cores that work well. Specifically I was looking at the NES section and turned on QuickNES (enabled the addon).

  • I did some searches and found the Internet Archive Game Launcher (IAGL) addon. I installed the addon, and started up a NES file. I was able to launch, and start one of them (Super Mario Bros). However, after a few seconds of playing I got the sad face. To be specific, I hit a power up (mushroom) and right after that I got the sad face. I was able to reproduce this behavior.

  • I started experimenting with other NES cores. None of the other cores would even load the file.

Am I going down the right path here? Apologies for no logs since I’m at work here but I’d like to hear what other people’s experiences are. Should I not use IAGL, are there other alternatives?

Thanks.

1 Like
#2

I’ve not tried IAGL myself, but i will try it on my pi3 since my vero4k is on gmc-19 builds, and report back my findings.

#3

Thanks. How are you running your emulators on the Vero if not using IAGL? I’m open to all suggestions, IAGL seemed like the only option.

#4

On the vero i’m using locally stored roms and just adding the folder as a source under games,

Add games…

But IAGL, I got Super Mario Bros. working at least to level 1.2 then i thought it stable enough on my PI3. Will try on the Vero later.

#5

I’m definitely missing something. I don’t have Games section, even with default OSMC skin. Tried customizing home menu and can’t find the Games option either.

#6

Have you tried “Restore menu items” under skin customization menu? It should be there.

1 Like
#7

Restore worked and I was able to see the Games menu item. That being said I think I need to unzip the files to work.

I’ve been going down the path of IAGL still and tried to create a log. When I tried to upload the log file, I got “URL:https://paste.osmc.tv/”. Is there a bug there?

I was able to play a few SNES games so that was good news.

#8

Update: maybe I never tried but FCEUmm NES core worked for Super Mario Brothers while the rest didn’t. Snex9X is working well for SNES.

#9

Feel free to add your results here

#10

I also didn’t have the games menu item, so was also installing IAGL, but after pointing the games add on to my USB stick in the Pi, it saw the roms and games played well, now just need a good controller. Having problems with DS4, DS3 seems to work best, but mine are not in best conditions.

#11

Are you loading them in zip or did you unzip the files?

I’d also like to hear back from folks that are using Vero to see if platform makes a difference.

#12

They have to be unzipped. I tried zipped and it did not work. But since i unzipped them they all work fine.

#13

I have had mixed results, IAGL would give unahppy face blue screen on certain cores (sega megadrive), oddly enough loading any sega MD game from my rom file also causes a reboot within 30 secs. GB + GBC work well though

#14

Looks like there is a way to load them in zip format:

https://forum.kodi.tv/showthread.php?tid=287826

I will try that tonight and report back.

#15

I would certainly like to avoid IAGL if I can since I have all the ROMs locally. What are you guys using? I was going to spend the weekend investigating AEL.

#16

I am now using the built in Games tab and pointing it to my usb, and have enabled a few emulators in my installed addons.

#17

I’m as i said using locally stored ROMs, unzipped, to not have to change the .zip association in kodi. And most emulators don’t work with VFS(zip, network shares).

#18

Every combination I’ve tried either results in a sad face or occasionally a “addon is incompatible due to unmet dependancies missing game.controller”

#19

Yeah you got to add controller mappings for each emulator, some need multiple controllers.

Settings->Add-on browser->Install from repository->Kodi Add-on repository->Game add-ons->Controller profiles

An add those needed for the emulator in question.

1 Like
#20

Added every single controller And working ty