Enable Menu Customisation does nothing

#1

I used to be able to change the home menu, but now when attempting to select this option nothing happens.

It doesn’t take me to this screen anymore (this is not my screen cap, I took it from a different thread):

#2

It doesn’t download the required addons?

Some debug logs might help us to see what’s what

2 Likes
#3

https://paste.osmc.tv/ocomepajok

#4

Thank you! It looks like all needed addons are correctly installed. Could you be so kind and post a screenshot of the addons section of the skin settings?

#5
1 Like
#6

The skin helper backgrounds addon has to be enabled. See the disabled note in the addons section of the skin settings.

But you pointed me to a bug: there should be a dialog telling you that the addon has to be enabled for home menu customization to work. :+1:t2:

EDIT: I fixed the issue - the customization can be used without the Skin Helper Backgrounds script now. The fix will be available in the next update. Thanks for the hint! :slightly_smiling_face:

#7

I can’t find it to enable it.

#8

It’s a hidden addon which doesn’t show up in the addons browser. Some addons do this - don’t ask me why.

It’s probably best to update to staging via these instructions to use the skin without the Skin Helper Backgrounds script:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

#10

Will this fix itself in the next auto update or do I need to do this manual fix?
I’d prefer to just wait and get the fix on an official\stable build.

#11

It will fix itself in the next update.

#12

It appears that my Vero took an update but I’m still getting the same error and “Enable menu customisation” doesn’t work.
Skin Helper Service Backgrounds still shows up as disabled.

#13
#14

There hasn’t been a regular, stable update recently… :thinking: The fix is only available on the staging repo as of now. And I don’t think you’ve updated to staging, have you?

#15

Please post some logs

1 Like
#17

Sam, I did a few posts up.

Chillbo, okay, I’ll keep waiting.

#18

Just stumbled over this topic and see you’re using user profiles.
What happens if you logout and re-login as master user?

#19

In that log we can see that you’re not on the staging repo. Therefore you can’t have received any update that contains this fix. Nothing to worry about :+1:t2:

#23

Same thing happens either profile.
I put my children’s profile under the default Kodi skin so I can turn menu items on and off since the OSMC is broken for me at the moment.

#24

So I got the funny idea to try switching my Master user skin to Estuary and then switch it back to OSMC and see if that does anything.
So I switched to Estuary and I got an error message saying “Skin Sortcuts - Unable to build menu. Install Kodi Log Uploader add=on to easily provide a debug log”, then I select OK (there’s no other option) and it reverts me back to the OSMC skin.

#25

I downloaded the ZIP from here: https://kodi.tv/addon/libraries/skin-helper-service-backgrounds and installed it manually since I couldn’t find in the repository.
It installed but fine but error persists.
Here’s a new log: https://paste.osmc.tv/zuhosohoji