Enable wifi (connman)


Does anyone know of alternate download location to downloaded connman? Index of /debian jessie/main connman armhf 1.21-1.2+deb8u1

Seems to end with the install failing due to a broken pipe.



First what are you trying to do? Not so sure about the title of your thread and the explanation of your problem?
Where did you get that link from? On OSMC connman is provided by the package armv7-connman-osmc

Not sure where I found the link now although, none of the tutorials I found on those forums have help either. The problem with me finding that link started out with me trying to not get wifi by default under OSMC. In Raspbian Jessie it took me a while to figure out the solution for the problem. In that case I had to change my NBN connection from 5.0 ghz to 2.4 ghz then using wpa_passphase to configure the wpa_supplicant.

What’s wrong with just disabling the adapter in MyOSMC?

It doesn’t become more clear what you are trying to achieve. Generally all wifi tasks can be done directly from the GUI via MyOSMC. All other stuff you can do on the command line as mentioned connman is the default network manager for OSMC and comes preinstalled.

The problem is that the wifi doesn’t show up in the settings under “My OSMC”.

I can only suggest you back up your kodi settings and re-install the latest OSMC release. If you have tried to install connman from another source, your device will be in an unknown state.

I used the OSMC-installer to download and install OSMC! No, I have only tried with the default sources or the default install of connman that comes from the install download. I have the same problem of the wifi settings not appearing in the “network” settings even after multiple attempts at trying to configure wifi. The only settings that appear in that section are “MySQL” and “Wired”.

If you don’t have “wifi” menu entry means your wifi dongle is physically not detected or no drivers are available for it. Suggest you start with telling which dongle you are using and provide the output of dmesg | paste-log

The problem is that I am using the Raspberry Pi 3 in-built wifi chip no dongle.

It would have helped if you had mentioned this initially! It could be a problem with your power supply. Or many things. Logs would help.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.

That’s not a problem but part of the solution :wink:
Provide full logs via grab-logs -A


Dec 23 23:38:07 osmc-Tobias kernel: mmc-bcm2835 3f300000.mmc: no support for card's volts
Dec 23 23:38:07 osmc-Tobias kernel: mmc1: error -22 whilst initialising SDIO card
Dec 23 23:38:07 osmc-Tobias kernel: mmc1: Got command interrupt 0x00030000 even though no command operation was in progress.
Dec 23 23:38:07 osmc-Tobias kernel: mmc1: Got command interrupt 0x00030000 even though no command operation was in progress.
Dec 23 23:38:07 osmc-Tobias kernel: random: fast init done

Are we back to the issue we already discussed here?

Well, I am not totally sure the interfaces mentioned before were the problem but rather wpa_supplicant.conf needed configuring. However, OSMC does not use this file and I can not figure out where I would check the interfaces either because OSMC does not contain raspi-config.


After I try to enable wifi using connman I receive the following error:

Error: wifi: Method “Set Property” with signature “sv” on interface “net.connman.Technology” does not exist.

It looks like you have a hardware issue. I would suggest that you try a different power supply, and a new SD card to begin with.

The specs for both of the power supplies are:

3000ma 5.2v

2.5a 5.1v

both power supplies are official Raspberry Pi power supplies (raspberry on the plug).

Just FYI: Raspberry Pi have never produced a 3A 5.2V PSU.


Ah, well, I will triple check what is written on the power supplies and I found this video which hopefully lead to a more actuate reading.

Raspberry Pi - How to check your power supplys voltage - YouTube

If the power supply is OK, then the next step would be the SD card.