Error during upgrade


Today I was going to upgrade my Raspberry Pi 3B+ with the new OSMC version with Kodi 19. At first I wasn’t able to start the upgrade from MyOSMC, but found a hotfix in another post that solved that issue. The upgrade started, but after a while I got an error. The error was just showed for 30 seconds and I didn’t reach to take a photo of it. But it said something about mediacenter couldn’t be installed. And after that it just went into a loop showing the sad face on the blue background.

I then tried to start the upgrade from command line with the following command:

sudo apt-get update && sudo apt-get dist-upgrade

But then it stopped with the following error:

Unpacking rbp2-mediacenter-osmc (19.1.0-14) over (18.9.0-4) …
dpkg: error processing archive /var/cache/apt/archives/rbp2-mediacenter-osmc_19.1.0-14_armhf.deb (–unpack):
trying to overwrite ‘/usr/share/kodi/addons/visualization.spectrum/addon.xml’, which is also in package kodi-visualization-spectrum:armhf 1.1.1-1
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

What should I do?

Got it sorted following this post: