Error installing: rpb-userland-osmc (1.9.0-1) on latest update

When trying to do the update I see the following error, which I can replicate via apt-get ssh.

I’ve bolded the error. I’ve tried cleaning the archive to remove previously downloaded versions, and re-downloaded but get the same error.

osmc@osmc:/var/cache/apt/archives$ sudo apt-get dist-upgrade -f
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
Calculating upgrade... The following packages were automatically installed and aSetting up libpam-modules-bin (1.1.8-3.1+deb8u2+rpi1) ...
(Reading database ... 51240 files and directories currently installed.)
Preparing to unpack .../libpam-modules_1.1.8-3.1+deb8u2+rpi1_armhf.deb ...
Unpacking libpam-modules:armhf (1.1.8-3.1+deb8u2+rpi1) over (1.1.8-3.1+deb8u2) ...
Setting up libpam-modules:armhf (1.1.8-3.1+deb8u2+rpi1) ...
(Reading database ... 51240 files and directories currently installed.)
**Preparing to unpack .../rbp-userland-osmc_1.9.0-1_armhf.deb ...**
**Unpacking rbp-userland-osmc (1.9.0-1) over (1.7.0-1) ...**
**dpkg: error processing archive /var/cache/apt/archives/rbp-userland-osmc_1.9.0-1_armhf.deb (--unpack):**
 trying to overwrite '/usr/share/alsa/cards/JustBoomDigi.conf', which is also in package libasound2-data 1.0.28-1+rpi2
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Preparing to unpack .../libevent-2.0-5_2.0.21-stable-2+deb8u1_armhf.deb ...
Unpacking libevent-2.0-5:armhf (2.0.21-stable-2+deb8u1) over (2.0.21-stable-2) ...
Preparing to unpack .../libpam-runtime_1.1.8-3.1+deb8u2+rpi1_all.deb ...
Unpacking libpam-runtime (1.1.8-3.1+deb8u2+rpi1) over (1.1.8-3.1+deb8u2) ...
Processing triggers for libc-bin (2.19-18+deb8u7) ...
Errors were encountered while processing:
 /var/cache/apt/archives/rbp-userland-osmc_1.9.0-1_armhf.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Is this on a Pi 1 or Pi2/3?

Also upload full logs so I can see sources

I suspect it’s a Pi 1, and that JustBoom cards are now supported in Raspbian via the libasound2-data package. We share a common userland for Pi0/1/2/3, but Pi2/Pi3 are based on Debian Jessie which do not package this file. This makes the situation a little complicated. However, if this is the case we simply cannot package this file for now.

I have exactly the same problem in a raspberry pi 3 with the Krypton update

Please post a full log so I can fix this.

There you go http://paste.osmc.io/fexedivaci

Thanks sam

Apt logs, ironically the ones you didn’t provide, are important to what we are looking for here.

Just upload all logs

Sorry, there is the log with more info http://paste.osmc.io/guyezinedo

Getting same error here. Pi3 upgraded to Krypton.

The only thing “different” that I may have installed is emulation Stattion (Retrosmc - [HowTo] RetroPie and OSMC: Retrosmc - Retrogaming on OSMC - #12 by mcobit) with the program addon shat starts Emulation Station from within Kodi …

When doing “sudo apt-get dist-upgrade”, I get the following:

Reading package lists… Done
Building dependency tree
Reading state information… Done
You might want to run ‘apt-get -f install’ to correct these.
The following packages have unmet dependencies:
rbp-userland-dev-osmc : Depends: rbp-userland-osmc (= 1.9.0-1) but 1.7.0-1 is installed
E: Unmet dependencies. Try using -f.

Did you add additional repositories? If this was conflicting with OSMC’s userland I would expect more reports. I see:


# Enable audio (added by raspberrypi-sys-mods)
sdtv_aspect=1  
dtparam=gpio_in_pin=18  
dtparam=gpio_out_pin=17  

which is in your config.txt. This is not something that is part of OSMC.

You also have:


Start-Date: 2016-11-11  21:56:01
Commandline: /usr/bin/apt-get-real install -y --no-install-recommends bluetooth pi-bluetooth raspberrypi-sys-mods
Install: raspberrypi-sys-mods:armhf (20161018+3), bluez-firmware:armhf (1.2-3+rpi1, automatic), pi-bluetooth:armhf (0.1.1), bluetooth:armhf (5.23-2+rpi2)
End-Date: 2016-11-11  21:56:14

This is strange, because OSMC has its own Bluetooth packages and installing those packages will actually cause problems. It seems like you may have installed packages that are not intended for OSMC.

Sorry, I’ve yet to pull my logs, but I too have Retropie installed in the same way that mariuslr has.

From time to time I’ve also done command-line updates to Retropie as shown here

There is also an option to update the kernel (can’t remember the exact language as not by Pi atm) but I’ve never selected that option, assuming it would overlap with OSMCs build.

I don’t think this has something to do with retropie. I don’t have those problems on multiple machines.
Please post logs so we can see what’s going on.

Yes in my case I did, but I have retropie installed also, so it could be related to the retropie installation its a common factor

Do you use a bluetooth gamepad or installed stuff from retropie to make one work?

Only USB gamepads for me

So please still upload full logs.
This is the only way to diagnose the problem.

Only USB game controller for me as well for RetroPie (wireless). I realize now that I also installed “motion” (webcam software) on OSMC. Might that cause issues maybe?

where can I find out how to get and upload the log files as I would like to help resolve this issue … ok, no problem - found the answer elsewhere on the forum …

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/