Error on update

I went to use osmc and it showed that there was an update error and to report it on the forums. It appeared hung so I rebooted. Now, after the initial OSMC logo it’s just shows a blank screen and never gets to the Kodi interface.

I’m able to get on SSH still, here’s the logs if it helps:


Not sure if this will help but its worth a shot, being as you have ssh access.

sudo apt-get update
sudo apt-get dist-upgrade

Report the result here, there maybe missing packages/updates which should be installed or error messages.

Also what model pi is it 2 or 3?

Thanks Tom.

Kodi seems to stop when reading the file Textures13.db, so this file might have become corrupted.

In SSH run this command:

mv /home/osmc/.kodi/userdata/Database/Textures13.db ~

This will move the file to your home directory (/home/osmc) so you still have the option to move it back. Then run:

sudo systemctl restart mediacenter

It’s a raspberry pi 2, here’s the results:

osmc@PIBed:~$ sudo apt-get update
Ign jessie InRelease
Hit jessie-updates InRelease
Hit jessie/updates InRelease
Hit jessie InRelease
Hit jessie Release.gpg
Hit jessie Release
Get:1 jessie-updates/main armhf Packages/DiffIndex [8392 B]
Hit jessie-updates/contrib armhf Packages
Get:2 jessie-updates/non-free armhf Packages/DiffIndex [736 B]
Hit jessie-updates/contrib Translation-en
Get:3 jessie-updates/main Translation-en/DiffIndex [3196 B]
Get:4 jessie-updates/non-free Translation-en/DiffIndex [736 B]
Hit jessie/updates/main armhf Packages
Hit jessie/updates/contrib armhf Packages
Hit jessie/updates/non-free armhf Packages
Hit jessie/updates/contrib Translation-en
Hit jessie/updates/main Translation-en
Get:5 jessie/main armhf Packages/DiffIndex [2023 B]
Hit jessie/updates/non-free Translation-en
Hit jessie/main armhf Packages
Hit jessie/contrib armhf Packages
Hit jessie/non-free armhf Packages
Hit jessie/contrib Translation-en
Hit jessie/main Translation-en
Hit jessie/non-free Translation-en
Ign jessie/main Translation-en
Fetched 15.1 kB in 18s (837 B/s)
Reading package lists... Done
osmc@PIBed:~$ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... The following packages were automatically installed and are no longer required:
  apt-transport-https armv7-libafpclient-osmc libass5 libbluray1
  libgssapi3-heimdal libheimntlm0-heimdal libkdc2-heimdal module-init-tools
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.



I ran both commands, but no difference from what I can tell.


Could you provide a bit more information about what you mean? Output from running the commands would be useful.

It’s still showing a blank screen, there was no output from running the commands through ssh which suggests they executed without issue. Here’s the latest logs, though it doesn’t appear to progress past the Textures13.db again:



Just to rule out your kodi configuration hasn’t become corrupted:

mv /home/osmc/.kodi /home/osmc/kodi.bak
sudo systemctl restart mediacenter

If the result is the same, you can revert by reversing the first step.

Thanks Tom.

Something looks to be a bit borked on your installation, possibly with the Kodi configuration.

Let’s try this:

sudo systemctl stop mediacenter
mv .kodi kodibak
sudo systemctl start mediacenter
osmc@PIBed:~$ cd
osmc@PIBed:~$ sudo systemctl stop mediacenter
osmc@PIBed:~$ mv .kodi kodibak
osmc@PIBed:~$ sudo systemctl start mediacenter

Progress has been made, it’s now getting into the kodi interface. Though I’ve lost all my configuration, I guess I need to try copying over pieces of it from the backup and see if it breaks?

EDIT, I just checked my other Pi (3) with OSMC on it, it has the exact same install error - “Error Installing: Please report this on the OSMC forum.” They both point back to the same MySQL video and music db. It would appear this is causing the issue, as when I cp the advancedsettings.xml from the kodibak, it won’t start. Any advice would be appreciated., I’d rather avoid having to recreate my video and music db.


I think you’ve updated from pre Krypton. See Kodi Krypton FAQ and Support

Hi Sam,

I’ve been running both Pi’s on Krypton without issue since osmc was first updated with it, which has been quite some months now.


@JinXD: are you using a shared MySQL database? If so, it’s possible that your shared DB got corrupted.

Yes it’s a share MySQL database, I guess I’ll just have to start it again from scratch :confused:

Is the DB housed on one of the Pi’s, or elsewhere? You could use the mysql command line interface to check the DB.

It’s on my NAS, so not on either of the Pi’s. I may have to remind myself how to check on the db :slight_smile:

You could try rebooting the NAS (if you haven’t tried that yet). It may do a check on the DB on boot.

From the Pi, you should be able to use the mysql command to try and connect to the DB. (Google is your friend :wink: )

I should have thought to do that earlier, but bouncing the NAS has resolved the issue. Thank you sir!

Good to hear! Your Welcome! :smiley: