Error2: share not available pi 3

got windows 10 on a homegroup, when i go into my pi 3 through osmc and try to add files it gives me “error2: share not available” before anything pop up

Use IP addresses, not hostnames.

okay, how do i add an IP address?

so what do i enter for share, browse, and how do i find the shared folder address? im guessing the name of the server is my desktop IP

IP address would be the IP of the Windows system with the shares.

on my LAN router my desktop IP is my pi is
so use
also i dont think i can ping my pi on my LAN

If you can’t ping the Pi on you LAN, you have another problem. Try pinging it from the Windows system.

thats where i was doing the pinging from lol i think my router could be a problem
i will try pinging it again

okay i just pinged with 0% packet loss so thats not the problem

Logs would be helpful then:

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.

my pi isnt connected to the internet, how do i get a log with no internet.also i tried the SAMBA again this morning and i got an error again i got “error2: share not available” and then when i went to “Browse”- ://smb i got anther error like “connection not available”

Do i have to install SMB ontop of OSMC?
Also another dumb question, when i power down the pi how do i power it back up again? just unplug and plug back in? thank you for your time


How is your pi connected to the router?

Does your pi have an IP?

Thanks Tom.

umm wirelessly i guess? my pi does have an ip, when i go into my router settings and it shows connected devices, my pi shows up


Whats is the pi’s ip

If its showing up on the router, it should have internet access.

If you try to upload logs, what happens?

Thanks Tom.

should i restart my desktop after i create the homegroup?
well the router isnt connected to the internet
the ip is
i tether my phone to my desktop for internet
i havent tried to upload logs yet


Ok that makes sense. You could try restarting the desktop.

You probably need to set your phone us as a wifi hotspot and connect the pi to that, to upload the logs then.

Thanks Tom.

okay before i fly blind, what will happen when i upload a log? will it upload to a database? will it give me a file i have to upload myself?

All the details are in the link bmilham provided, anyway it will provide you a link, which you need to post in this topic.

Thanks Tom.

okay i read that link, also how will i be able to replicate the error (i honestly think i am just setting something up wrong here) if i am connected to a different network. it says i can get a link without internet but i dont know how to bring up the command prompt in osmc to type -grab -logs -A

You should be able to hit [esc] on the keyboard during the initial boot to get to the command line.